Blätter in Zelle anzeigen

Bild

Betrifft: Blätter in Zelle anzeigen
von: erriso
Geschrieben am: 22.04.2005 09:02:35
Hallo!
Ich würde gerne alle erstellten Blätter in einer Tabelle automatisch anzeigen.
Für Excel 97 ging das mit einer Formel - in 2003 funtioniert die aber nicht. Ich hatte das mit Eurer Hilfe so gelöst: =WENN(ISTFEHLER(INDIREKT(A12&"!$P$15"));"";INDIREKT(A12&"!$P$15"))
Für Hilfen wäre ich sehr Dankbar
Grüße erriso

Bild

Betrifft: AW: Blätter in Zelle anzeigen
von: Andre
Geschrieben am: 22.04.2005 09:20:12
Hallo Erriso
probier mal folgenden Code
'nur ein Schnellschuß als Ansatz (Listet alle Tabellenblattnamen in Spalte B)


Sub blattnamen()
Dim i As Integer
For i = 1 To Sheets.Count
    Cells(i, 2).Value = Sheets(i).Name
Next
End Sub

Gruß Andre
Bild

Betrifft: AW: Blätter in Zelle anzeigen
von: erriso
Geschrieben am: 22.04.2005 09:35:06
... ich bin leider zu dumm für VBA - wie muss ich das denn machen? :-)
Bild

Betrifft: AW: Blätter in Zelle anzeigen
von: Andre
Geschrieben am: 22.04.2005 11:10:32
Drücke ALT+F11 dann kopiere diesen Code in das Tabellenblatt1

Sub blattnamen()
Dim i As Integer
For i = 1 To Sheets.Count
    Cells(i, 2).Value = Sheets(i).Name
Next
End Sub

und dann Makro starten fertig!
Bild

Betrifft: AW: Blätter in Zelle anzeigen
von: ingoG
Geschrieben am: 22.04.2005 09:41:46
Hallo zusammen,
oder als function()
Gruß Ingo ;-)

Function Blattname(Nr As Integer) As String
Application.Volatile
If Nr < 1 Or Nr > ThisWorkbook.Sheets.Count Then
  Blattname = ""
Else
  Blattname = ThisWorkbook.Sheets(Nr).Name
End If
End Function

 Bild

Beiträge aus den Excel-Beispielen zum Thema "Blätter in Zelle anzeigen"