Herbers Excel-Forum - das Archiv

SV funktioniert plötzlich nicht mehr

Bild

Betrifft: SV funktioniert plötzlich nicht mehr
von: Claudia

Geschrieben am: 20.12.2006 09:04:09
Ich habe mir ein nettes Makro gemacht welches einen SVerweis durchführt. Es hat auch immer tadellos funktioniert. Plötzlich sind aber Fehler drinnen. Warum?
Hier die Tabellen
die "Ursprungsdatei"

1. Korrektur 2. Korrektur wahre Note
C1-100-2-2-2=2 2 2 2.00
C1-101-2-2=2 2 2 2.00
C1-102-1.5-1.5-2=1.67 1.5 1.5 1.50
C1-103-1.5-1.5=1.5 1.5 1.5 1.50
C1-104-2-2=2 2 2 2.00
C1-105-1-1=1 1 1 1.00
C1-106-1.5-1.5=1.5 1.5 1.5 1.50
C1-107-2-2=2 2 2 2.00
C1-108-2-2=2 2 2 2.00
C1-109-2-2=2 2 2 2.00
C1-110-2-2=2 2 2 2.00
C1-111-1.5-1.5=1.5 1.5 1.5 1.50
die Datei mit dem Verweis
1. Korrektur 2. Korrektur wahre Note
C1-100-2-2-2=2.txt 2.00 2.00 2.00
C1-101-2-2=2.txt 2.00 2.00 2.00
C1-102-1,5-2-1,5=1,67.txt 1.00 2.00 2.00
C1-103-1,5-1,5=1,5.txt 1.50 1.50 1.50
C1-104-2-2=2.txt 2.00 2.00 2.00
C1-105-1-1=1.txt 1.00 1.00 1.00
C1-106-1,5-1,5=1,5.txt 1.00 1.00 1.00
C1-107-2-2=2.txt 2.00 2.00 2.00
C1-108-2-2=2.txt 2.00 2.00 2.00
C1-109-2-2=2.txt 2.00 2.00 2.00
C1-110-2-2=2.txt 2.00 2.00 2.00
C1-111-1,5-1,5=1,5.txt 2.00 2.00 2.00

Folgende Formel ist zB in der Zelle B4: =SVERWEIS("'Noten C1'!";'Noten C1'!$A$2:$D$26;2;WAHR) als Ergebnis kommt 2 obwohl es 1,5 sein sollte.
Die Ursprungstabelle ist sortiert.
Was muss ich vor und nach der Tabelle eingeben, damit sie richtig dargestellt wird?
Gleich mal Danke für Eure Beiträge!
Lg, Claudia
Bild

Betrifft: AW: SV funktioniert plötzlich nicht mehr
von: Rudi Maintaire

Geschrieben am: 20.12.2006 09:25:26
Hallo,
das kann gar nicht sein.
=SVERWEIS("'Noten C1'!";'Noten C1'!$A$2:$D$26;2;WAHR)
Die Formel ist mit Sicherheit falsch, da nur Noten C1! als Kriterium gar nicht geht. Außerdem würde ich anstatt WAHR immer FALSCH nehmen.
Gruß
Rudi
Eine Kuh macht Muh, viele Kühe machen Mühe
Bild

Betrifft: AW: SV funktioniert plötzlich nicht mehr
von: jockel

Geschrieben am: 20.12.2006 09:41:54
hi Rudi, die datei kannst du dir hier ansehen...: http://phorum.excelhost.de/read.php?11,108705,108706#msg-108706 und den ursprungsthread: http://phorum.excelhost.de/read.php?11,108342,108342#msg-108342 ... ich hatte damals ausgeklingt
cu jörg
Bild

Betrifft: AW: SV funktioniert plötzlich nicht mehr
von: Claudia
Geschrieben am: 20.12.2006 09:45:13
Hallo Jörg,
es hat damals dann schon tadellos funktioniert! nur bei diesem Datensatz funktioniert es plötzlich nicht mehr.
Lg, Claudia
Bild

Betrifft: AW: SV funktioniert plötzlich nicht mehr
von: Claudia

Geschrieben am: 20.12.2006 09:42:49
ups da ist das A4 beim kopieren einfach verschwunden. hier nochmal die Formel welche in meiner Zelle steht
=SVERWEIS(A4;'Noten C1'!$A$2:$D$26;2;WAHR)
Es bezieht sich auf das Registerblatt Noten C1, Zellen A2 bis D26 und das stimmt eigentlich.
Wahr habe ich deswegen, da ich eine Annäherung brauche. Manchmal heißen die Dateien nämlich auch folgendermaßen:
C1-100-2-2-2=2.txt___1.txt
C1-101-2-2=2.txt___1.txt
C1-102-1,5-2-1,5=1,67.txt___1.txt
C1-103-1,5-1,5=1,5.txt___1.txt
C1-104-2-2=2.txt___1.txt
C1-105-1-1=1.txt___1.txt
C1-106-1,5-1,5=1,5.txt___1.txt
C1-107-2-2=2.txt___1.txt
C1-108-2-2=2.txt___1.txt
C1-109-2-2=2.txt___1.txt
C1-110-2-2=2.txt___1.txt
C1-111-1,5-1,5=1,5.txt___1.txt
Lg, Claudia
Bild

Betrifft: AW: SV funktioniert plötzlich nicht mehr
von: Claudia

Geschrieben am: 20.12.2006 14:11:31
Sollte noch jemand interessiert sein, hier ist die Lösung/das Problem:
Ich hatte bei der Ursprungsdatei und bei der Zieldatei unterschiedliche Formate: einmal als Komma einen Punkt und beim anderen einen Beistrich - und das bringt auch einen "funktionierenden Verweis" zum scheitern...
Danke an alle die für die Lösung mitgerätselt haben...
Lg und noch einen produktiven Tag wünscht Claudia
 Bild