Live-Forum - Die aktuellen Beiträge
Anzeige
Anzeige
HERBERS
Excel-Forum (Archiv)
20+ Jahre Excel-Kompetenz: Von Anwendern, für Anwender
Inhaltsverzeichnis

AutoFill funktioniert nicht mehr

AutoFill funktioniert nicht mehr
26.11.2008 10:44:00
Anna
Hallo
schon oft habe ich die AutoFill-Methode benutzt und immer lief es einwandfrei, doch auf einmal bekomme ich immer eine Fehlermeldung
"Laufzeitfehler '1004': Die AutoFill-Methode des Range-Objektes konnte nicht ausgeführt werden."
Ich hab schon alles ausprobiert, deswegen glaube ich nicht, dass es an der Syntax liegt:
Range(Cells(a, "A"), Cells(a, "B")).AutoFill Destination:=Range(Cells(a + 1, "A"), Cells(a + 1, "B")), _Type:=xlFillDefault
Es geht auch nicht, wenn ich den Range-Bereich mit Range("A1:B1") usw. angebe.
Vielen Dank schonmal im Voraus!

1
Beitrag zum Forumthread
Beitrag zu diesem Forumthread

Betreff
Datum
Anwender
Anzeige
AW: AutoFill funktioniert nicht mehr
26.11.2008 14:20:17
fcs
Hallo Anna,
bei der Autofill-Methode müssen scheinbar die Quellzellen mit im Destination-Bereich enthalten sein.
Gruß
Franz
P.S.: Die Angabe der Spalte in "Cells" mit Buchstaben ist nicht unbedingt guter Programmierstil. Besser mit Zahlen arbeiten.

a = ActiveCell.Row
Range(Cells(a, 1), Cells(a, 2)).AutoFill _
Destination:=Range(Cells(a, 1), Cells(a + 1, 2)), Type:=xlFillDefault
' oder
Range(Cells(a, "A"), Cells(a, "B")).AutoFill _
Destination:=Range(Cells(a, "A"), Cells(a + 1, "B")), Type:=xlFillDefault


Anzeige

328 Forumthreads zu ähnlichen Themen

Anzeige
Anzeige
Anzeige

Beliebteste Forumthreads (12 Monate)

Anzeige

Beliebteste Forumthreads (12 Monate)

Anzeige
Anzeige
Anzeige