Microsoft Excel

Herbers Excel/VBA-Archiv

Spalten vergleichen mit Leerzeichen

Betrifft: Spalten vergleichen mit Leerzeichen von: Schüle
Geschrieben am: 17.06.2008 12:59:19

Hallo Zusammen,

habe eine Spalte A die ich mit einer Spalte B vergleichen möchte. Alle Werte sind einmalig aber in Spalte B nicht alle vorhanden. Sobald ein Wert in B nicht vorhanden ist, möchte ich in Spalte C eine "1" stehen haben. Habe es mit dieser Formel gelöst:

=WENN(ZÄHLENWENN(E:E;B2);1;"")

jetzt kommt aber mein Problem. In Spalte A und B sind bei manchen Texten noch Leerzeichen hintendran. Die werden dann von der Formel nicht erkannt.

Was kann ich tun, damit nur der tatsächliche Text verglichen wird?

  

Betrifft: AW: Spalten vergleichen mit Leerzeichen von: Rudi Maintaire
Geschrieben am: 17.06.2008 13:35:24

Hallo,
Hilfsspalten: =Glätten(A2) bzw =Glätten(B2) und diese vergleichen.

Gruß
Rudi


  

Betrifft: AW: Spalten vergleichen mit Leerzeichen von: Schüle
Geschrieben am: 17.06.2008 14:37:23

Hallo Rudi,

vielen Dank für die Hilfe. Hat wunderbar geklappt!!

LG
Reinhard


 

Beiträge aus den Excel-Beispielen zum Thema "Spalten vergleichen mit Leerzeichen"