Microsoft Excel

Herbers Excel/VBA-Archiv

Sverweis; variabler Tabellenname | Herbers Excel-Forum


Betrifft: Sverweis; variabler Tabellenname von: Snewi
Geschrieben am: 10.12.2009 11:50:22

Hallo,

ich habe einen Sverweis und möchte aber den Tabellenname über ein Optionsfeld auswählen können!
Das heisst ich habe 2 Tabellen (Tabelle1 und Tabelle2)! Dann habe ich 2 optionsfelder die ich mit einer Zelle verknüpft habe! Jetzt sollen abhängig der Zelle und der Optionsauswahl die Daten über den Sverweis aus der jeweiligen Tabelle angezeigt werden!

Wie mache ich das?

SVERWEIS(A1;Tabelle1!$A:$C;1;0))
SVERWEIS(A1;Tabelle2!$A:$C;1;0))

Gruß

  

Betrifft: mit INDIREKT von: Björn B.
Geschrieben am: 10.12.2009 11:58:23

Hallo,

=SVERWEIS(A1;INDIREKT(D1&"!$A:$C";1);1;0)

in D1 muss Dein Tabellenname stehen.

Gruß
Björn B.


  

Betrifft: AW: mit INDIREKT von: Snewi
Geschrieben am: 10.12.2009 12:38:19

Das klappt irgendwie nicht "NV wird ausgegeben! Muss ich beim Tabellennamen was beachten?

Gruß


  

Betrifft: AW: mit INDIREKT von: {Boris}
Geschrieben am: 10.12.2009 12:57:25

Hi,

da Du von Optionsbuttons sprichst, werden die Rückgabewerte in der verknüpften Zelle sicherlich 1 und 2 sein - und das sind natürlich keine Blattnamen.


=SVERWEIS(A1;INDIREKT("'Tabelle"&D1&"'!A:C";1);1;0)

Grüße Boris


  

Betrifft: AW: mit INDIREKT von: Björn B.
Geschrieben am: 10.12.2009 13:06:25

Hallo,

ich sagte ja auch, dass in D1 der Tabellenname stehen muss, nicht irgendeine Nummer.
Was steht denn da bei Dir?

Gruß
Björn B.


  

Betrifft: AW: mit INDIREKT von: Snewi
Geschrieben am: 10.12.2009 13:11:11

Ich habe über =WENN(A1=1;"Tabelle1";"Tabelle2") oder geht das so nicht?
Hab dann einfach die Zelle wo die Ausgabe der Tabelle angegeben ist in den Sverweis gepackt!

Gruß


  

Betrifft: AW: mit INDIREKT von: Björn B.
Geschrieben am: 10.12.2009 13:15:40

Wenn du es richtig geschrieben hast, dann funktioniert es.

Was passiert denn, wenn du die Tabelle fix eingibst? Findet SVERWEIS dann was?

Also ich habe meine Formel getestet und grad nochmal geprüft, die stimmt und funktioniert.

Lad doch mal die Datei hoch, das ist bestimmt irgendwo ein kleiner Tippfehler.

Gruß
Björn B.


  

Betrifft: AW: mit INDIREKT von: Snewi
Geschrieben am: 10.12.2009 13:30:32

https://www.herber.de/bbs/user/66483.xls


  

Betrifft: Den Suchbegriff gibt´s nicht oT von: {Boris}
Geschrieben am: 10.12.2009 13:33:22

...


  

Betrifft: AW: mit INDIREKT von: Björn B.
Geschrieben am: 10.12.2009 13:40:52

Hallo,

wie Boris schon richtig bemerkt hat, Du suchst nach etwas, das es nicht gibt.
Du suchst nach 1001, diesen Wert gibt es in Tabelle PRD nicht.
Deshalb kommt #NV.

Der #BEZUG-Fehler kommt daher, dass Du bei F3 die Dollarzeichen vergessen hast und nach unten kopiert hast.
Formel muss so aussehen:
=SVERWEIS(A12;INDIREKT($F$3&"!$A:$D";1);1;0)

Dann kommt bei den Werten, die gefunden werden auch ein Ergebnis.

GRuß
Björn B.