Microsoft Excel

Herbers Excel/VBA-Archiv

Zählenwenn nicht null und leere zellen

Betrifft: Zählenwenn nicht null und leere zellen von: Katharina
Geschrieben am: 09.09.2014 10:29:53

Guten Morgen,

ich möchte in Excel die Anzahl berechnen. Nun habe ich jedoch auch eine 0 mit drinnen und leere Zellen, die ich nicht zählen möchte. Hinzu kommt, dass ich minuszahlen zählen möchte.
Nun lautet meine Funktion wie folgt
=ZÄHLENWENN(M12:M137;">0")+ZÄHLENWENN(M139:M205;">0")+ZÄHLENWENN(M12:M137;"<0")+ZÄHLENWENN(M139:M205;"<0").

Mein Problem ist jetzt, dass ich unterschiedliche Jahre habe und bei einigen Jahren stimmt das Ergebnis,bei 2 Jahren jedoch nicht.
Weiß vielleicht jemand woran das liegen könnte?

Grüße
Katarina

  

Betrifft: AW: Zählenwenn nicht null und leere zellen von: Rudi Maintaire
Geschrieben am: 09.09.2014 11:16:32

Hallo,
als Anregung:

ABC
21 6
32  
43  
50  
60  
7-3  
8   
9   
104  
11-5  

ZelleFormel
C2=ANZAHL(A2:A11)-ZÄHLENWENN(A2:A11;0)


Gruß
Rudi


 

Beiträge aus den Excel-Beispielen zum Thema "Zählenwenn nicht null und leere zellen"