Datum in Tabelle finden

Bild

Betrifft: Datum in Tabelle finden
von: WinterMensch
Geschrieben am: 06.08.2015 09:45:18

Hallo,
Ich habe ein Problem mit meiner Tabelle.
Und zwar stehen in Spalte "Buchungstag" meiner Tabelle Tabelle1 Datumswerte.
Ich würde nun gerne neben die Tabelle die Zeile mit dem heutigen Datum kopieren.
Aber falls das heutige Datum nicht in der Tabelle eingetragen ist, dann soll die Zeile mit dem am wenigsten zurückliegensten Datum (also gestern oder vorgestern oder...) genommen werden.
Meine Tabelle ist nach Datum sortiert falls das irgendwie hilft.
Ich bedanke schon einmal für die Hilfe :)

Bild

Betrifft: AW: Datum in Tabelle finden
von: Bernd
Geschrieben am: 06.08.2015 09:48:20
Hi,
und wie sieht Deine Tabelle aus?
mfg Bernd

Bild

Betrifft: AW: Datum in Tabelle finden
von: Conelius
Geschrieben am: 06.08.2015 09:56:29
Oh da ist wohl etwas schief gelaufen.
Hier ein Screenshot:
Userbild

Bild

Betrifft: AW: Datum in Tabelle finden
von: WinterMensch
Geschrieben am: 06.08.2015 09:59:16
Hallo,
Es ist wie eine Kontoübersicht.
Ich habe 4 Spalten.
In der ersten stehen die Datumsangaben (Buchungstag). In der zweiten bis jetzt noch nichts (Art).
In der dritten steht der Betrag. Und in der vierten Spalte ist der entsprechende Kontostand.

Bild

Betrifft: AW: Datum in Tabelle finden
von: Bernd
Geschrieben am: 06.08.2015 10:11:45
Hallo Unbekannter ohne Namen!
also ohne Beispielmappe, wie exakt was aufgebaut und formatiert ist, wirst Du nur sehr schwer wen finden, der Dir weiter helfen kann/wird.
z.B.: "dann soll die Zeile mit dem am wenigsten zurückliegensten Datum " von wo bis wo geht die Zeile?
Wo sind ältere Datumswerte eingetragen in welchem Bezug eingetragen usw.
mfg Bernd

Bild

Betrifft: AW: Datum in Tabelle finden
von: WinterMensch
Geschrieben am: 06.08.2015 10:00:31
Ich wollte eigentlich auf diese Nachricht antworten. Deshalb nun noch einmal:
Es ist wie eine Kontoübersicht.
Ich habe 4 Spalten.
In der ersten stehen die Datumsangaben (Buchungstag). In der zweiten bis jetzt noch nichts (Art).
In der dritten steht der Betrag. Und in der vierten Spalte ist der entsprechende Kontostand.

Bild

Betrifft: AW: Datum in Tabelle finden
von: hary
Geschrieben am: 06.08.2015 10:35:46
Moin
Versteh nicht was du moechtest. Dein Bild und die Beschreibung sagen mir nix.



Tabelle1

 ABCDE
101.08.2015 SucheErgebniss 
202.08.2015 06.08.201502.08.2015Datum
312.08.2015  2Zeile
409.08.2015    
510.08.2015    

verwendete Formeln
Zelle Formel Bereich R1C1 für Add In
C2=HEUTE()  =TODAY()
D2=INDEX(A1:A5;VERGLEICH(C2;A1:A5;1))  =INDEX(R[-1]C[-3]:R[3]C[-3],MATCH(RC[-1],R[-1]C[-3]:R[3]C[-3],1))
D3=VERGLEICH(C2;A1:A5;1)  =MATCH(R[-1]C[-1],R[-2]C[-3]:R[2]C[-3],1)

http://excel-inn.de/dateien/vba_beispiele/tabellenanzeige_in_html_addin.zip
http://hajo-excel.de/tools.htm
XHTML-Tabelle zur Darstellung in Foren, einschl. der neuen Funktionen ab Version 2007
Add-In-Version 14.02 einschl 64 Bit

grus hary

Bild

Betrifft: zu wenig Infos !
von: Matthias L
Geschrieben am: 06.08.2015 10:37:24
Hallo Namenloser
Dann müsste es je immer der letzte Datensatz sein, den Du kopieren willst
Wenn Du einen Buchungstag hast kann der ja nicht in der Zukunft liegen, oder?
Sieht die Tabelle also so aus, was soll jetzt wohlin?

 ABCD
1DatumArtBetragStand
216.12.2014 200 
305.03.2015 300 
402.06.2015 200 
519.07.2015 300 
605.08.2015 250 


Excel Tabellen im Web darstellen >> Excel Jeanie HTML 4
Gruß Matthias

Bild

Betrifft: AW: zu wenig Infos !
von: WinterMensch
Geschrieben am: 06.08.2015 11:04:38
Hallo,
Vielen Dank für alle Antworten.
Ich glaube ich habe das Problem nicht gut genug beschrieben. Das tut mir Leid. Wahrscheinlich wäre dadurch Schreibarbeit erspart geblieben.
Ich habe jetzt eine Beispielmappe angehangen in der die Tabelle ist. Dabei ist auch ein Textfeld wo hoffentlich alles genau erklärt ist.
https://www.herber.de/bbs/user/99362.xlsx

Bild

Betrifft: {=MAX(WENN(B3:B395<=HEUTE();B3:B395))}
von: Matthias L
Geschrieben am: 06.08.2015 11:17:16
Hallo

 IJKL
13BuchungstagArt Betrag Stand
1431.07.2015   

Formeln der Tabelle
ZelleFormel
I14{=MAX(WENN(B3:B395<=HEUTE();B3:B395))}
Enthält Matrixformel:
Umrandende
{ } nicht miteingeben,
sondern Formel mit STRG+SHIFT+RETURN abschließen!


Excel Tabellen im Web darstellen >> Excel Jeanie HTML 4
Gruß Matthias

Bild

Betrifft: AW: {=MAX(WENN(B3:B395<=HEUTE();B3:B395))}
von: WinterMensch
Geschrieben am: 06.08.2015 11:29:22
Super, das funktioniert.
Ich habe nur B3:B395 durch Tabelle1[Buchungstag] ersetzt da die Tabelle erweiterbar sein soll.
Vielen Dank nochmal an alle die geholfen haben und insbesondere Matthias :)

Bild

Betrifft: Der Rest mit SVerweis ...
von: Matthias L
Geschrieben am: 06.08.2015 11:29:26
Hallo

 IJKL
13BuchungstagArt Betrag Stand
1406.08.20150-50001197,29

Formeln der Tabelle
ZelleFormel
I14{=MAX(WENN(B3:B396<=HEUTE();B3:B396))}
J14=SVERWEIS($I$14;$B$3:$F$396;SPALTE()-8;0)
K14=SVERWEIS($I$14;$B$3:$F$395;SPALTE()-8;0)
L14=SVERWEIS($I$14;$B$3:$F$395;SPALTE()-8;0)
Enthält Matrixformel:
Umrandende
{ } nicht miteingeben,
sondern Formel mit STRG+SHIFT+RETURN abschließen!


Excel Tabellen im Web darstellen >> Excel Jeanie HTML 4
Gruß Matthias

Bild

Betrifft: AW: Der Rest mit SVerweis ...
von: WinterMensch
Geschrieben am: 06.08.2015 14:19:13
Genau, danke :)

 Bild

Beiträge aus den Excel-Beispielen zum Thema "Datum in Tabelle finden"