Microsoft Excel

Herbers Excel/VBA-Archiv

Datumsanzeige mit KW in Tabelle die 2.

Betrifft: Datumsanzeige mit KW in Tabelle die 2. von: Benjamin
Geschrieben am: 02.10.2020 07:14:49

Hallo, ich konnte Krankheitsbedingt leider nicht mehr auf meinen alten Beitrag antworten. Der Thread ist nun im Archiv gelandet. Die Lösung die ich zuletzt bekommen habe für KW53 funktioniert leider immer noch nicht. Habe jetzt alles so eingegeben wie Beschrieben. Wäre toll, wenn da noch mal jemand drüber gucken könnte. In KW01 sind andere Formeln als in KW00 bzw. KW53. Ich poste einfach noch mal beides.

 =Übersicht!B3 ist nun =Übersicht!E2 (Das Jahr) aber ansonsten ist alles gleich geblieben
Alter Thread: https://www.herber.de/forum/cgi-bin/callthread.pl?index=1783244#1783244
 Datumsanzeige mit KW in Tabelle


KW53:
Arbeitsblatt mit dem Namen '00'
 ABCDEFGHIJKLMNOPQRSTUVWX
1 Leiter  Gruppe      Jahr2020
2 Woche                 Monat 
3                    Woche 
4                        
5   01Mo  02Di  #######           
6 NameVornameStun
den
Anwes.
X / E / K
Hausaufg.
J/N
Früher abgeholt
um:
StundenAnwes.
X / E / K
Hausaufg.
J/N
Früher abgeholt
um:
StundenAnwes.
X / E / K
Hausaufg.
J/N
Früher abgeholt
um:
StundenAnwes.
X / E / K
Hausaufg.
J/N
Früher abgeholt
um:
StundenAnwes.
X / E / K
Hausaufg.
J/N
Früher abgeholt
um:
 
71                       
82                       

ZelleFormel
W1=Übersicht!E2
W2=D5
W3=WENNFEHLER(KALENDERWOCHE(W2;21);"")
D5=7*KÜRZEN((2&-1&-W1)/7+W3)-5
E5=D5
H5=D5+1
I5=H5
L5=P5-1
M5=L5
P5=WENNFEHLER(WENN(JAHR(T5-1)=$W1;T5-1;"");"")
Q5=P5
T5=WENN(JAHR('01'!D5-3)=W1;'01'!D5-3;"")
U5=T5
B7=Übersicht!D8
C7=Übersicht!E8
B8=Übersicht!D9
C8=Übersicht!E9
Verwendete Systemkomponenten: [Windows (32-bit) NT :.00] MS Excel 2016
Diese Tabelle wurde mit Tab2Html (v2.6.0) erstellt. ©Gerd alias Bamberg


KW01:
Arbeitsblatt mit dem Namen '01'
 ABCDEFGHIJKLMNOPQRSTUVWX
1 Leiter  Gruppe      Jahr2020
2 Woche                 MonatJanuar
3                    Woche01
4                        
5   30Mo  31Di  01Mi  05Do  06Fr   
6 NameVornameStun
den
Anwes.
X / E / K
Hausaufg.
J/N
Früher abgeholt
um:
StundenAnwes.
X / E / K
Hausaufg.
J/N
Früher abgeholt
um:
StundenAnwes.
X / E / K
Hausaufg.
J/N
Früher abgeholt
um:
StundenAnwes.
X / E / K
Hausaufg.
J/N
Früher abgeholt
um:
StundenAnwes.
X / E / K
Hausaufg.
J/N
Früher abgeholt
um:
 
71                       
82                       

ZelleFormel
W1=Übersicht!E2
W2=T5
W3=TEXT(TEIL(ZELLE("Dateiname";$A$1);FINDEN("]";ZELLE("Dateiname";$A$1))+1;31)+0;"00")
D5=7*KÜRZEN((2&-1&-W1)/7+W3)-5
E5=D5
H5=D5+1
I5=H5
L5=H5+1
M5=L5
P5=WENNFEHLER(WENN(JAHR(T5-1)=$W1;T5-1;"");"")
Q5=P5
T5=P5+1
U5=T5
B7=Übersicht!D8
C7=Übersicht!E8
B8=Übersicht!D9
C8=Übersicht!E9
Verwendete Systemkomponenten: [Windows (32-bit) NT :.00] MS Excel 2016
Diese Tabelle wurde mit Tab2Html (v2.6.0) erstellt. ©Gerd alias Bamberg


So sollte ich das eingeben für KW00 bzw. KW53
https://www. _
herber.de/forum/cgi-bin/callthread.pl?index=1783244#1783305


Betrifft: AW: es war schon aufgezeigt ...
von: neopa C
Geschrieben am: 02.10.2020 10:14:43

Hallo Benjamin,

... aber offensichtlich möchtest Du, dass in W1 nicht das Jahr angezeigt wird, um das es in der Arbeitsmappe geht (nämlich 2021) sondern passend zur KW des Vorjahres, wenn Januartage des Jahres (2021) zu dieser Vojahres-KW gehören.

Dann eben in W1 dieses Tabellenblattes = =Übersicht!B3-1
Dann aber in T5: =WENN(JAHR('01'!D5-3)=W1+1;'01'!D5-3;"")
und in P5: =WENNFEHLER(WENN(JAHR(T5-1)=$W1+1;T5-1;"");"")

und diese nach links kopieren.

In W2 bleibt dann aber weiter =T5 also Januar stehen, wenn dies in T5 so ermittelt wird, weil es ja um das Jahr 2021 geht.

Gruß Werner
.. , - ...

Betrifft: AW: es war schon aufgezeigt ...
von: Benjamin
Geschrieben am: 02.10.2020 12:54:54

Egal was ich eingebe, die Felder bleiben bei mir einfach weiss.
Bin ich zu doof um irgendwelche Formeln einzugeben?

Arbeitsblatt mit dem Namen '01'
 ABCDEFGHIJKLMNOPQRSTUVWX
1 Leiter  Gruppe      Jahr2019
2 Woche                 Monat 
3                    Woche01
4                        
5    Mo       ###           
6 NameVornameStun
den
Anwes.
X / E / K
Hausaufg.
J/N
Früher abgeholt
um:
StundenAnwes.
X / E / K
Hausaufg.
J/N
Früher abgeholt
um:
StundenAnwes.
X / E / K
Hausaufg.
J/N
Früher abgeholt
um:
StundenAnwes.
X / E / K
Hausaufg.
J/N
Früher abgeholt
um:
StundenAnwes.
X / E / K
Hausaufg.
J/N
Früher abgeholt
um:
 
71                       
82                       
93                       
104                       
115                       

ZelleFormel
W1=Übersicht!B3-1
W2=D5
W3=TEXT(TEIL(ZELLE("Dateiname";$A$1);FINDEN("]";ZELLE("Dateiname";$A$1))+1;31)+0;"00")
D5=WENNFEHLER(WENN(JAHR(T5-1)=$W1+1;T5-1;"");"")
E5=D5
H5=WENNFEHLER(WENN(JAHR(T5-1)=$W1+1;T5-1;"");"")
I5=H5
L5=WENNFEHLER(WENN(JAHR(T5-1)=$W1+1;T5-1;"");"")
M5=L5
P5=WENNFEHLER(WENN(JAHR(T5-1)=$W1+1;T5-1;"");"")
Q5=P5
T5=WENN(JAHR('01'!D5-3)=W1+1;'01'!D5-3;"")
U5=T5
B7=Übersicht!D8
C7=Übersicht!E8
B8=Übersicht!D9
C8=Übersicht!E9
B9=Übersicht!D10
C9=Übersicht!E10
B10=Übersicht!D11
C10=Übersicht!E11
B11=Übersicht!D12
C11=Übersicht!E12
Verwendete Systemkomponenten: [Windows (32-bit) NT :.00] MS Excel 2016
Diese Tabelle wurde mit Tab2Html (v2.6.0) erstellt. ©Gerd alias Bamberg


Leider kann ich hier im Forum keine xlsx DAtei hochladen, deswegen habe ich sie bei MediaFire hochgeladen. Vl habe da allgemein was falsches eingetragen.
Und vielen dank, für deine Hilfe :)

Betrifft: AW: es war schon aufgezeigt ...
von: Benjamin
Geschrieben am: 02.10.2020 12:55:58

http://www.mediafire.com/file/oauue5y8j082n1y/Affen3.xlsx/file

Betrifft: AW: eine KW aus Vorjahr gibt es 2020 nicht ...
von: neopa C
Geschrieben am: 02.10.2020 14:10:12

Hallo Benjamin,

... welche berücksichtigt werden müsste. Eine solche anteilige KW gibt es erst wieder für das das auszuwertende Jahr 2021. Deshalb ist das Tabellenblatt für eine zu berücksichtigende KW aus dem Vorjahr für 2020 auch mit meinen Formeln leer.

Deinen Link auf Deine Datei hab ich jetzt nicht genutzt, weil ich nur Daten vom Forumsserver mir herunterlade.

Gruß Werner
.. , - ...

Betrifft: AW: eine KW aus Vorjahr gibt es 2020 nicht ...
von: Benjamin
Geschrieben am: 03.10.2020 06:46:26

Hallo Werner, ich habe mir alles noch mal angeguckt und es funktioniert jetzt alles. 1000 Dank für die ganze Hilfe

Betrifft: AW: bitteschön owT
von: neopa C
Geschrieben am: 03.10.2020 10:02:22

Gruß Werner
.. , - ...