Microsoft Excel

Herbers Excel/VBA-Archiv

Drop Down inkl. Folgefelder

Betrifft: Drop Down inkl. Folgefelder von: Nicole
Geschrieben am: 19.10.2020 16:12:11

https://www.herber.de/bbs/user/140979.xlsx

Hallo! Ich habe ein Problem und benötige Hilfe.
ich habe ein Excel mit 2 Tabellenblättern. Per Drop Down wähle ich den Artikel aus.
Ich hätte gerne, automatisch den EK und VK Preis jeweilig gleich dazu ausgewählt.
Ist das überhaupt möglich für rund 150 Einträge?

Danke! LG

Betrifft: AW: Drop Down inkl. Folgefelder
von: SF
Geschrieben am: 19.10.2020 16:17:04

Hola,

ja, mit dem Sverweis.
https://www.online-excel.de/excel/singsel.php?f=9

Gruß,
steve1da

Betrifft: AW: Drop Down inkl. Folgefelder
von: Nicole
Geschrieben am: 19.10.2020 16:21:10

Hallo,

danke für die schnelle antwort, das hab ich schon versucht, aber da komme ich nicht weiter.
Der S-Verweis geht ja auf die Spalte und müsste ja individuell an das Produkt angepasst werden.
Hier steh ich bei der Formel total an - gibt es vielleicht einen Tipp dazu?

DANKE!

Betrifft: AW: Drop Down inkl. Folgefelder
von: SF
Geschrieben am: 19.10.2020 16:24:40

Hola,

das Suchkriterium ist B6. Das passt sich also selber an den Inhalt an.

Gruß,
steve1da

Betrifft: AW: Drop Down inkl. Folgefelder
von: Nicole
Geschrieben am: 19.10.2020 16:27:45

Hallo,

zm Haare raufen.
=SVERWEIS(B6;Produkte!$B$2:$B$104;Produkte!$C$2:$C$104)
Damit habe ich aber ein #NV. Was mache ich falsch?

Betrifft: AW: Drop Down inkl. Folgefelder
von: EtoPHG
Geschrieben am: 19.10.2020 16:30:34

Hallo,

Excel gut? Noch nie was von er Funktionshilfe gehört?
=SVERWEIS(B6;Produkte!B:D;2;FALSCH)
=SVERWEIS(B6;Produkte!B:D;3;FALSCH)
Gruess Hansueli

Betrifft: AW: Drop Down inkl. Folgefelder
von: Nicole
Geschrieben am: 19.10.2020 16:32:17

Man sieht den WAld vor Bäumen nicht DANKE!!! :)

Betrifft: AW: Drop Down inkl. Folgefelder
von: SF
Geschrieben am: 19.10.2020 16:31:29

Hola,

du beachtest die Syntax aus dem Link nicht.
=wennfehler(SVERWEIS($B6;Produkte!$B$2:$D$104;SPALTE(B1);0);"")

Gruß,
steve1da