Zusammenfassen gleicher Werte mit Auswahlkriterien

Bild

Betrifft: Zusammenfassen gleicher Werte mit Auswahlkriterien
von: Alexander Benz
Geschrieben am: 03.06.2015 11:45:01

Hallo zusammen,
ich benötige dringend die Hilfe eines Excel Spezialisten :
Für eine Auswetung benötige ich folgende Ergebnisse :
Aus einer Liste mit mehreren gleichen Artikeln muss eine Summe, vergleichbar mit Zählenwenn (allerdings für 1000 verschiedene Artikel)summiert werden und anschließend in einer Zuordnung (Artikel - Summe) zusammengefasst werden. Da die Liste fortlaufend fortgeführt wird muss auch das Datum als Auswahlkriterium mit eingebracht werden. Ich hoffe das mir hier jemand weiterhelfen kann.
Vielen lieben Dank
Alex
Userbild

Bild

Betrifft: AW: Zusammenfassen gleicher Werte mit Auswahlkriterien
von: Hajo_Zi
Geschrieben am: 03.06.2015 11:46:43
Hallo Alex,
Ein Nachbau sieht bestimmt anders aus als das Original.
Eine Datei oder ein Tabellen Ausschnitt (nicht als Bild) erhöht die Wahrscheinlichkeit einer Antwort. Ein Bild in Excel geöffnet sieht anders aus als das Bild. Ich habe kein Tool um ein Bild in Excel zu importieren.


Bild

Betrifft: eine PIVOTauswertung sollte helfen ...
von: der neopa C
Geschrieben am: 03.06.2015 11:48:09
Hallo Alexander,
... und noch ein Hinweis. Es ist immer günstiger die Daten als kopierfähige Daten oder gleich als Datei einzustellen als nur als Bilddatei.
Gruß Werner
.. , - ...

Bild

Betrifft: AW: Zusammenfassen gleicher Werte mit Auswahlkriterien
von: Alexander Benz
Geschrieben am: 03.06.2015 13:36:28
Hallo zusammen,
vielen Dank für eine erste Reaktion :-)
Ich hänge mal die Datei an die ich begonnen habe zu erstellen. Ich bin kein Excel Profi daher stocke ich an diesem Punkt.
Ich habe die Zusammenhänge gelb markiert.
Die Daten im Sheet Datenexport sind immer variabel , d.h. Artikel bleibt aber die Anzahl ist tgl. unterschiedlich.
Ich muss die Daten zusammenfassen - als Summe den Artikeln zuordnen und im Sheet Auslastung UH Tool ab Spalte "V" in Bezug zum Datum und Artikel Spalte "A" darstellen. Hier soll anhand der Export-Auswertung aus SAP der tägliche Versand pro Tag und Artikel abgebildet werden.
Mir ist das too much - habe da noch keinen Anhaltspunkt.
Für eure Unterstützung lieben Dank
https://www.herber.de/bbs/user/98015.xlsx
Grüße
Alex

Bild

Betrifft: nicht ganz eindeutig, aber ...
von: der neopa C
Geschrieben am: 03.06.2015 14:32:43
Hallo Alex,
... aber wenn ich Dein Anliegen richtig interpretiere: sollte in B6 die Formel richtig so lauten:
=WENN($A6="";"";SUMMEWENNS('Datenexport Bestand'!$E:$E;'Datenexport Bestand'!$A:$A;B$3; 'Datenexport Bestand'!$C:$C;$A6)) und diese nach rechts und unten kopieren.
Und in V6 analog so:
=WENN($A6="";"";SUMMEWENNS('Datenexport Versand'!$E:$E;'Datenexport Versand'!$A:$A;V$4; 'Datenexport Versand'!$C:$C;$A6))
In W6 dann einfach so: =WENNFEHLER(1/(V6/B6);"")
Gruß Werner
.. , - ...

Bild

Betrifft: AW: nicht ganz eindeutig, aber ...
von: Alexander Benz
Geschrieben am: 03.06.2015 15:15:10
Hallo Werner,
vielen Dank für Deine Antwort.
Die erste Formel ist in Ordnung.
Aber die zweite Formel geht so nicht :-(
Das Problem ist, das im Sheet Datenexport Versand die exportierten Daten summiert werden müssen = gleiche Werte zusammenfassen und als Summe in Bezug zu den Artikeln abbilden. Diese Summen aus dem Sheet Datenexport_Versand muss ich dann in Spalte "V" - Sheet Auslastung_UH_Tool abbilden. Problem 1 ist : Das ich gleiche Werte zu Summen zusammenfassen muss, da keine numerischen Summen ausgegeben werden und das dieser Export jeden Tag, fortlaufend eingefügt wird. Jeder gleiche Wert 9040,9040,9040,2032,2032,2032 usw. entspricht dabei immer 1 Stück.
Einziger Anhaltspunkt zur Trennung und Summierung pro Tag wäre ein Bezug auf das Datum.
Gibt's hier so eine Art PN Funktion ? Vielleicht könnte man sich kurz zusammen telefonieren ?
Ich danke Dir aber für jede Unterstützung die Du mir geben kannst.
Grüße
Alex

Bild

Betrifft: AW: nicht ganz eindeutig, aber ...
von: Alexander Benz
Geschrieben am: 03.06.2015 16:18:48
Hi Werner,
die 2 . Formel von Dir war doch richtig - habe nur die Bereiche angepasst. Jetzt funktioniert die Auswertung wie gewünscht. Vielen Dank für diesen "Denkanstoß" - ich habe da wieder viel zu kompliziert gedacht und so nicht hinbekommen. Nochmal DANKE ! :-)

 Bild

Beiträge aus den Excel-Beispielen zum Thema "Zusammenfassen gleicher Werte mit Auswahlkriterien"