@erichm - Formeln durch VBA-Lösung ersetzen

Informationen und Beispiele zu den hier genannten Dialog-Elementen:
Bild

Betrifft: @erichm - Formeln durch VBA-Lösung ersetzen
von: fcs
Geschrieben am: 26.04.2015 12:26:39

Hallo Erich,
Fortsetzung Beitrag
https://www.herber.de/forum/archiv/1420to1424/t1421626.htm#1422848
Ich hab das Makro jetzt in der Datei so angepasst, dass Zeilenbereiche angegeben werden können.
https://www.herber.de/bbs/user/97309.xlsm
Hierfür hab ich das Blatt "Steuerung" angelegt, da das etwas einfacher zu handhaben ist als ein Userform. Man kann die 4 Zeilenwerte natürlich auch über ein Userform eingeben und in das Makro einbinden.
Bezüglich Anpassung der Formeln:
Alte Formel in C3:

=SUMMENPRODUKT(ZÄHLENWENN(Tabelle3!$A3:$AE3;Tabelle2!$A$3:$K$22*(Tabelle2!$A$3:$A$22=C$2)))

Neue Formel in C3:
=SUMMENPRODUKT(ZÄHLENWENN(Tabelle3!$B3:$AE3;Tabelle2!$B$3:$K$22*(Tabelle2!$A$3:$A$22=C$2))) 

Gruß
Franz

Bild

Betrifft: AW: @erichm - Formeln durch VBA-Lösung ersetzen
von: erichm
Geschrieben am: 27.04.2015 07:24:21
Hallo Franz,
DANKE - das sieht mir jetzt nach einer perfekten Lösung aus. Wenn ich mich damit beschäftigt habe, melde ich mich natürlich wieder (muss jetzt wieder los :) ).
mfg

Bild

Betrifft: AW: @erichm - Formeln durch VBA-Lösung ersetzen
von: erichm
Geschrieben am: 28.04.2015 07:47:22
Hallo Franz,
also das klappt alles wunderbar - die "Steuerungstabelle" ist eine sehr gute Idee und ist wesentlich einfacher als die UserForm :)
Wir bedanken uns nochmals ausdrücklich für diese hervorragende Lösung!
mfg

 Bild

Beiträge aus den Excel-Beispielen zum Thema "@erichm - Formeln durch VBA-Lösung ersetzen"