Live-Forum - Die aktuellen Beiträge
Anzeige
Anzeige
HERBERS
Excel-Forum (Archiv)
20+ Jahre Excel-Kompetenz: Von Anwendern, für Anwender
816to820
816to820
Aktuelles Verzeichnis
Verzeichnis Index
Verzeichnis Index
Übersicht Verzeichnisse
Inhaltsverzeichnis

Zählen ohne Duplikate mit Bedingung

Zählen ohne Duplikate mit Bedingung
14.11.2006 08:47:15
Suzette
Hallo Reinhard, hallo an alle anderen, die eine Lösung kennen könnten...
Die Formel die ich in dem Excelforum bekomme, lautet:
{=SUMME((VERGLEICH(A1:A10&B1:B10;A1:A10&B1:B10;0)=ZEILE(1:10)*(A1:A10=1)*(B1:B10""))*1)}
Ich muss leider zugeben, dass ich es nicht auf meine Datei umsetzen kann.... :-(
Wie bekomme ich denn hier die 2. Bedingung aus Spalte C noch hinein?
Danke im voraus und liebe Grüße,
Suzette
Hi Susanne,
schau mal bei www.excelformeln.de vorbei.
Gruß
Reinhard
ps: Ich freue mich über eine Rückmeldung ob diese Antwort hilfreich war oder nicht..
Bezieht sich auf diese Nachricht:
Hallo!
Ich möchte folgendes machen:
Aus der Spalte A möchte ich die Werte zählen - jedoch nur jeden Wert ein einziges Mal. Dies habe ich mir mit der Formel:
=(SUMME(WENN(INDIREKT("2a:"a&$AK$1)"";(1/ZÄHLENWENN(INDIREKT("a2:a"&$AK$1);(INDIREKT("a2:a"&$AK$1)))))))
aus dem Archiv abgeschrieben. (Indirekt hier, damit die Zeilenanzahl variabel bleibt - funktioniert auch)
Nun soll er aber noch in 2 anderen Spalten Bedingungen abfragen (in Spalte B eine "1" und in Spalte C eine "2"), und nur wenn die beide eintreffen, soll er die Werte in der Spalte A zählen. Hier scheitert es bei mir (leider :-( )
Kann mir hierzu jemand eine Hilfestellung geben?
Vielen vielen Dank im voraus
und liebe Grüße
Susanne Lehmann

11
Beiträge zum Forumthread
Beiträge zu diesem Forumthread

Betreff
Datum
Anwender
Anzeige
AW: Zählen ohne Duplikate mit Bedingung
14.11.2006 09:07:15
Erich
Hallo Susanne,
schau mal das an:
 ABCDE
1SpASpBSpCmit A und Bmit A, B, C
22  32
3x1232
44    
55    
66    
7y1   
8812  
9 1   
10     

Formeln der Tabelle
ZelleFormel
D2{=SUMME((VERGLEICH(A1:A10&B1:B10;A1:A10&B1:B10;0)=ZEILE(1:10)*(A1:A10&"">"")*(B1:B10=1))*1)}
E2{=SUMME((VERGLEICH(A1:A10&B1:B10&C1:C10;A1:A10&B1:B10&C1:C10;0)=ZEILE(1:10)*(A1:A10&"">"")*(B1:B10=1))*(C1:C10=2)*1)}
D3{=SUMME((VERGLEICH(A1:A10&B1:B10;A1:A10&B1:B10;0)=ZEILE(1:10)*(A1:A10>0)*(B1:B10=1))*1)}
E3{=SUMME((VERGLEICH(A1:A10&B1:B10&C1:C10;A1:A10&B1:B10&C1:C10;0)=ZEILE(1:10)*(A1:A10>0)*(B1:B10=1))*(C1:C10=2)*1)}
Enthält Matrixformel:
Umrandende
{ } nicht miteingeben,
sondern Formel mit STRG+SHIFT+RETURN abschließen!
Matrix verstehen


Excel Tabellen im Web darstellen >> Excel Jeanie HTML 4
Rückmeldung wäre nett! - Grüße von Erich aus Kamp-Lintfort
Anzeige
AW: Zählen ohne Duplikate mit Bedingung
14.11.2006 10:05:20
Suzette
Hallo,
bekomme leider eine Fehlermeldung. Ich verstehe auch nicht, was bei der Funktion "Zeile" passieren soll....Ich habe da nebenan in den Spalten nämlich auch noch andere Sachen stehen.....
Eigentlich dachte ich, es müsste mit
={(SUMME(WENN(UND(INDIREKT("2a:"a&$AK$1)"";(INDIREKT("2b:"b&$AK$1)=1);(INDIREKT("2c:"c&$AK$1)=2);(1/ZÄHLENWENN(INDIREKT("a2:a"&$AK$1);(INDIREKT("a2:a"&$AK$1)))))))}
funktionieren - aber da bekomme ich immer 0 als Ergebnis.
Bin also für weitere Hilfe absolut dankbar!
Liebe Grüße
Suzette
AW: Zählen ohne Duplikate mit Bedingung
14.11.2006 09:57:10
HermannZ
Hallo Susanne;
kann es sein das du sowas suchst?
Beispiel;
 
 ABCDEFGH
930        
9311.) Werte in Spalte A summieren wenn in SpalteB und C die Bedingung erfüllt ist   
9322.) Werte in Spalte A zählen wenn in SpalteB und C die Bedingung erfüllt ist   
933      die Anzahl der Zeilen soll variabel sein   
934     Ergebnis  
935WerteBedingung1Bedingung2erste Bedingungzweite Bedingungbis Zeile  
93610111294530<< Summe der
9371022    Werte in Spalte A
9381013     
9391012     
9401024   2<< Anzahl der
9411013    Werte in Spalte A
9421024     
9431012    beides ohne
9441024    doppelte in SpalteA
9452012     
9461014     
9471213     
9481022     
949        
Formeln der Tabelle
G936 : {=SUMME((INDIREKT("B936:B"&F936)=D936)*(INDIREKT("C936:C"&F936)=E936)*(INDIREKT("A936:A"&F936))*(VERGLEICH(WENN((INDIREKT("B936:B"&F936)=D936)*(INDIREKT("C936:C"&F936)=E936);INDIREKT("A936:A"&F936));WENN((INDIREKT("B936:B"&F936)=D936)*(INDIREKT("C936:C"&F936)=E936);INDIREKT("A936:A"&F936));)=ZEILE(INDIREKT("1:"&F936-935))))}
G940 : {=SUMME((INDIREKT("B936:B"&F936)=D936)*(INDIREKT("C936:C"&F936)=E936)*(VERGLEICH(WENN((INDIREKT("B936:B"&F936)=D936)*(INDIREKT("C936:C"&F936)=E936);INDIREKT("A936:A"&F936));WENN((INDIREKT("B936:B"&F936)=D936)*(INDIREKT("C936:C"&F936)=E936);INDIREKT("A936:A"&F936));)=ZEILE(INDIREKT("1:"&F936-935))))}
Enthält Matrixformel:
Umrandende
{ } nicht miteingeben,
sondern Formel mit STRG+SHIFT+RETURN abschließen!
 
Diagramm - Grafik - Excel Tabellen einfach im Web darstellen    Excel Jeanie HTML  3.0    Download  
Gruss hermann
Anzeige
AW: Zählen ohne Duplikate mit Bedingung
14.11.2006 10:16:13
Suzette
An Hermann!
Vielen Dank! Könnte sein, dass es funktioniert. Erklär mir nur noch bitte kurz, wie ich den Schluss deiner Formel einstellen muss...
So lautet es bei Dir:
ZEILE(INDIREKT("1:"&F936-935))))}
Nun habe ich meinen variablen Wert ja in Zeile AK1 stehen. Muss es dann lauten:
ZEILE(INDIREKT("1:"&AK1-1))))} ?
Danke im voraus,
LG, Suzette
AW: Zählen ohne Duplikate mit Bedingung
14.11.2006 10:34:33
HermannZ
Hallo Susanne;
der Formelteil; ZEILE(INDIREKT("1:"&F936-935))
dient nur dazu die Zeilenzahl anzupassen in dem Beispiel beginnt die Tabelle in Zeile 936 somit wird von der zeilenzahl in ZelleF936 der Wert 935 abgezogen und ich erhalte dann die richte Anzahl der zellen.
für dein beispiel ZEILE(INDIREKT("1:"&AK1-1))))}
müsste folgendes gelten du gibst in Zelle AK1 die Zelle an bis zu der gezählt werden soll minus der zeilen über der Tabelle,wenn also die tabelle in Zeile 2 beginnt dann minus 1 wie du geschrieben hast.
ich hoffe du kommst damit klar,sonst fragen.
Gruss hermann
Anzeige
AW: Zählen ohne Duplikate mit Bedingung
14.11.2006 10:42:33
Suzette
An Hermann,
also ich bekomme jetzt Ergebnisse, die zumindest realistisch sind. Ich muss sie jetzt mal überprüfen....
Vielen Dank für deine Hilfe!
LG, Suzette
AW: Zählen ohne Duplikate mit Bedingung
14.11.2006 10:50:16
Suzette
Attn. Hermann,
eine Frage habe ich jetzt doch noch. Das Ergebnis, das ich bekomme, ist immer um 1 höher, als es sein sollte. Das hat m.E. mit den Leerzellen zu tun, die jetzt auch als 1 gezählt werden. Wie kann ich dies in die Formel integrieren?
Danke im Voraus, Du hast mir sehr geholfen!
LG, Suzette
AW: Zählen ohne Duplikate mit Bedingung
14.11.2006 11:27:04
HermannZ
hallo Susanne;
ich kann dir leider nicht folgen, die Formel nimmt keine Rücksicht auf Leerzellen.
hier das Beispiel mit Leerzellen du siehst hat keinen Einfluss auf das Ergebniss.
 
 ABCDEFGH
9311.) Werte in Spalte A summieren wenn in SpalteB und C die Bedingung erfüllt ist   
9322.) Werte in Spalte A zählen wenn in SpalteB und C die Bedingung erfüllt ist   
933      die Anzahl der Zeilen soll variabel sein   
934     Ergebnis  
935WerteBedingung1Bedingung2erste Bedingungzweite Bedingungbis Zeile  
93610111295030<< Summe der
9371022    Werte in Spalte A
9381013     
9391012     
9401024   2<< Anzahl der
941       Werte in Spalte A
942        
9431012    beides ohne
9441024    doppelte in SpalteA
9452012     
9461014     
9471213     
9481022     
949        
Formeln der Tabelle
G936 : {=SUMME((INDIREKT("B936:B"&F936)=D936)*(INDIREKT("C936:C"&F936)=E936)*(INDIREKT("A936:A"&F936))*(VERGLEICH(WENN((INDIREKT("B936:B"&F936)=D936)*(INDIREKT("C936:C"&F936)=E936);INDIREKT("A936:A"&F936));WENN((INDIREKT("B936:B"&F936)=D936)*(INDIREKT("C936:C"&F936)=E936);INDIREKT("A936:A"&F936));)=ZEILE(INDIREKT("1:"&F936-935))))}
G940 : {=SUMME((INDIREKT("B936:B"&F936)=D936)*(INDIREKT("C936:C"&F936)=E936)*(VERGLEICH(WENN((INDIREKT("B936:B"&F936)=D936)*(INDIREKT("C936:C"&F936)=E936);INDIREKT("A936:A"&F936));WENN((INDIREKT("B936:B"&F936)=D936)*(INDIREKT("C936:C"&F936)=E936);INDIREKT("A936:A"&F936));)=ZEILE(INDIREKT("1:"&F936-935))))}
Enthält Matrixformel:
Umrandende
{ } nicht miteingeben,
sondern Formel mit STRG+SHIFT+RETURN abschließen!
 
Diagramm - Grafik - Excel Tabellen einfach im Web darstellen    Excel Jeanie HTML  3.0    Download  
anders ist das verhalten wenn in Spalte A Leerzellen sind aber in Spalte B und C die Bedingungen erfüllt werden dann ist das ergebniss ein anderes es entstehen ja dann wieder unterschiede in der Spalte A und die werden eben gezählt.
Beispiel;
 
 ABCDEFGH
934     Ergebnis  
935WerteBedingung1Bedingung2erste Bedingungzweite Bedingungbis Zeile  
93610111295030<< Summe der
9371022    Werte in Spalte A
9381013     
9391012     
9401024   3<< Anzahl der
941       Werte in Spalte A
942        
943 12    beides ohne
9441024    doppelte in SpalteA
9452012     
9461014     
9471213     
9481022     
949        
Formeln der Tabelle
G936 : {=SUMME((INDIREKT("B936:B"&F936)=D936)*(INDIREKT("C936:C"&F936)=E936)*(INDIREKT("A936:A"&F936))*(VERGLEICH(WENN((INDIREKT("B936:B"&F936)=D936)*(INDIREKT("C936:C"&F936)=E936);INDIREKT("A936:A"&F936));WENN((INDIREKT("B936:B"&F936)=D936)*(INDIREKT("C936:C"&F936)=E936);INDIREKT("A936:A"&F936));)=ZEILE(INDIREKT("1:"&F936-935))))}
G940 : {=SUMME((INDIREKT("B936:B"&F936)=D936)*(INDIREKT("C936:C"&F936)=E936)*(VERGLEICH(WENN((INDIREKT("B936:B"&F936)=D936)*(INDIREKT("C936:C"&F936)=E936);INDIREKT("A936:A"&F936));WENN((INDIREKT("B936:B"&F936)=D936)*(INDIREKT("C936:C"&F936)=E936);INDIREKT("A936:A"&F936));)=ZEILE(INDIREKT("1:"&F936-935))))}
Enthält Matrixformel:
Umrandende
{ } nicht miteingeben,
sondern Formel mit STRG+SHIFT+RETURN abschließen!
 
Diagramm - Grafik - Excel Tabellen einfach im Web darstellen    Excel Jeanie HTML  3.0    Download  
Gruss hermann
Anzeige
AW: Zählen ohne Duplikate mit Bedingung
14.11.2006 11:50:59
Suzette
Hallo Hermann,
ja, das genau ist mein Problem. Die beiden Bedingungen werden erfüllt, aber in der eigentlichen Spalte die Zelle ist leer....... es müsste mit einer weiteren Bedingung - nämlich
INDIREKT("a936:a"&F936)""
irgendwie aus der Berechnung ausgeschlossen werden. Nur bekomme ich das nicht so ohne weiteres hin...
LG, Suzette
AW: Zählen ohne Duplikate mit Bedingung
14.11.2006 11:56:00
Suzette
OK - ich glaub, ich habs!
={SUMME((INDIREKT("aa2:aa"&$AK$1)=$AH9)*(INDIREKT("ad2:ad"&$AK$1)=$AJ9)*(VERGLEICH(WENN((INDIREKT("aa2:aa"&$AK$1)=$AH9)*(INDIREKT("ad2:ad"&$AK$1)=$AJ9)*(INDIREKT("p2:p"&$AK1)"");INDIREKT("p2:p"&$AK$1));WENN((INDIREKT("aa2:aa"&$AK$1)=$AH9)*(INDIREKT("ad2:ad"&$AK$1)=$AJ9);INDIREKT("p2:p"&$AK$1));)=ZEILE(INDIREKT("1:"&$AK$1-1))))}
Vielen Dank!!!!!
Anzeige
AW: Zählen ohne Duplikate mit Bedingung
14.11.2006 12:22:41
HermannZ
Hallo Susanne;
wenn du das ausschliessen willst dann muss die Festlegung ob "" woanders hin;
hier das geänderte Beispiel;
 
 ABCDEFGH
9311.) Werte in Spalte A summieren wenn in SpalteB und C die Bedingung erfüllt ist   
9322.) Werte in Spalte A zählen wenn in SpalteB und C die Bedingung erfüllt ist   
933      die Anzahl der Zeilen soll variabel sein   
934     Ergebnis  
935WerteBedingung1Bedingung2erste Bedingungzweite Bedingungbis Zeile  
93610111295030<< Summe der
9371022    Werte in Spalte A
9381013     
9391012     
9401024   3<< Anzahl der
941       Werte in Spalte A
942        
943 12    beides ohne
9441024    doppelte in SpalteA
9452012     
9461014     
9471213   2<< mit Leerzellen
9481022           in Spalte A
949        
Formeln der Tabelle
G936 : {=SUMME((INDIREKT("B936:B"&F936)=D936)*(INDIREKT("C936:C"&F936)=E936)*(INDIREKT("A936:A"&F936))*(VERGLEICH(WENN((INDIREKT("B936:B"&F936)=D936)*(INDIREKT("C936:C"&F936)=E936);INDIREKT("A936:A"&F936));WENN((INDIREKT("B936:B"&F936)=D936)*(INDIREKT("C936:C"&F936)=E936);INDIREKT("A936:A"&F936));)=ZEILE(INDIREKT("1:"&F936-935))))}
G940 : {=SUMME((INDIREKT("B936:B"&F936)=D936)*(INDIREKT("C936:C"&F936)=E936)*(VERGLEICH(WENN((INDIREKT("B936:B"&F936)=D936)*(INDIREKT("C936:C"&F936)=E936);INDIREKT("A936:A"&F936));WENN((INDIREKT("B936:B"&F936)=D936)*(INDIREKT("C936:C"&F936)=E936);INDIREKT("A936:A"&F936));)=ZEILE(INDIREKT("1:"&F936-935))))}
G947 : {=SUMME((INDIREKT("B936:B"&F936)=D936)*(INDIREKT("C936:C"&F936)=E936)*(INDIREKT("A936:A"&F936)<>"")*(VERGLEICH(WENN((INDIREKT("B936:B"&F936)=D936)*(INDIREKT("C936:C"&F936)=E936);INDIREKT("A936:A"&F936));WENN((INDIREKT("B936:B"&F936)=D936)*(INDIREKT("C936:C"&F936)=E936);INDIREKT("A936:A"&F936));)=ZEILE(INDIREKT("1:"&F936-935))))}
Enthält Matrixformel:
Umrandende
{ } nicht miteingeben,
sondern Formel mit STRG+SHIFT+RETURN abschließen!
 
Diagramm - Grafik - Excel Tabellen einfach im Web darstellen    Excel Jeanie HTML  3.0    Download  
Gruss Hermann
Anzeige

163 Forumthreads zu ähnlichen Themen

Anzeige
Anzeige
Anzeige
Anzeige

Beliebteste Forumthreads (12 Monate)

Anzeige

Beliebteste Forumthreads (12 Monate)

Anzeige
Anzeige
Anzeige