Microsoft Excel

Herbers Excel/VBA-Archiv

Verketten mit Bedingung


Betrifft: Verketten mit Bedingung von: Heinz
Geschrieben am: 28.04.2017 11:00:06

Hallo Liebe Excellenten,

ich haben folgende Aufgabenstellung.

Ich habe eine große Tabelle mit Daten.
Oberhalb der Tabelle ist für bestimmte Spalten eine
Kennung angegeben, in meinem Fall ein Wort, über einigen
Spalte steht Prio1, über einigen Prio2 und über einigen Prio3.

Ich möchte gerne in eine Zelle eine Verkettung ausführen,
das heißt es sollen alle Inhalte aus der aktuellen Zeile
aus den Spalten, über denen "Prio1" steht verkettet werden.
Das gleiche natürlich mit Prio2 usw.

Ich freue mich auf eure Vorschläge und wünsche allen für
das WE ein besseres Wetter als jetzt (im Süden).

Heinz

  

Betrifft: AW: Verketten mit Bedingung von: ChrisL
Geschrieben am: 28.04.2017 11:18:24

Hi Heinz

Falls es nur wenige Spalten sind, dann z.B.
=WENN(A$1="Prio 1";A2;"")&WENN(B$1="Prio 1";B2;"")&WENN(C$1="Prio 1";C2;"")&WENN(D$1="Prio 1";D2;"")

Wenn es sehr viele Spalten sind, könnte eine benutzerdefinierte VBA-Funktion helfen...
http://www.ms-office-forum.net/forum/showthread.php?t=273352

cu
Chris


  

Betrifft: Danke an Chris owT von: Heinz
Geschrieben am: 28.04.2017 13:37:38




Beiträge aus den Excel-Beispielen zum Thema "Verketten mit Bedingung"