Wenn null falsches Ergebnis

Bild

Betrifft: Wenn null falsches Ergebnis
von: Snewi
Geschrieben am: 24.11.2015 09:53:08

Guten Morgen,
ich habe folgende Formel:


=WENN(W10>"";"100%";"")
Wenn W10 jetzt "" ist dann wird trotzdem 100% angezeigt weil in der Zelle eine Formel steht! Wie macht man es besser?
Gruß

Bild

Betrifft: AW: Wenn null falsches Ergebnis
von: Rudi Maintaire
Geschrieben am: 24.11.2015 09:57:08
Hallo,
bei mir nicht.
Prüfe Formel in W10. " " statt ""???
Gruß
Rudi

Bild

Betrifft: AW: Wenn null falsches Ergebnis
von: Snewi
Geschrieben am: 24.11.2015 10:27:26
Sorry! Meinte folgende Formel:


=WENN(W10>0;100;"")
Es wird wenn die Zelle einen Wert enthält die 100 angezeigt! Wenn aber die Zelle in der die Formel:

=WENNFEHLER(SVERWEIS(W$4;Daten!$A:$X;4;0);"")

steht null ist wird trotzdem die 100 angezeigt!
gruß

Bild

Betrifft: AW: Wenn null falsches Ergebnis
von: Chak
Geschrieben am: 24.11.2015 10:44:11
Hi Snewi,
vielleicht auf nicht gleich 0 anstatt auf größer 0 Prüfen.

=WENN(W10<>0;100;"")
Oder auf beides Prüfen.
=WENN(UND(W10<>0;W10>0);100;"")
Gruß
Chak

Bild

Betrifft: AW: Wenn null falsches Ergebnis
von: Snewi
Geschrieben am: 24.11.2015 10:47:11
klappt auch nicht!!!

Bild

Betrifft: AW: ="" ist für Excel nicht leer auch nicht 0 ...
von: ... neopa C
Geschrieben am: 24.11.2015 10:52:40
Hallo,
... deshalb dann so:


=WENN((W10<>"")*(W10>0);100;"")
Gruß Werner
.. , - ...

Bild

Betrifft: AW: ="" ist für Excel nicht leer auch nicht 0 ...
von: Snewi
Geschrieben am: 24.11.2015 10:57:28
So klappt es SUPER!
Danke

Bild

Betrifft: AW: Wenn null falsches Ergebnis
von: SF
Geschrieben am: 24.11.2015 10:50:19
Hola,
bei mir nicht.
Zeig doch mal eine Beispieldatei.
Gruß,
steve1da

Bild

Betrifft: AW: Wenn null falsches Ergebnis
von: Snewi
Geschrieben am: 24.11.2015 10:56:20
https://www.herber.de/bbs/user/101765.xlsx

 Bild

Beiträge aus den Excel-Beispielen zum Thema "Wenn null falsches Ergebnis"