Anzeige
Archiv - Navigation
1264to1268
Aktuelles Verzeichnis
Verzeichnis Index
Übersicht Verzeichnisse
Vorheriger Thread
Rückwärts Blättern
Nächster Thread
Vorwärts blättern
Anzeige
HERBERS
Excel-Forum (Archiv)
20+ Jahre Excel-Kompetenz: Von Anwendern, für Anwender
Inhaltsverzeichnis

Monatsanfang auf bestimmten Tag

Monatsanfang auf bestimmten Tag
Werner
Hallo Excel Freunde
Habe einen Arbeitsplan erstellt, und möchte das der erste des Monats in Form TT.MMM.JJ. automatisch bei den richtigen Wochentag eingetragen wird.
Die Wochentage sind fest in einer bestimmten Zelle angegeben.
Beispiel:
F4 = Montag, M4 = Dienstag, T4 = Mittwoch, AA4 = Donnerstag, AH 4 = Freitag, AO4 = Samstag, AV4 = Sonntag
Der erste soll immer in der Zelle darüber richtig eingetragen werden.
Im Monat Juni zum Beispiel in Zelle AH3
Gruß
Werner

9
Beiträge zum Forumthread
Beiträge zu diesem Forumthread

Betreff
Benutzer
Anzeige
AW: Monatsanfang auf bestimmten Tag
23.05.2012 20:17:43
Hajo_Zi
Hallo Werner,
Tabelle2
 FMTAAAHAOAV
3        01.06.12   
4MontagDienstagMittwochDonnerstagFreitagSonnabendSonntag

verwendete Formeln
Zelle Formel Bereich
F3 =WENN(WOCHENTAG(DATUM(JAHR(HEUTE());MONAT(HEUTE())+1;1);2)=1;DATUM(JAHR(HEUTE());MONAT(HEUTE())+1;1);"") 
M3 =WENN(WOCHENTAG(DATUM(JAHR(HEUTE());MONAT(HEUTE())+1;1);2)=2;DATUM(JAHR(HEUTE());MONAT(HEUTE())+1;1);"") 
T3 =WENN(WOCHENTAG(DATUM(JAHR(HEUTE());MONAT(HEUTE())+1;1);2)=3;DATUM(JAHR(HEUTE());MONAT(HEUTE())+1;1);"") 
AA3 =WENN(WOCHENTAG(DATUM(JAHR(HEUTE());MONAT(HEUTE())+1;1);2)=4;DATUM(JAHR(HEUTE());MONAT(HEUTE())+1;1);"") 
AH3 =WENN(WOCHENTAG(DATUM(JAHR(HEUTE());MONAT(HEUTE())+1;1);2)=5;DATUM(JAHR(HEUTE());MONAT(HEUTE())+1;1);"") 
AO3 =WENN(WOCHENTAG(DATUM(JAHR(HEUTE());MONAT(HEUTE())+1;1);2)=6;DATUM(JAHR(HEUTE());MONAT(HEUTE())+1;1);"") 
AV3 =WENN(WOCHENTAG(DATUM(JAHR(HEUTE());MONAT(HEUTE())+1;1);2)=7;DATUM(JAHR(HEUTE());MONAT(HEUTE())+1;1);"") 

Tabellendarstellung in Foren Version 5.48



Anzeige
AW: Monatsanfang auf bestimmten Tag
23.05.2012 20:39:50
Werner
Hallo Hajo
funktioniert leider nicht.
die Zellen bleiben leer.
Habe im übrigen vergessen an zu geben: in Zelle B2 steht der Monat und in Zelle F2 das Jahr.
Das sieht so aus: Juni 2012
Greuß Werner
AW: Monatsanfang auf bestimmten Tag
23.05.2012 21:00:14
Hajo_Zi
Hallo werner,
Du siehst in meinemn Beispiel das das Datum an der richtigen Stelle steht. Da Du die Aufgabe nur halb beschrieben hast mußte ich einige Dinge annehmen. Das hat den Vorteil die Anpassung an Deine Bedingunggen darfst Du selber vornehmen.
Gruß Hajo
AW: Monatsanfang auf bestimmten Tag
23.05.2012 20:36:05
Reinhard
Hallo Werner,
als Ansatz, die Tage stehen in A4:G4, formatiere A3:G3 so: TT.MM.JJJJ;Standard;;
Formel in A3 die du nach rechts kopierst:
=(TEXT(DATUM(JAHR(HEUTE());6;1);"TTTT")=A4)*(DATUM(JAHR(HEUTE());6;1))
Gruß
Reinhard
Anzeige
AW: Monatsanfang auf bestimmten Tag
23.05.2012 20:58:04
Werner
Hallo Reinhard
funktioniert soweit, aber wenn in Zelle B2 den Momat Mai eingebe erscheint trotzdem unter Freitag der 01.Jun.2012
des weiteren erscheint unter Samstag und Sonntag kein Datum mehr.
Bisher habe ich immer das Datum so einfügen lassen: ZelleXY +1
Wobei für XY immer die Zellennummer mit den vorhergehenden Tag steht.
Gruß
Werner
AW: Monatsanfang auf bestimmten Tag
23.05.2012 21:14:09
Reinhard
Hallo Werner,
meine Formel wußte nix von B2. ZelleXY +1 erscheint mir zumindest sonderbar da deine
Tagesspalten auseinander liegen.
Mein Vorschlag ist, du erstellst für einen beliebigen Monat eine Beispielmappe wo du manuell
alles einträgst was da zu sehen sein soll und lädst die hier hoch.
Färbe die Zellen die später Formeln aufweisen sollen.
Gruß
Reinhard
Anzeige
AW: Monatsanfang auf bestimmten Tag
23.05.2012 21:31:10
Werner
Hallo Reinhard
habe die Datei als ZIP-Datei mit hochgeladen.
In Zeile 3 sollen die Datums stehen.
In Zeile 4 sind die Wochentage angegeben.(In den Zellen F4, M4, T4, AA4, AH4, AO4, AV4, manuell eingegeben, währen in der 2 Woche abhängig vom Datum darüber)
https://www.herber.de/bbs/user/80271.zip
Gruß
Werner
AW: Monatsanfang auf bestimmten Tag
23.05.2012 21:50:11
Josef

Hallo Werner,
Std.-Plan

 ABCDEFGHJMNOQTUVXAAABACAEAHAIAJALAOAPAQASAVAWAXAZBCBD
1 - Monat  Jahr 
2 Mai  2012
3   In Leistung %ZuschlagMo 30.04.12 1. Mai. 2012 2. Mai. 2012 3. Mai. 2012 4. Mai. 2012 5. Mai. 2012 6. Mai. 2012 WOCHEN            -                   SUMME
4   Montag Dienstag Mittwoch Donnerstag Freitag Samstag Sonntag 
5                               

Formeln der Tabelle
ZelleFormel
F3=DATWERT(B2&"/"&F2)-WOCHENTAG(DATWERT(B2&"/"&F2); 2)+1


Excel Tabellen im Web darstellen >> Excel Jeanie HTML 4

« Gruß Sepp »

Anzeige
AW: Monatsanfang auf bestimmten Tag
23.05.2012 21:54:20
Werner
Hallo Sepp
vielen Dank, klappt wunderbar.
Gruß
Werner

304 Forumthreads zu ähnlichen Themen

Anzeige
Anzeige
Anzeige

Beliebteste Forumthreads (12 Monate)

Anzeige

Beliebteste Forumthreads (12 Monate)

Anzeige
Anzeige
Anzeige