Live-Forum - Die aktuellen Beiträge
Anzeige
Anzeige
HERBERS
Excel-Forum
20+ Jahre Excel-Kompetenz: Von Anwendern, für Anwender
Inhaltsverzeichnis

Wievielter Sonntag im Monat

Wievielter Sonntag im Monat
Tomi
Hallo,
wie kann ich in einer Tabelle mit fortlaufendem Datum in einer Spalte in einer weiteren Spalte feststellen, der wievielte So (Mo, Di...) es im Monat ist? Bsp: 03.01.2010 ist der 1. Sonntag, 10.01.2010 ist der 2. Sonntag usw.
Tomi

6
Beiträge zum Forumthread
Beiträge zu diesem Forumthread

Betreff
Benutzer
Anzeige
kann man bestimmt noch vereinfachen...
11.11.2009 14:17:45
Björn
Hallo,
also diese Formel geht davon aus, dass das erste Datum in A2 steht und dann Tageweise nach unten.
Die Formel muss dann in B2. Diese kannst Du nach unten kopieren bzw. ausfüllen.
=WENN(MONAT(A2)=MONAT(A1);WENN(WOCHENTAG(A2;1)=1;B1+1;B1);WENN(WOCHENTAG(A2;1)=1;1;0))
Da man das bestimmt noch verinfachen kann, lass ich mal noch offen.
Gruß
Björn
AW: Wievielter Sonntag im Monat
11.11.2009 14:40:17
Erich
Hi Tomi,
stimmt, das geht einfacher:
 ABC
1DatumAnz WToder kurz
2Do   01.10.20091. Donnerstag1
3Fr   02.10.20091. Freitag1
4Sa   03.10.20091. Samstag1
5So   04.10.20091. Sonntag1
6Mo   05.10.20091. Montag1
7Di   06.10.20091. Dienstag1
8Mi   07.10.20091. Mittwoch1
9Do   08.10.20092. Donnerstag2
10Fr   09.10.20092. Freitag2
11Sa   10.10.20092. Samstag2
12So   11.10.20092. Sonntag2
13   
14So   25.10.20094. Sonntag4
15Mo   26.10.20094. Montag4
16Di   27.10.20094. Dienstag4
17Mi   28.10.20094. Mittwoch4
18Do   29.10.20095. Donnerstag5
19Fr   30.10.20095. Freitag5
20Sa   31.10.20095. Samstag5
21So   01.11.20091. Sonntag1
22Mo   02.11.20091. Montag1
23Di   03.11.20091. Dienstag1
24Mi   04.11.20091. Mittwoch1
25Do   05.11.20091. Donnerstag1
26Fr   06.11.20091. Freitag1
27Sa   07.11.20091. Samstag1
28So   08.11.20092. Sonntag2
29Mo   09.11.20092. Montag2

Formeln der Tabelle
ZelleFormel
B2=GANZZAHL((TAG(A2)+6)/7)&"."&TEXT(A2;" TTTT")
C2=GANZZAHL((TAG(A2)+6)/7)

Rückmeldung wäre nett! - Grüße von Erich aus Kamp-Lintfort
Anzeige
AW: Wievielter Sonntag im Monat
11.11.2009 14:45:51
Tomi
Hallo Erich - Volltreffer. Besten Dank Tomi
und noch etwas kürzer ...
11.11.2009 18:34:25
neopa
Hallo Erich,
... würde Deine Formel mittels =KÜRZEN((TAG(A2)+6)/7;) sein.
Aber was hälst Du von nur: =(TAG(A2)+3)/7 und Format:"0" ?
Gruß Werner
.. , - ...
AW: und noch etwas kürzer ...
11.11.2009 19:57:40
robert
hi,
=(TAG(A2)+3)/7
scheint aber nicht das ergebnis der frage zu sein - oder ?
gruß
robert
AW: und noch etwas kürzer ...
11.11.2009 21:13:13
Erich
Hi Werner,
klar, KÜRZEN ist kürzer als GANZZAHL...
Deine 2. Lösung =(TAG(A2)+3)/7 und Format:"0" ist auch listig - wenn man damit nicht weiter rechnen will.
Grüße von Erich aus Kamp-Lintfort

304 Forumthreads zu ähnlichen Themen


Guten Morgen,
habe mal etwas in Google gesucht und bin mit dieser Formel fündig geworden:
=SUMMENPRODUKT(--(WOCHENTAG(ZEILE(INDIREKT(V44&":"&DATUM(JAHR(V44);MONAT(V44)+1;0)));2)<6)) &" Tage"
Wenn in der Zelle "V44" 01.01.2008 drin steht kommt als Ergebnis "X44" = 23...
Anzeige

Guten Tag
Angenommen, in einer Tabelle steht in A1 das Datum 30. September 2009. Gesucht wird in Zelle A2 der letzte Arbeitstag des nächsten Monats. Da der 31. Oktober ein Samstag ist, wäre dies der 30. Oktober.
Kann ich dieses Datum mit einer Formel ermitteln?
Danke für eine Antwor...

Hallo zusammen,
Archiv gibt leider nur Lösungen mit VBA her.
wie finde ich per VBA den ersten Montag im Monat?
Ich hatte eine Lösung ohne VBA, doch ist mein Prog weitläufiger und daher bin ich auf der Suche nach einer VBA lösung.
Danke vorab,
markus
Anzeige

Wer kann mir bitte sagen, wie ich den letzten Tag eines Monats ermittle unter Berücksichtigung der Schaltjahre.

Hallo,
im Archiv fand ich leider nichts hilfreiches.
In der Spalte A1-A20 stehen verschiedene Datum(er).
Nun suche nich nach einer Möglichkeit, jeweils zum Monat den 4. Arbeitstag herauszufinden.
( Samstag kein Arbeitstag gerechnet).
Gibt es eine solche Formel?
Danke für...

Hallo liebe Experten,
Ich brauche wieder mal Eure Hilfe...
Ich suche einen Code, der mir alle 5 Tage im laufenden Monat, sowie am letzten des Monats eine msgbox anzeigt...
Also wenn der Monat 31 Tage hat, dann am 5. , 10., 15., 20., 25., und am 31.
Wenn der Monat aber nur 28 Tag...
Anzeige

Beliebteste Forumthreads (12 Monate)

Anzeige

Beliebteste Forumthreads (12 Monate)

Anzeige
Anzeige
Anzeige