Microsoft Excel

Herbers Excel/VBA-Archiv

Wievielter Sonntag im Monat | Herbers Excel-Forum


Betrifft: Wievielter Sonntag im Monat von: Tomi
Geschrieben am: 11.11.2009 14:01:04

Hallo,

wie kann ich in einer Tabelle mit fortlaufendem Datum in einer Spalte in einer weiteren Spalte feststellen, der wievielte So (Mo, Di...) es im Monat ist? Bsp: 03.01.2010 ist der 1. Sonntag, 10.01.2010 ist der 2. Sonntag usw.

Tomi

  

Betrifft: kann man bestimmt noch vereinfachen... von: Björn B.
Geschrieben am: 11.11.2009 14:17:45

Hallo,

also diese Formel geht davon aus, dass das erste Datum in A2 steht und dann Tageweise nach unten.
Die Formel muss dann in B2. Diese kannst Du nach unten kopieren bzw. ausfüllen.

=WENN(MONAT(A2)=MONAT(A1);WENN(WOCHENTAG(A2;1)=1;B1+1;B1);WENN(WOCHENTAG(A2;1)=1;1;0))
Da man das bestimmt noch verinfachen kann, lass ich mal noch offen.

Gruß
Björn


  

Betrifft: AW: Wievielter Sonntag im Monat von: Erich G.
Geschrieben am: 11.11.2009 14:40:17

Hi Tomi,
stimmt, das geht einfacher:

 ABC
1DatumAnz WToder kurz
2Do   01.10.20091. Donnerstag1
3Fr   02.10.20091. Freitag1
4Sa   03.10.20091. Samstag1
5So   04.10.20091. Sonntag1
6Mo   05.10.20091. Montag1
7Di   06.10.20091. Dienstag1
8Mi   07.10.20091. Mittwoch1
9Do   08.10.20092. Donnerstag2
10Fr   09.10.20092. Freitag2
11Sa   10.10.20092. Samstag2
12So   11.10.20092. Sonntag2
13   
14So   25.10.20094. Sonntag4
15Mo   26.10.20094. Montag4
16Di   27.10.20094. Dienstag4
17Mi   28.10.20094. Mittwoch4
18Do   29.10.20095. Donnerstag5
19Fr   30.10.20095. Freitag5
20Sa   31.10.20095. Samstag5
21So   01.11.20091. Sonntag1
22Mo   02.11.20091. Montag1
23Di   03.11.20091. Dienstag1
24Mi   04.11.20091. Mittwoch1
25Do   05.11.20091. Donnerstag1
26Fr   06.11.20091. Freitag1
27Sa   07.11.20091. Samstag1
28So   08.11.20092. Sonntag2
29Mo   09.11.20092. Montag2

Formeln der Tabelle
ZelleFormel
B2=GANZZAHL((TAG(A2)+6)/7)&"."&TEXT(A2;" TTTT")
C2=GANZZAHL((TAG(A2)+6)/7)

Rückmeldung wäre nett! - Grüße von Erich aus Kamp-Lintfort


  

Betrifft: AW: Wievielter Sonntag im Monat von: Tomi
Geschrieben am: 11.11.2009 14:45:51

Hallo Erich - Volltreffer. Besten Dank Tomi


  

Betrifft: und noch etwas kürzer ... von: neopa
Geschrieben am: 11.11.2009 18:34:25

Hallo Erich,

... würde Deine Formel mittels =KÜRZEN((TAG(A2)+6)/7;) sein.
Aber was hälst Du von nur: =(TAG(A2)+3)/7 und Format:"0" ?


Gruß Werner
.. , - ...


  

Betrifft: AW: und noch etwas kürzer ... von: robert
Geschrieben am: 11.11.2009 19:57:40

hi,

=(TAG(A2)+3)/7

scheint aber nicht das ergebnis der frage zu sein - oder ?

gruß
robert


  

Betrifft: AW: und noch etwas kürzer ... von: Erich G.
Geschrieben am: 11.11.2009 21:13:13

Hi Werner,
klar, KÜRZEN ist kürzer als GANZZAHL...

Deine 2. Lösung =(TAG(A2)+3)/7 und Format:"0" ist auch listig - wenn man damit nicht weiter rechnen will.

Grüße von Erich aus Kamp-Lintfort


Beiträge aus den Excel-Beispielen zum Thema "Wievielter Sonntag im Monat"