Microsoft Excel

Herbers Excel/VBA-Archiv

5 größten Werte einer Zahlenfolge


Betrifft: 5 größten Werte einer Zahlenfolge von: Karsten
Geschrieben am: 09.07.2018 16:21:29

Hi,

ich versuche die 5 größten Werte einer Zahlenfolge A1:R1 in einer anderen Zeile mit dem Wert "1" wiederzugeben. Aber so, dass der Wert "1" in der gleichen Spalte steht, wie die dazu gehörige Zahl. Die bisher verwendete Formel klappt aber nicht korrekt:

=WENN(E1=KGRÖSSTE($A1:$R1;5);1;0) - ich denke das Problem ist der k Wert

Freue mich über jede Anregung

Grüße Karsten

  

Betrifft: AW: 5 größten Werte einer Zahlenfolge von: ChrisL
Geschrieben am: 09.07.2018 16:28:18

Hi

Vielleicht so...

=WENN(E1>=KGRÖSSTE($A1:$R1;5);1;0)

oder besser in WAHR/FALSCH ausgedrückt...
=E1>=KGRÖSSTE($A1:$R1;5)

(wenn E1 grösser/gleich dem 5. grössten Wert)

cu
Chris


  

Betrifft: AW: 5 größten Werte einer Zahlenfolge von: Karsten
Geschrieben am: 09.07.2018 16:36:19

ja, dass klappt - vielen Dank!


Beiträge aus dem Excel-Forum zum Thema "5 größten Werte einer Zahlenfolge"