Anzeige
Archiv - Navigation
912to916
Aktuelles Verzeichnis
Verzeichnis Index
Übersicht Verzeichnisse
Vorheriger Thread
Rückwärts Blättern
Nächster Thread
Vorwärts blättern
Anzeige
HERBERS
Excel-Forum (Archiv)
20+ Jahre Excel-Kompetenz: Von Anwendern, für Anwender
912to916
912to916
Aktuelles Verzeichnis
Verzeichnis Index
Verzeichnis Index
Übersicht Verzeichnisse
Inhaltsverzeichnis

Matrix für: Zelle mit Zahl Zelle ohne Zahl

Matrix für: Zelle mit Zahl Zelle ohne Zahl
09.10.2007 15:52:00
Born
Liebe Kollegen,
was soll ich machen, ich quäl mich eine Weile mit dem Problem rum und dann schreib ich
doch wieder rein. Bin halt doch noch Anfänger. Und hoffe, daß ich mit den Fragen niemandem
zu sehr auf die nerven gehe.
Diesmal geht es um folgendes:
Userbild
Wenn es nur um eine Spalte ginge, wäre die Formel
=WENN(UND(ISTZAHL(A6);ODER(A7="";A7=1));A6;"")
Wie schreibt man die um, daß sie für 20 Spalten funktioniert, ohne einen elendslangen
Bandwurm zu erzeugen?
Danke für Eure Hilfe,
born

7
Beiträge zum Forumthread
Beiträge zu diesem Forumthread

Betreff
Datum
Anwender
Anzeige
AW: Matrix für: Zelle mit Zahl Zelle ohne Zahl
09.10.2007 17:02:44
Born
Danke Bertram. Hatte ich vergessen. Dumme Angewohnheit.
Hier die Tabelle:
https://www.herber.de/bbs/user/46648.xls
Gruß,
born

AW: Matrix für: Zelle mit Zahl Zelle ohne Zahl
09.10.2007 17:33:00
Christian
Hallo Born,
als Ansatz:
Tabelle2

 ABCDEFGH
43  13   
54  24   
65  35  5
7   46  4
8   17   
9   28  2
10    9   
11    10  10
12        

Formeln der Tabelle
ZelleFormel
H6{=WENN(ODER(ISTLEER(BEREICH.VERSCHIEBEN(A6;1;KKLEINSTE(WENN(ISTZAHL(A6:G6); SPALTE(A6:G6)); 1)-1)); BEREICH.VERSCHIEBEN(A6;1;KKLEINSTE(WENN(ISTZAHL(A6:G6); SPALTE(A6:G6)); 1)-1)=1;); BEREICH.VERSCHIEBEN(A6;0;KKLEINSTE(WENN(ISTZAHL(A6:G6); SPALTE(A6:G6)); 1)-1); "")}
Enthält Matrixformel:
Umrandende
{ } nicht miteingeben,
sondern Formel mit STRG+SHIFT+RETURN abschließen!
Matrix verstehen


Excel Tabellen im Web darstellen >> Excel Jeanie HTML 4
MFG Christian

Anzeige
AW: @Christian...............
09.10.2007 19:24:59
HermannZ
Hallo Christian;
wenn du auf die ODER und ISTLEER Funktion verzichtest wird die Formel wesendlich kürzer und übersichtlicher denn beide sind auch nicht erforderlich;
wenn du für Zelle H6 folgende Formel verwendest;
{=WENN(BEREICH.VERSCHIEBEN(A6;1;MIN(WENN(ISTZAHL(A6:G6); SPALTE($A$1:$G$1)))-1)<2; BEREICH.VERSCHIEBEN(A6;0;MIN(WENN(ISTZAHL(A6:G6); SPALTE($A$1:$G$1)))-1); "") }
Gruss HermannZ

@Hermann
09.10.2007 22:11:44
Christian
Hallo Hermann,
ja, ist korrekt, aber es stand ja auch nur "als Ansatz" ;-)
MfG Christian

AW: @Christian...............
10.10.2007 08:40:20
Born
Hallo HermannZ,
auch dir herzlichen Dank für die Hilfe bei der Lösung.
Klasse, danke,
Born

Anzeige
AW: Matrix für: Zelle mit Zahl Zelle ohne Zahl
10.10.2007 08:38:16
Born
Hallo Christian,
you did it again.
Herzlichen Dank,
Born

304 Forumthreads zu ähnlichen Themen

Anzeige
Anzeige
Anzeige

Beliebteste Forumthreads (12 Monate)

Anzeige

Beliebteste Forumthreads (12 Monate)

Anzeige
Anzeige
Anzeige