Microsoft Excel

Herbers Excel/VBA-Archiv

WENN und TEXT Funktion kombiniert?

Betrifft: WENN und TEXT Funktion kombiniert? von: Bernhard
Geschrieben am: 22.02.2021 17:03:07

Hallo, ich habe eine Zelle, welche basierend auf Unterschiedlichen Zellenwerte, eine Bewertung in Textform ausgibt.

Eine dieser Textausgaben soll "Deckelung auf 0.000,00 €" lauten.

Die Formel habe ich folgendermaßen aufgebaut:

=WENN(A35>A16;"Deckelung auf "&C16/B9&" € !";"")

Leider übernimmt diese Funktion nicht das gewünschte Zahlenformat 0.000,00, sondern gibt als Bewertung "Deckelung auf 3333,3333333333 €! aus. Wie kann ich das in der Formel berücksichtigen? Ich dachte an die TEXT Funktion, wie TEXT(C2;"#'###. 00"). Funktioniert irgendwie nicht, da ich ja keinen direkten Zellenbezug übernehmen kann, sondern das Ergebnis aus eine Multiplikation zweier Zellen.

Betrifft: AW: WENN und TEXT Funktion kombiniert?
von: SF
Geschrieben am: 22.02.2021 17:06:22

Hola,

dann pack TEXT() halt um die Division.

Gruß,
steve1da

Betrifft: AW: und warum setzt nicht ...&TEXT(...) ein?
von: neopa C
Geschrieben am: 22.02.2021 17:07:44

Gruß Werner
.. , - ...

Beiträge aus dem Excel-Forum zum Thema "WENN und TEXT Funktion kombiniert?"