Microsoft Excel

Herbers Excel/VBA-Archiv

Zählen von Zellen mit 2 Werten

Betrifft: Zählen von Zellen mit 2 Werten von: Mario
Geschrieben am: 03.04.2008 10:33:51

Hallo Forumsgemeinde,

kann mir ev. jemand von euch erklären, wie ich die Anzahl von Zellen mit mehreren Argumenten zählen kann (hab schon gegoogelt finde aber nichts was passt)

Habe in Spalte A mehrere Textwerte: zB jaA, jaB, jaC usw.
In Spalte B habe ich Zahlen: 0 bis 3000

Möchte nun folgendes rausbekommen:
Zähle die Anzahl der Zellen die in Spalte A jaA haben und davon wiederum nur die, die in Spalte B größer 0 sind.

Also jaA = 37 und davon sind 20 größer 0 / Ergebnis = 20

Danke im Voraus für eure Hilfe

Mario

  

Betrifft: AW: Zählen von Zellen mit 2 Werten von: Renee
Geschrieben am: 03.04.2008 10:38:44

Hi Mario,

Bei Excel gut, müsst man sich mal das Summenprodukt und/oder das Herber-Archiv ansehen:

=SUMMENPRODUKT((A1:A10000="jaA")*(B1:B10000>0))



GreetZ Renée


  

Betrifft: soll nur jaA und nicht jaa gezählt werden von: WF
Geschrieben am: 03.04.2008 10:43:47

=SUMMENPRODUKT((IDENTISCH(A1:A99;"jaA")*(B1:B99>0)))

Salut WF


  

Betrifft: AW: Zählen von Zellen mit 2 Werten (funktioniert) von: Mario
Geschrieben am: 03.04.2008 16:46:48

Hallo Renee und WF,

danke für eure rasche Hilfe. Habe beide Varianten getestet und beide funktionieren.

Habe mich da wohl in einer Zählenwenn Funktion verrannt.

Grüße

Mario


 

Beiträge aus den Excel-Beispielen zum Thema "Zählen von Zellen mit 2 Werten"