Microsoft Excel

Herbers Excel/VBA-Archiv

Leerzellen Mittelwert

Betrifft: Leerzellen Mittelwert von: Helmuth
Geschrieben am: 11.08.2014 22:24:17

Hallo,

wie kann ich in beiliegender Tabelle die Formel in der Zelle D8 anpassen, damit auch im Falle von Leerzellen der richtigen Mittelwert errechnet wird.

Danke im voraus,

Helmuth

https://www.herber.de/bbs/user/92026.xlsx

  

Betrifft: AW: Leerzellen Mittelwert von: Daniel
Geschrieben am: 11.08.2014 22:39:57

Hi

nimm doch die Bedingung "IstZahl" als Faktor noch hinzu:

=SUMMENPRODUKT((Tabelle!A2:A9={"Katze"."Hund"})*Tabelle!C2:C9) /SUMMENPRODUKT((Tabelle!A2:A9={"Katze"."Hund"})*ISTZAHL(Tabelle!C2:C9))

Gruß Daniel


  

Betrifft: AW: Leerzellen Mittelwert von: Matze Matthias
Geschrieben am: 11.08.2014 22:46:05

Hi Daniel , Hallo Helmut,
gilt aber wirklich nur für eine "leere" Zelle , bei einer Eingabe von 0 wird dies hinfällig.

Matze


  

Betrifft: AW: Leerzellen Mittelwert von: Daniel
Geschrieben am: 11.08.2014 23:13:06

ich denke halt, wenn da 0 in der Zelle steht, dass dann diese Zeile beim Mittelwert mit berücksichtigt werden soll.
Aber das muss Helmuth nochmal genauer erklären, welche Mittelwertbildung der sich wünscht.
Es gibt ja auch in Excel zwei verschiedene Mittelwerte, die eben solche Fälle unterschiedlich betrachten.

statt dem Summenprodukt könnte man hier bei der genannten Excelversion wahrscheinlich auch auf das etwas einfachere MittelwertWenns zurückgreifen (neu seit Excel 2007)

Gruß Daniel


  

Betrifft: AW: Leerzellen Mittelwert von: Matze Matthias
Geschrieben am: 11.08.2014 23:19:54

Hi Daniel,
hatte es nur aus dem Grund herraus geschrieben, da mancher User in den Exceloptionen die NULLWERTE ausblendet, da ist die Gefahr groß das eine "0" in der Zelle schnell zum Rechenfehler wird.

Gebe dir aber ansonsten Recht, "MittelwertWenns" kenn ich gar nicht, werds mir mal bei Gelegenheit ansehen, danke

N8 Matze


  

Betrifft: MITTELWERTWENNS-Einsatz würde ... von: Luc:-?
Geschrieben am: 12.08.2014 03:00:03

…bei diesem Bsp zu einer deutlich kürzeren Fml führen, Daniel (, Matze & Helmuth),
aber, da alle angegebenen Kriterien auf jede AuswahlZelle zutreffen müssen (UND-Verknüpfung), wird bei PositivAngabe der Kriterien auch nichts ausgewählt. Da eine ODER-Verknüpfung der Kriterien nicht einstellbar zu sein scheint, würde das dazu führen, dass alle nicht zutreffenden Kriterien angegeben wdn müssten (NegativAngabe von max 127; trifft auch auf SUMMEWENNS und ZÄHLENWENNS zu!). Außerdem folgen diese (3 neuen) xlFktt ihren alten Pendants mit nur 1 Kriterium → sie akzeptieren nur ZellBereiche* als Arg1[,3ff] bzw 1,2[,4ff]! Das könnte zu einem erheblichen Aufwand führen und sehr lange Fmln verursachen. Für dieses Bsp geht's aber noch:
=MITTELWERTWENNS(B2:B9;$A2:$A9;"<>Auto";$A2:$A9;"<>Haus") bzw
=MITTELWERTWENNS(C2:C9;$A2:$A9;"<>Auto";$A2:$A9;"<>Haus")
* Mit bedingt­forma­tiertem Benutzer­Zahlen­Format und .Text ist deshalb auch nichts zu machen.
Morrn, Luc :-?


  

Betrifft: wenn aber neben Haus, Auto noch Hof, Garten ... von: neopa C (paneo)
Geschrieben am: 12.08.2014 08:52:09

Hallo Luc,

... dann ist eine MITTELWERTWENNS()-Lösung noch immer möglich, aber ich würde zu einer klsassischen MATRIXFormel mit WENN() raten.

Tabelle

 ABC
1ObjektSommerbewertungWinterbewertung
2Auto23
3Hund12
4Hof31
5Haus21
6Hund12
7Katze1 
8Katze12
9Hund12
10 12

Formeln der Tabelle
ZelleFormel
B10{=MITTELWERT(WENN(($A2:$A9={"Katze"."Hund"})*(B2:B9<>""); B2:B9))}
C10{=MITTELWERT(WENN(($A2:$A9={"Katze"."Hund"})*(C2:C9<>""); C2:C9))}
Enthält Matrixformel:
Umrandende
{ } nicht miteingeben,
sondern Formel mit STRG+SHIFT+RETURN abschließen!


Excel Tabellen im Web darstellen >> Excel Jeanie HTML 4


Gruß Werner
.. , - ...


  

Betrifft: Ja, das wäre dann wohl d.kürzeste StandardFml-... von: Luc:-?
Geschrieben am: 12.08.2014 14:23:46

…Lösung, Werner,
wie so oft bei den ganz alten XlFktt (→Standard bezogen auf AllgemeinGültigkeit)! ;-)
Aber mir ging's hier ja auch nur um die Klarstellung der Fktsweise von SUMMEWENNS, die offensichtlich doch dem Einen oder Anderen (noch) weitgehend unbekannt ist…
(Hätte ich diese Fkt pgmiert, wäre höchstwahrscheinlich sowohl UND- als auch ODER-Verknüpfung der Kriterien möglich, von der Einschränkung auf ZellBereiche ganz zu schweigen…)
Gruß, Luc :-?


 

Beiträge aus den Excel-Beispielen zum Thema "Leerzellen Mittelwert"