Live-Forum - Die aktuellen Beiträge
Anzeige
Anzeige
HERBERS
Excel-Forum (Archiv)
20+ Jahre Excel-Kompetenz: Von Anwendern, für Anwender
Inhaltsverzeichnis

alle Zahlen-/Summenkombinationen eines Wertes

alle Zahlen-/Summenkombinationen eines Wertes
02.08.2008 23:23:00
Jörg
Hallo liebe Excel-User,
folgendes Problem versuche ich mit Excel zu lösen: Mittels einer Formel sollen alle Zahlen-/Summenkombinationen eines vorgegebenen Wertes ausgegeben werden. Jede Summe besteht dabei aus 3 Summanden.
Am besten am Beispiel.
Aus der Zahl 13 sollen untereinander alle Kombinationen angegeben werden (je Zeile eine Kombination), welche in der Summe der drei anzugebenen Summanden eben die Zahl 13 ergeben.
Also
13 0 0 ___1. Kombination
0 13 0 ___2. Kombination
0 0 13 ___3. Kombination
12 2 0 ___4. Kombination
0 12 2 ___5. Kombination
2 0 12 ___6. Kombination
12 1 1 ___7. Kombination
1 12 1 ___8. Kombination
1 1 12 ___9. Kombination
usw.
Jeder Summand sollte in einer Extra-Zelle angegeben werden (nur zur Vollständigkeit).
Herzlichen Dank im Voraus für jeden Vorschlag.
Jörg

3
Beiträge zum Forumthread
Beiträge zu diesem Forumthread

Betreff
Datum
Anwender
Anzeige
AW: alle Zahlen-/Summenkombinationen eines Wertes
03.08.2008 00:55:00
Erich
Hallo Jörg,
eine Möglichkeit (Formeln von Zeile 3 nach unten kopieren):
 ABC
1  13
21300
31210
41201
51120
61111
71102
81030
91021
101012
111003
12940
13931

Formeln der Tabelle
ZelleFormel
A2=C1
B2=WENN(A2=A1;B1-1;$C$1-A2)
C2=$C$1-A2-B2
A3=A2-(ZÄHLENWENN(A$1:A2;A2)>=$C$1+1-A2)
B3=WENN(A3=A2;B2-1;$C$1-A3)
C3=$C$1-A3-B3
A4=A3-(ZÄHLENWENN(A$1:A3;A3)>=$C$1+1-A3)
B4=WENN(A4=A3;B3-1;$C$1-A4)
C4=$C$1-A4-B4

Rückmeldung wäre nett! - Grüße von Erich aus Kamp-Lintfort

Anzeige
AW: alle Zahlen-/Summenkombinationen eines Wertes
03.08.2008 02:35:28
Jörg
Hallo Erich,
vielen Dank für den Lösungsansatz.
Habe es grad ausprobiert und es funktioniert einwandfrei.
Also Danke nochmal und alles Gute.
Herzliche Grüße nach Kamp-Lintford
Jörg

AW: alle Zahlen-/Summenkombinationen eines Wertes
03.08.2008 09:24:00
Erich
Hi Jörg,
danke für deine Rückmeldung!
Hier noch eine abgewandelte Möglichkeit, etwas kürzer und mit anderer Reihenfolge:
 ABC
113  
20013
30112
40211

Formeln der Tabelle
ZelleFormel
B2=WENN(A1=A2;B1+1;0)
C2=$A$1-A2-B2
A3=A2+(ZÄHLENWENN(A$2:A2;A2)>A$1-A2)
B3=WENN(A2=A3;B2+1;0)
C3=$A$1-A3-B3
A4=A3+(ZÄHLENWENN(A$2:A3;A3)>A$1-A3)
B4=WENN(A3=A4;B3+1;0)
C4=$A$1-A4-B4

Schönen Sonntag! - Grüße von Erich aus Kamp-Lintfort
Anzeige

300 Forumthreads zu ähnlichen Themen

Anzeige
Anzeige
Anzeige
Anzeige

Beliebteste Forumthreads (12 Monate)

Anzeige

Beliebteste Forumthreads (12 Monate)

Anzeige
Anzeige
Anzeige