Summe bilden aus Datumsangaben

Bild

Betrifft: Summe bilden aus Datumsangaben
von: Daniel
Geschrieben am: 14.07.2015 09:49:00

Hallo zusammen
Ich habe ein Problem, bei dem ich alleine leider nicht weiterkomme.
In Spalte A habe ich unterschiedliche Datumsangaben (formatiert als Datum) und in Spalte B einige Zahlen (formatiert als Zahl).
Jetzt würde ich mir gerne die Summe der Zahlen von z.B. Januar 2015 errechnen lassen.
Ich habs mit folgender Formel probiert:
=SUMME(WENN((MONAT(A1:A100)=1)*(JAHR(A1:A100)=2015);B1:B100))
Leider krieg ich als Summe "0".
Woran kann das liegen? Habt Ihr ne Idee?
Danke schonmal für Eure Hilfe

Bild

Betrifft: AW: Summe bilden aus Datumsangaben
von: UweD
Geschrieben am: 14.07.2015 09:54:11
Hallo
ist eine Matrixformel.
Anstelle ENTER musst du STRG+ SHIFT+ ENTER drücken.
LG UweD

Bild

Betrifft: AW: Summe bilden aus Datumsangaben
von: UweD
Geschrieben am: 14.07.2015 09:56:56
Alternative...
=SUMMEWENNS(B:B;A:A;">=01.01.2015";A:A;"<=31.01.2015")
Normal mit ENTER abgschlossen
Gruß UweD

Bild

Betrifft: AW: Summe bilden aus Datumsangaben
von: SF
Geschrieben am: 14.07.2015 10:42:28
Hola,
dann lass #NV mit Wennfehler() ausblenden und nimm die schon vorgeschlagene Summewenns() Formel.
Gruß,
steve1da

Bild

Betrifft: AW: Summe bilden aus Datumsangaben
von: Daniel
Geschrieben am: 14.07.2015 10:51:17
Cool, hat funktioniert.
Vielen Dank nochmal
Liebe Grüsse Daniel

Bild

Betrifft: AW: Summe bilden aus Datumsangaben
von: SF
Geschrieben am: 14.07.2015 09:54:51
Hola,
du hast die Formel nicht mit Strg-Shift-Enter abgeschlossen?
Gruß,
steve1da

Bild

Betrifft: AW: Summe bilden aus Datumsangaben
von: Daniel
Geschrieben am: 14.07.2015 10:33:25
Oje, jetzt habe ich in der Datumsspalte teilweise keine Werte.
Dadurch krieg ich #Wert zurück :-(
Wie kann ich dies ausschliessen? Ich möchte nur die Summe mit einem Datumswert.
Vielen Dank nochmal.

Bild

Betrifft: AW: Summe bilden aus Datumsangaben
von: SF
Geschrieben am: 14.07.2015 10:34:59
Hola,
keine Werte wären kein Problem. Ich rate mal: die Daten werden durch eine Formel erzeugt, die "" ausgibt?
Gruß,
steve1da

Bild

Betrifft: AW: Summe bilden aus Datumsangaben
von: Daniel
Geschrieben am: 14.07.2015 10:36:03
Ja, die Daten werden über einen SVERWEIS ausgelesen und bringen teilweise #NV

Bild

Betrifft: AW: Summe bilden aus Datumsangaben
von: Daniel
Geschrieben am: 14.07.2015 09:58:30
Hi
probier mal mit SummeWenns:


=SummeWenns(B:B;A:A;">="&Datum(2015;1;1);A:A;"<"&Datum(2015;2;1))

die Eingabe erfolgt ganz normal mit ENTER.
gruß Daniel

Bild

Betrifft: AW: Summe bilden aus Datumsangaben
von: Daniel
Geschrieben am: 14.07.2015 10:12:02
Wahnsinn, so einfach.
Herzlichen Dank an alle
Gruss
Daniel

 Bild

Beiträge aus den Excel-Beispielen zum Thema "Summe bilden aus Datumsangaben"