Microsoft Excel

Herbers Excel/VBA-Archiv

Laufzeitfehler 1004

Betrifft: Laufzeitfehler 1004
von: Azubi
Geschrieben am: 23.04.2003 - 08:17:15

Hallo Excel-Team,

ich erhalte beim Starten einer Excel-Datei den Laufzeitfehler 1004. Darunter steht dann:
"Die OLEObjects-Eigenschaft des Worksheet-Objektes kann nicht zugeordnet werden."

Was ist das und wie bekommt man sowas weg ?

  

Re: Laufzeitfehler 400
von: Azubi
Geschrieben am: 23.04.2003 - 08:27:19

Hallo,

ich habe in einer Excel-Datei 2 UserForms erstellt und beide mit einer Schaltfläche ausgestattet, die wiederum Zugriff auf das andere UserForm haben. Dies jeweils mit UserForm1.Show und UserForm2.Show.
Einmal funktioniert es dass ich zwischen den Forms Umschalten kann, will ich aber dann vom 2. Form zum ersten mit der Schaltfläche zurück, erhalte ich eine Fehlermeldung:

Laufzeitfehler 400
Formular wird bereits angezeigt und kann daher nicht gebunden dargestellt werden.

Mit VB hat es immer geklappt, warum hier nicht?

  

Re: Laufzeitfehler 400
von: Nike
Geschrieben am: 23.04.2003 - 08:33:42

Hi,
etwas Code könnte nicht schaden ;-)
"Versteckst" du die UF mit hide oder
entlädtst du sie mit unload?

Versuchs mal mit
UserForm1.Visible = True

Bye

Nike

  

Re: Laufzeitfehler 400
von: Azubi
Geschrieben am: 23.04.2003 - 08:39:03

Also zum Ausblenden der UF benutz ich eine weitere Schaltfläche mit Unload Me.

Aber wo schreib ich den text UserForm1.Visible = True rein?
In den Bereich für UF oder der Scahltfläche?

 

Beiträge aus den Excel-Beispielen zum Thema "Laufzeitfehler 1004"