Umwandlung Zahl in Uhrzeitformat

Bild

Betrifft: Umwandlung Zahl in Uhrzeitformat
von: nille
Geschrieben am: 22.02.2005 19:24:58
hallo,
ich versuche gerade meine Stundenabrechnung zu machen...habe dabei eingegeben
Arbeitszeit;minus;Pause;=Ist Arbeitszeit
wie bekomme ich das hin, das mir der Computer die Zeiten in 60'er Taktung umwandelt???? heisst 60 minuten = 100%???
gruss
nille

Bild

Betrifft: k. AW auf Frage: wie 60 minuten = 100% setzen?
von: Luc
Geschrieben am: 22.02.2005 19:39:28
Hallo nille,
vielleicht solltest du deine Frage im Titel so formulieren, damit eher einer antwortet. Denn das gewöhnliche Uhrzeitformat wurde schon xmal behandelt.
Gruß Luc
Bild

Betrifft: AW: k. AW auf Frage: wie 60 minuten = 100% setzen?
von: nille
Geschrieben am: 22.02.2005 19:48:40
ich schau schon die ganze zeit nach einer Lösung!!!
vielleicht bin ich auch zu blöd
mein Problem ist wie ich das ding aufbaue hier beispiel
von zb 10,00 Uhr Arbeitsbeginn arbeitsende 22,15 Pause 1,45 will ich das endergebnis haben arbeitszeit gleich 10,30
Bild

Betrifft: AW: k. AW auf Frage: wie 60 minuten = 100% setzen?
von: Hübi
Geschrieben am: 22.02.2005 19:57:08
Hi Nille,
du musst die Zeiten mit Doppelpunkt eingeben
Tabelle5
 ABCD
110:0022:1501:4510:30
Formeln der Tabelle
D1 : =B1-A1-C1
 
Diagramm - Grafik - Excel Tabellen einfach im Web darstellen    Excel Jeanie HTML  3.0    Download  

Gruß Hübi
Bild

Betrifft: AW: danke euch Beiden!!!!
von: nille
Geschrieben am: 22.02.2005 20:25:42
Ich habe den Fehler nun mit euren Antworten gefunden.....
mann ich danke euch
Bild

Betrifft: Gibt doch noch Dankbarkeit! OK -- owT
von: Luc
Geschrieben am: 22.02.2005 20:42:42

Bild

Betrifft: AW auf Frage: wie 60 minuten = 100% setzen?
von: Luc
Geschrieben am: 22.02.2005 20:07:57
Hallo nille,
dann handelt es sich wohl doch um eine einfache Differenzstundenermittlung. Wenn dein Problem nicht das Uhrzeitformat ist, dann ist es wohl eher der Zeitraum über Mitternacht hinweg. Du musst dann das Tagesdatum mit einbeziehen. Denn...
Excel wandelt Datum und Uhrzeit in eine Dezimalzahl um, Tag/Monat/Jahr vor dem Komma, Stunde/Minute/Sekunde nach dem Komma. Damit kannst du solche Zahlen dann auch voneinander subtrahieren, du musst nur die kleinere (Arbeitsbeginn mit Tag) von der größeren (Arbeitsende mit Tag) subtrahieren. Voraussetzung ist natürlich, dass beide im Datums-/Uhrzeitformat formatiert sind. Das gilt dann selbstverständlich auch für die Pause, die dann als 1:45:00 einzutragen ist. So kannst du die auch noch abziehen und erhältst 10:30:00. In Stunden wären das 10,5. Wenn dir letzteres lieber ist, musst du das Ergebnis noch konvertieren. Dafür muss es auch Funktionen geben. Schau mal nach!
Gruß Luc
Bild

Betrifft: @Luc
von: Hübi
Geschrieben am: 22.02.2005 20:27:02
Hi Luc,
du brauchst auch über Mitternacht hinweg kein Tagesdatum ;-))
Tabelle1
 ABC
5BeginnEndeGesamt
615:0003:0012:00
719:0004:0009:00
813:0023:0010:00
905:0018:0013:00
1007:0003:0020:00
11  64:00
12 Format:[h]:mm
Formeln der Tabelle
C6 : =WENN(B6>A6;B6-A6;1-A6+B6)
C7 : =WENN(B7>A7;B7-A7;1-A7+B7)
C8 : =WENN(B8>A8;B8-A8;1-A8+B8)
C9 : =WENN(B9>A9;B9-A9;1-A9+B9)
C10 : =WENN(B10>A10;B10-A10;1-A10+B10)
C11 : =SUMME(C6:C10)
 
Diagramm - Grafik - Excel Tabellen einfach im Web darstellen    Excel Jeanie HTML  3.0    Download  

Schau mal, mit wenig Text ist alles erklärt.
Gruß Hübi
Bild

Betrifft: Kürzer
von: M@x
Geschrieben am: 22.02.2005 20:37:02
Hi,
da man davon ausgehen kann, daß die Arbeitszeit nie über 24Stunden ist
kann man auch mit der Formel über Mitternacht rechnen:
=REST(B2-A2;1)
Gruss
M@x
Bild

Betrifft: @Hübi & Max - schon klar, dass es auch...
von: Luc
Geschrieben am: 22.02.2005 20:48:23
...anders gehen kann mit etwas mehr Aufwand. Ich hätte sicher auch nicht so gerechnet wie ich geschrieben habe, aber so hat er gleich eine Erklärung, was intern passiert und findet das nächste mal die Lösung selbst.
Gruß Luc
Bild

Betrifft: AW: Kürzer
von: Hübi
Geschrieben am: 22.02.2005 20:49:26
Hi M@x,
danke, ich habe aber extra die lange Form gewählt, weil da besser nchvollziehbar ist, was passiert. (Zeit bis 24:00 + Zeit nach 24:00)
Gruß Hübi
Bild

Betrifft: AW: k. AW auf Frage: wie 60 minuten = 100% setzen?
von: FP
Geschrieben am: 22.02.2005 20:31:50
Hi nille,
falls Du es so gemeint hast:
Eingabe in Dezimalzahlen, wobei nach dem Komma die Minuten stehen:
Ergebnis im Zeitformat [hh]:mm
2 Lösungen: 1 x lang und 1 x kurz :-)

Tabelle3
 ABCDE
110,0022,301,4510:4510:45
210,002,301,4514:4514:45
Formeln der Tabelle
D1 : =KÜRZEN(B1)/24+(B1<A1)+REST(B1;1)/14,4-KÜRZEN(A1)/24-REST(A1;1)/14,4-KÜRZEN(C1)/24-REST(C1;1)/14,4
E1 : {=SUMME(KÜRZEN(A1:C1)/24*{-1.1.-1};REST(A1:C1;1)/14,4*{-1.1.-1})+(B1<A1)}
D2 : =KÜRZEN(B2)/24+(B2<A2)+REST(B2;1)/14,4-KÜRZEN(A2)/24-REST(A2;1)/14,4-KÜRZEN(C2)/24-REST(C2;1)/14,4
E2 : {=SUMME(KÜRZEN(A2:C2)/24*{-1.1.-1};REST(A2:C2;1)/14,4*{-1.1.-1})+(B2<A2)}
Enthält Matrixformel:
Umrandende
{ } nicht miteingeben,
sondern Formel mit STRG+SHIFT+RETURN abschließen!
 
Diagramm - Grafik - Excel Tabellen einfach im Web darstellen    Excel Jeanie HTML  3.0    Download  

Ich würde es aber nicht so machen...
Servus aus dem Salzkammergut
Franz
 Bild

Beiträge aus den Excel-Beispielen zum Thema "Umwandlung Zahl in Uhrzeitformat"