Microsoft Excel

Herbers Excel/VBA-Archiv

Verknüpfung, Sverweis auf Server

Betrifft: Verknüpfung, Sverweis auf Server von: Peißl
Geschrieben am: 11.09.2014 10:46:43

Hallo,
ich bastle immer noch an meinem Problem mit der Verknüpfung bzw. Sverweis auf eine Serverdatei

Verknüpfung
=+'https://qrpprod-data.xxx.net/xxx/xx/xx/[xxx.xls]xx'!$A$2

Sverweis:
=WENNFEHLER(SVERWEIS($A$5;'https://qrpprod-data.xxx.net/xxx/xx/xx/[xxx.xls]xx'!$B$1:$IB$360; VERGLEICH(D2;'https://qrpprod-data.xxx.net/xxx/xx/xx/[xxx.xls]xx'!$B$1:$IB$1;0);0);"")

Mir ist aufgefallen, dass die Daten bei geschlossener Datei nicht gefunden werden.
Kennt jemand die Ursache?

  

Betrifft: URsache von: Jack_d
Geschrieben am: 11.09.2014 12:19:16

ist, dass der sverweis das eben nicht kann (Mappe öffnen und guggen)

Grüße


  

Betrifft: AW: URsache von: Peißl
Geschrieben am: 11.09.2014 13:15:53

Danke!
Stimmt aber nicht ganz, wenn die Dateien auf dem gleichen Pfad liegen - kann er :-)


  

Betrifft: AW: Verknüpfung, Sverweis auf Server von: Ewald
Geschrieben am: 11.09.2014 21:28:17

Hallo,

diese Vorgehensweise sollte man möglichst vermeiden,da sie sehr schnell Fehler produzieren kann.

Es ist besser eine ausgeblendete Tabelle zu benutzen und diese mit der Servertabelle zu verknüpfen.

Der Sverweis geht dann auf die ausgeblendete Tabelle.

Gruß Ewald

PS. seit wann ist denn der Pfad einer Lokaldatei gleich einer Serverdatei


  

Betrifft: AW: Verknüpfung, Sverweis auf Server von: Peißl
Geschrieben am: 12.09.2014 11:25:20

Danke!
wir arbeiten nicht über lokale Dateien sondern immer über Netzwerkdateien.
Wenn Quelldatei und Arbeitsmappe im gleichen Pfad liegen und egal ob über Laufwerksbuchstaben oder Servernamen angesprochen werden klappt es.
Wenn ich auf eine andere Serverdatei zugreife, dann geht es nur wenn im Hintergrund die Quelldatei mit geöffnet wird.
Ich verstehe es nicht ganz wie das mit der ausgeblendeten Datei gemeint ist.
Und warum verursacht es Fehler? Ich habe X-Dateien die mit Verknüpfungen bzw. Verweisen gefüllt werden und hab da niemals Probleme - eben nur wenn sie auf verschiedenen Pfaden - sprich Laufwerken oder Servern liegen


 

Beiträge aus den Excel-Beispielen zum Thema "Verknüpfung, Sverweis auf Server"