Herbers Excel-Forum - das Archiv

sverweis-zugriff auf variable Tabellen???

Bild

Betrifft: sverweis-zugriff auf variable Tabellen???
von: ralle

Geschrieben am: 22.12.2006 08:12:49
Guten Morgen zusammen,
habe eine Frage an Euch!!
Ich habe eine Excel Datei mit mehreren Tabellenblättern, die von 1 bis 5 durchnummeriert sind. Im Tabellenblatt 6 möchte ich durch eingabe des sheet-Namens die entsprechenden Daten aus dem sheet übernehmen.
Meinie Formel leutet bis jetzt so:
WENN(ISTNV(SVERWEIS($B9;'1'!$B$11:$F$100;5;FALSCH));"";(SVERWEIS($B9;'1'!$B$11:$F$100;5;FALSCH)))
Schön wäre es, anstatt den Wert 1 in die Funktion einzutragen diese aus dem Feld A1 im sheet 6 genommen würde.
Folgendes sollte dann passieren:
Ich geben in das A1 (sheet6) den Wert 1 ein und es werden die Daten aus dem sheet 1 angezeigt.
Wenn ich in das Feld 4 eingebe, werden die Daten aus dem sheet 4 angezeigt.
Kann mir jemand bei meinem Problem helfen??
Ich danke Euch schon jetzt für Eure mithilfe.
Gruß
bunten
Bild

Betrifft: AW: sverweis-zugriff auf variable Tabellen???
von: Erich G.

Geschrieben am: 22.12.2006 08:36:17
Hallo bunten oder ralle,
probier mal
 CD
9sdf 

Formeln der Tabelle
ZelleFormel
C9=WENN(ISTNV(SVERWEIS($B9;INDIREKT(A1&"!$B$11:$F$100");5;FALSCH));""; SVERWEIS($B9;INDIREKT(A1&"!$B$11:$F$100");5;FALSCH))

Rückmeldung wäre nett! - Erich aus Kamp-Lintfort wünscht euch schöne Feiertage!
Bild

Betrifft: AW: sverweis-zugriff auf variable Tabellen???
von: ralle
Geschrieben am: 22.12.2006 10:29:31
Hallo Erich,
hat super funktioniert.
Danke für Deine Hilfe!!!!
Wünsche auch schöne Feiertage.
 Bild
Excel-Beispiele zum Thema "sverweis-zugriff auf variable Tabellen???"
Variablenübergabe in andere Arbeitsmappen Text aus Textbox in Variable
Einlesen von Zellinhalten in Variablen Variable in Formel einbauen
Variable in Excel-Formel einbauen. Text aus UserForm-Textbox in Variable einlesen
Variable in Zwischenablage übernehmen Variablen in einer temporären Textdatei zwischenspeichern
Zellinhalte in Verbindung mit Variablen in Textdatei schreiben Feldvariable auf Inhalt testen