Microsoft Excel

Herbers Excel/VBA-Archiv

Sverweis auf zwei Tabellen

Betrifft: Sverweis auf zwei Tabellen von: Benedikt
Geschrieben am: 08.11.2020 20:51:11

Guten Abend

Ich sollte einen Sverweis auf zwei Tabellenblätter machen
Nachfolgende Formel funktioniert, aber es ergibt sich ein Formatierungsproblem
Beispiel : Anstelle der gewünschten 37.00 erhalte ich nur 37 und die Zelle welche eigentlich auf Zahlenformat eingestellt ist lässt sich auch manuell nicht mehr mit zwei Nachkommastellen formatieren

=WENNFEHLER(SVERWEIS(C31;Daten!B5:F100;3;FALSCH);"")&WENNFEHLER(SVERWEIS(C31;Supplements!B5:F100;3; FALSCH); "")

Wo liegt der Fehler

Betrifft: AW: Sverweis auf zwei Tabellen
von: Hajo_Zi
Geschrieben am: 08.11.2020 20:57:48

Zu Deiner Datei kann ich nichts schreiben, was wohl daran liegt das ich nicht auf fremde Rechner schaue.Ich baue keine Datei nach.

Sollte die Datei verlinkt werden?

Wenn du an Stelle einer Demomappe deine Originalmappe hochladen willst, diese aber sensible Daten enthält, kannst du diese Daten
http://www.ms-office-forum.de/forum/showthread.php?t=322895
ändern.

Bilder lade ich mir nicht runter, da Excel damit nichts anfangen kann.

http://www.excel-ist-sexy.de/bilder-statt-datei/

Hochgeladene Bilder können zwar als solche in Excel importiert werden, sind jedoch bei der Lösung von Problemen nicht sehr hilfreich, da man die eigentlichen Daten nicht ohne große und zeitraubende Umwege direkt in die Tabelle übertragen kann.

Das ist nur meine Meinung zu dem Thema.

http://www.excel-ist-sexy.de/bilder-statt-datei/

Hochgeladene Bilder können zwar als solche in Excel importiert werden, sind jedoch bei der Lösung von Problemen nicht sehr hilfreich, da man die eigentlichen Daten nicht ohne große und zeitraubende Umwege direkt in die Tabelle übertragen kann.

Das ist nur meine Meinung zu dem Thema.

GrußformelHomepage

Betrifft: AW: Sverweis auf zwei Tabellen
von: SF
Geschrieben am: 08.11.2020 21:39:25

Hola,

Formate werden per Formel nicht übergeben, das musst du per TEXT() in der Formel regeln.

Gruß,
steve1da

Betrifft: Beispieltabelle inkl. Format und Problem
von: Benedikt
Geschrieben am: 09.11.2020 01:35:17

Danke für die Antworten
Im Anhang die Beispieldatei mit dem bisherigen und dem gewünschten Sverweis
(Inkl. Format und eben fehlendem Format)
https://www.herber.de/bbs/user/141418.xlsx

Betrifft: AW: Beispieltabelle inkl. Format und Problem
von: Hajo_Zi
Geschrieben am: 09.11.2020 05:20:12

Text kann Du formatieren wie Du willst es bleibt Text.

Rechnung
 EFG
162 15

verwendete Formeln
Zelle Formel Bereich N/A
E16=TYP(G16)  
G16=WENNFEHLER(SVERWEIS(C16;Daten!B5:F100;3;FALSCH);"")&WENNFEHLER(SVERWEIS(C16;Supplements!B5:F100;3;FALSCH); "")  

definierte Namen  
Name Bezieht sich auf Tabelle Z1S1-Formel
Daten=Daten!$B$5:$E$99 =Daten!R5C2:R99C5
Daten=Supplements!$B$5:$E$99Supplements=Supplements!R5C2:R99C5
http://excel-inn.de/dateien/vba_beispiele/tabellenanzeige_in_html_addin.zip
http://Hajo-Excel.de/tools.htm
XHTML-Tabelle zur Darstellung in Foren, einschl. der neuen Funktionen ab Version 2007
Add-In-Version 25.21 einschl. 64 Bit



Gruß Hajo

Betrifft: AW: Beispieltabelle inkl. Format und Problem
von: Hajo_Zi
Geschrieben am: 09.11.2020 05:54:22


Rechnung
 G
1615
17 
1818

verwendete Formeln
Zelle Formel Bereich N/A
G17=WENNFEHLER(SVERWEIS(C17;Daten!B6:F101;3;FALSCH);"")&WENNFEHLER(SVERWEIS(C17;Supplements!B6:F101;3;FALSCH); "")  
G16,G18=WENNFEHLER(SVERWEIS(C16;Daten!B3:F100;3;FALSCH);WENNFEHLER(SVERWEIS(C16;Supplements!B3:F100;3;FALSCH); ""))  

definierte Namen  
Name Bezieht sich auf Tabelle Z1S1-Formel
Daten=Daten!$B$5:$E$99 =Daten!R5C2:R99C5
Daten=Supplements!$B$5:$E$99Supplements=Supplements!R5C2:R99C5

Zahlenformate
Zelle Format Inhalt
G16 '0,00000000  15
G17 '0,00000000 
G18 '0,00000000  18
Zellen mit Format Standard werden nicht dargestellt
http://excel-inn.de/dateien/vba_beispiele/tabellenanzeige_in_html_addin.zip
http://Hajo-Excel.de/tools.htm
XHTML-Tabelle zur Darstellung in Foren, einschl. der neuen Funktionen ab Version 2007
Add-In-Version 25.21 einschl. 64 Bit



Gruß Hajo

Betrifft: AW: Beispieltabelle inkl. Format und Problem
von: Benedikt
Geschrieben am: 09.11.2020 07:52:48

Guten Morgen Hajo du Frühaufsteher....
Besten Dank für deine zwei Tabellen und die damit verbundene Arbeit. Leider kann ich jetzt nicht an dieser Sache Arbeiten. Aber beim kurzen überfliegen habe ich ehrlich gesagt den Lösungsansatz nicht gesehen.
Ich verstehe nicht das der Sverweis in Zelle G12 und G14 mit Dezimalstellen funktioniert, während die anderen Formel in G16, G18 und G20 diese Dezimalstellen nicht anzeigen?
Was ist die differenz?
=WENN(ISTNV(SVERWEIS(C12;Test.xlsx!Daten;3;0));0;SVERWEIS(C12;Test.xlsx!Daten;3;0))
=WENNFEHLER(SVERWEIS(C14;Daten!B5:E100;3;FALSCH);"")&WENNFEHLER(SVERWEIS(C14;Supplements!B5:E100;3;FALSCH); "")

Danke für deine Hilfe und Geduld

Betrifft: AW: Beispieltabelle inkl. Format und Problem
von: SF
Geschrieben am: 09.11.2020 07:58:59

Hola,

durch das "&" erzeugst du in der Zelle einen TEXT. Und den kannst du nicht mit Dezimalstellen darstellen, so einfach ist das.
=istzahl(G12) ergibt WAHR
=istzahl(G16) eribt FALSCH

Gruß,
steve1da

Beiträge aus dem Excel-Forum zum Thema "Sverweis auf zwei Tabellen"