Kontenplan



Excel-Version: 9.0 (Office 2000)
nach unten

Betrifft: Kontenplan
von: Clemens
Geschrieben am: 18.06.2002 - 10:33:51

Hi,
ich stehe gerade vor folgendem Problem:
Ich habe eine Datei, in der Buchungssätze aufgelistet sind. Leider sind aber nur Kontennummern verzeichnet. In einer zweiten Datei ist nun der Kontenplan aufgeführt. Nun versuche ich, in der ersten Datei eine Formel zu finden, die ähnlich der sumif (summewenn) Funktion funktioniert.
Die Funktion soll die Spalte mit den Kontennummern im Kontenplan durchlaufen und bei Übereinstimmung mit der Kontennummer in der ersten Datei den zugehörigen Kontentext, der in der Spalte daneben (im Kontenplan) steht, übernehmen.
Ich doktere hier schon eine ganze Weile herum. Da ich bislang keine Formel gefunden habe, bin ich mittlerweile schon auf VBA umgestiegen. Leider bisland auch ohne Erfolg.
Kann mir vielleicht jemand von euch helfen???
Vielen Dank
Clemens
nach oben   nach unten

Re: Kontenplan
von: Robert Werner
Geschrieben am: 18.06.2002 - 10:57:09

Mit der Funktion SVerweis müsstest du das hinkriegen.

Gruß
Robert


nach oben   nach unten

Re: Kontenplan
von: Arnim
Geschrieben am: 18.06.2002 - 11:21:09

Hallo Clemens,
genau wie Robert schreibt:
in Spalte B stehen die Kto.-Nrn., in Spalte C soll die Kontobezeichnung stehen:
In Tabelle 2 stehen in Spalte A die Nummern und in B der Kontoname:
Formel in B2:
=WENN(B2<>"";SVERWEIS(B2;Tabelle2!A2:B100;2;0);"")
und runterkopieren.
Gruß Arnim
nach oben   nach unten

Re: Kontenplan
von: Clemens
Geschrieben am: 18.06.2002 - 11:29:22

Hi Robert,
vielen Dank für den Hinweis. Mein Problem ist nun, dass ich die englische Version von Excel nutze und ich nichts finden kann, was irgendwie im übersetzten Sinne auf SVerweis schließen läßt. Kannst Du mir in der Hinsicht vielleicht noch einen Tipp geben?
Vielen Dank,
Clemens

nach oben   nach unten

Re: Kontenplan
von: Clemens
Geschrieben am: 18.06.2002 - 11:34:01

Danke Arnim!!!
Habe bloß leider eine englische Version und komme mit dem SVerweis nicht weiter. Ich hoffe, DU hast da noch eine Lösung für dieses Sprachproblem.;-)))
Vielen Dank aber schon einmal soweit,
Clemens

nach oben   nach unten

Müßte =VLOOKUP() sein! oT
von: Arnim
Geschrieben am: 18.06.2002 - 11:50:05

x

nach oben   nach unten

Noch etwas!
von: Arnim
Geschrieben am: 18.06.2002 - 12:33:51

Hallo Clemens,
im Grunde ist meine Formel unvollständig! Um Irritationen beim Runterkopieren auszuschließen:
Die Zeilenzahlen von Tabelle2 müssen absolut gesetzt werden, also lautet die Formel (in deutscher Fassung)
=WENN(B2<>"";SVERWEIS(B2;Tabelle2!A$1:B$100;2;0);"")

Gruß Arnim

nach oben   nach unten

Re: Müßte =VLOOKUP() sein! oT
von: Clemens
Geschrieben am: 18.06.2002 - 13:28:42

Danke nochmals!!!
Das Problem ist nur, dass die Formel zu dem Ergebnis
#N/A
führt. Das verstehe ich nun gar nicht...
CU
Clemens

nach oben   nach unten

Re: Müßte =VLOOKUP() sein! oT
von: Arnim
Geschrieben am: 18.06.2002 - 13:45:23

Hallo Clemens,
verstehe ich nicht! Möglich wäre, daß die "0" (Null) in der Formel in der engl.Version nicht erkannt wird. Sie steht für FALSCH. Nun weiß ich nicht, wie der analoge Ausdruck in Englisch heißt.
Hast Du eigentlich meine Korrektur (Beitrag "Noch etwas") berücksichtigt?
Ich rate Dir, mache mal ein separates Beispiel nicht nach Deiner Vorlage, sondern nach meinem Beispiel. Ob es da klappt!??
Gruß Arnim

nach oben   nach unten

Re: Müßte =VLOOKUP() sein! oT
von: Clemens
Geschrieben am: 18.06.2002 - 13:54:45

Hallo Arnim,
ich habe bereits die Formel anhand des Formelassistenten angepaßt, so dass sie auch in der englischen Version korrekt sein müßte. Deinen Hinweis habe ich auch berücksichtigt. Daher weiß ich nun nicht, wo der Fehler noch liegen kann. Vielen Dank aber für Deine Hilfe. Jetzt weiss ich zumindest, wei es gehen müßte.;-))
Danke,
Clemens

nach oben   nach unten

Weitere Grübelei
von: Arnim
Geschrieben am: 18.06.2002 - 14:13:45

Hallo Clemens,

also jetzt habe ich die Formel mal "übersetzt" - weiß nicht, ob das stimmt!
=IF(B2<>"";VLOOKUP(B2;Sheet2!A$2:B$100;2;FALSE);"")
Noch eine Fehlerquelle wäre, wenn Tabelle2 (oder Sheet2) bei Dir einen anderen Namen hat; dann mußt Du auch entsprechend diesen Namen anstatt "Tabelle2" nehmen. Und das Ausrufungszeichen nicht vegessen!!
Gruß Arnim

nach oben   nach unten

Re: Weitere Grübelei
von: Clemens
Geschrieben am: 18.06.2002 - 14:31:41

Hi Arnim,
die Formel sieht bei mir mittlerweile schon so aus (auch inklusive der notwendigen Anpassungen;-))). Ich denke Mal, dass es irgendwie mit einer Ordnung der Kontennumern oder mit den Zellformaten zusammen hängt. Aber ich krieg es einfach nicht raus...
CU
Clemens

nach oben   nach unten

Re: Weitere Grübelei
von: Arnim
Geschrieben am: 18.06.2002 - 16:56:25

Hallo Clemens,

stell' doch mal ein oder zwei Nummern und entsprechenden Text (kann ja abgewandelt sein) hier ins Forum, damit man es nachvollziehen kann! - Kannst mir auch ein Beispiel schicken!

Gruß Arnim


 nach oben

Beiträge aus den Excel-Beispielen zum Thema "bedingtes kopieren"