Microsoft Excel

Herbers Excel/VBA-Archiv

Datei zu groß, weil viele Formel hinterlegt sind | Herbers Excel-Forum


Betrifft: Datei zu groß, weil viele Formel hinterlegt sind von: Alex
Geschrieben am: 19.10.2008 13:37:08

Folgendes Problem:

Ich hab in einigen Tabellenblättern Formeln hinterlegt,
die sich auf andere Tabellenblätter beziehen.

Zum Beispiel:

=WENN(Konfiguration!$D11="nein";"";WENN(ODER(Konfiguration!$B11="G";Konfiguration!$B11="U");""; WENN(Konfiguration!$O11="nein";"";WENN(BR12="ja";"ja";WENN(UND(Konfiguration!$M11="teilweise"; LINKS(BR12;3)="ja,");"ja";WENN(UND(Konfiguration!$M11="teilweise";LINKS(BR12;5)="nein,");"nein"; WENN(UND(Konfiguration!$M11="voll";BR12="ja");"ja";"nein")))))))

Mein Problem ist nicht das nur ein Formel hinterlegt ist, sondern pro
Tabellenblatt ca. 3000. Dadurch erbift sich eine Größe nur durch dieses Tabellenblatt
von ca. 8 MB. Ich benötige allerdings ca. 40-50 Tabellenblätter, damit wäre die Datei
420-500 MB groß.

Lässt sich die Dateigröße mit einem Trick reduzieren?

Vielen Dank für deine Hilfe

Alex

  

Betrifft: AW: Datei zu groß, weil viele Formel hinterlegt sind von: Gerd
Geschrieben am: 19.10.2008 13:50:18

Hi,

da ist was faul mit deiner mappe, die darf max. 1 MB groß sein, bei 3000 Formaln.

mfg Gerd


  

Betrifft: AW: Datei zu groß, weil viele Formel hinterlegt sind von: Alex
Geschrieben am: 19.10.2008 14:09:40

die Datei ist leider zu groß um es ins Forum zu stellen.

Deshalb auf meiner Homepage:

https://ssl.maklerexperten.de/s/mx/m.php?n=x

Dateiname Test.zip

Die Formeln stehen in den Spalten K;L;M und alle vier darauffolgenden Spalten.

Gruß

Alex


  

Betrifft: AW: Datei zu groß, weil viele Formel hinterlegt sind von: Alex
Geschrieben am: 19.10.2008 15:50:14

Korrektur:

Die Datei hat nicht 3000 Tausend Formeln, sondern knapp 30000.

Ist es normal, dass die Datei dann so groß wird
oder lässt sich die Dateigröße reduzieren?

Danke

Alex


  

Betrifft: AW: Datei zu groß, weil viele Formel hinterlegt sind von: Gerd
Geschrieben am: 19.10.2008 22:10:37

Hi,

wenn man wüsste, welchem Zweck die tausenden Formeln dienen, könnte man ev.
eine andere Lösung finden, aber so...

mfg Gerd


  

Betrifft: AW: Datei zu groß, weil viele Formel hinterlegt sind von: Daniel
Geschrieben am: 19.10.2008 23:55:00

Hi

wenn es wirklich die Formeln sind, die die Dateigrösse verursachen, dann könnte man, falls die Formeln nicht ständig neu berechnet werden müssen, ein kleines Makro schreiben, das folgendes macht:

1. in alle Zellen die entsprechende Formel reinschreibt
2. per KOPIEREN - INHALTE EINFÜGEN - WERTE in den Zellen die Fix-Werte reinschreibt.

damit wird deine Tabelle zwar statisch, dh. für jede neuberechnung muss du das Makro starten, aber der Platzverbrauch sollte deutlich kleiner sein und Aktionen wie "Autofiltern" und "Sortieren" sollten auch schneller ablaufen.

Gruß, Daniel


Beiträge aus den Excel-Beispielen zum Thema "Datei zu groß, weil viele Formel hinterlegt sind"