Vergleich+Verweis in VBA



Excel-Version: 97
  

Re: Vergleich+Verweis in VBA

von: Peter H. Erdmann
Geschrieben am: 16.04.2002 - 14:50:00


Hallo Nora

hier der Code

=WENN(ISTNV(SVERWEIS(A2;Tabelle2!A:E;5;FALSCH));0;SVERWEIS(A2;Tabelle2!A:E;5;FALSCH))

Gruß aus dem Land der Bayern
Peter

  

Re: Vergleich+Verweis in VBA

von: Nora
Geschrieben am: 16.04.2002 - 14:59:37


Das das so geht weiß ich, aber ich will nicht diese Befehle in jede Zelle schreiben. Geht das nicht über VBA mit einer Schleife?

nach unten

Betrifft: Vergleich+Verweis in VBA
von: Nora
Geschrieben am: 16.04.2002 - 13:38:46

Hallöchen!!!!

Ich bräucht mal wieder Hilfe:

Brauch den VBA-Quelltext zu:

Wenn der String aus meiner Tabelle1-Spalte1-Zeilek, in einer anderen Datei (Tabelle2)-Spalte1-Zeilel vorhanden ist,
dann gib den Wert aus Tabelle2-Spalte5-Zeilel in meine Tabelle1-Spalte3-Zeilek wieder,
sonst schreib in Tabelle1-Spalte3-Zeilek eine 0.

Tabelle 1

____1_______2____3________________________________
1___A5BH12__..___12,5=Überrtag aus Tabelle2 Spalte 5
2___A5BH25__..___10,4=Überrtag aus Tabelle2 Spalte 5
3___A5BH88__..______0=da in Tab2 A5BH88 nicht vorkommt
4___A5BG67__..___38,0=Überrtag aus Tabelle2 Spalte 5
k....................


Tabelle 2

____1_______2____3____4____5___________
1___A5BH08__..___..___..___34,9
2___A5BH12__..___..___..___12,5
3___A5BH13__..___..___..___08,5
4___A5BH25__..___..___..___10,4
5___A5BG67__..___..___..___38,0
l.................................

Würd mich auf Antwort freuen.
Nora


 nach oben

Beiträge aus den Excel-Beispielen zum Thema "Zellen nach bestimmten Inhalt durchsuchen"