SummeWenn mit Bedingung nicht leer | Herbers Excel-Forum


Betrifft: SummeWenn mit Bedingung nicht leer
von: Paul
Geschrieben am: 10.07.2012 20:35:03

Hallo,
habe mal wiederein Problem
möchte mit "SummeWenn" die Werte der Spalte A addieren, die in der gleichen Zeile in Spalte B eine Zahl (auch "0) stehen haben, bekomme aber kein Suchkriterium hin, dass das funktioniert, mein Problem ist die "0"
SUMMEWENN(B1:B40;?????;A1:A40)
Hat da jemand eine Idee
Gruß Paul

Betrifft: AW: SummeWenn mit Bedingung nicht leer
von: Josef Ehrensberger
Geschrieben am: 10.07.2012 20:48:00


Hallo Paul,
zwei Möglichkeiten.
Tabelle1

 ABCDE
118 33 
2110 33 
313   
410   
51    
611   
719   
816   
917   
1015   
111    
1211   
1311   
1414   
151    
1611   
1710   
1819   
1916   
2017   
211    
2217   
2313   
2419   
2510   
2610   
2714   
281    
2914   
30110   
3119   
3219   
331    
3419   
3510   
3618   
37110   
381    
3910   
4015   
41     
42     
43     

Formeln der Tabelle
ZelleFormel
D1=SUMMEWENN(B1:B40;">=0";A1:A40)
D2=SUMMENPRODUKT(ISTZAHL(B1:B40)*A1:A40)


Excel Tabellen im Web darstellen >> Excel Jeanie HTML 4

« Gruß Sepp »


Betrifft: AW: SummeWenn mit Bedingung nicht leer
von: Paul
Geschrieben am: 10.07.2012 21:31:50
Hallo Josef,
die Formel in D1 ist soweit i.O. nur berücksichtigt sie evtl auch vorkommende negative Werte nicht
bei der Formel in D2 bekomme ich "#Wert!"
Gruß Paul

Betrifft: AW: SummeWenn mit Bedingung nicht leer
von: Josef Ehrensberger
Geschrieben am: 10.07.2012 21:40:44


Hallo Paul,
Lust auf ein Ratespiel?
Ich nicht, also lade deine Tabelle hoch.

« Gruß Sepp »


Betrifft: AW: SummeWenn mit Bedingung nicht leer
von: Paul
Geschrieben am: 10.07.2012 22:20:21
Hallo Josef
hier das Beispiel
https://www.herber.de/bbs/user/80925.xls
beim Aufaddieren der Spalte A sollen die Werte berücksichtigt werden die in Spalte B eine Zahl stehen haben. Wobei die Zahl eineZahl zwischen -10000 und +10000 sein kann
Gruß Paul

Betrifft: AW: SummeWenn mit Bedingung nicht leer
von: Josef Ehrensberger
Geschrieben am: 10.07.2012 22:42:58


Hallo Paul,
und wo ist das Problem?
Tabelle1

 ABCDEFGH
419840Wunschergebniss in Spalte A unter Berücksichtung der Werte in Spalte B      
42        
4398       
44        

Formeln der Tabelle
ZelleFormel
A43=SUMMENPRODUKT(ISTZAHL(B1:B40)*A1:A40)


Excel Tabellen im Web darstellen >> Excel Jeanie HTML 4

« Gruß Sepp »


Beiträge aus den Excel-Beispielen zum Thema "SummeWenn mit Bedingung nicht leer"