Microsoft Excel

Herbers Excel/VBA-Archiv

Formel zählenwenns?


Betrifft: Formel zählenwenns? von: lemmy
Geschrieben am: 23.10.2019 11:35:50

Hallo zusammen,
leider finde ich meinen Formelfehler nicht!
Ich habe in einer Spalte C Nummern als Text abgelegt.
Hier möchte ich festellen wievielmal eine Nr. (Text) vorhanden ist.
Allerdings ist das Ergebenis nicht so wie erwartet. Mit der Formel =zählenwenns komme ich nicht zum richtigen Ergebnis!
Ist die Fromel falsch oder die Funktion nicht richtig?

In Spalte F und I habe ich testweise weitere Nr./ Zahlen/text angelegt und gezählt hier scheint alles o.k zu sein.
https://www.herber.de/bbs/user/132682.xlsx

LG
Lemmy

  

Betrifft: AW: Formel zählenwenns? von: SF
Geschrieben am: 23.10.2019 11:42:00

Hola,

Zählenwenn betrachtet nur die ersten 15 Stellen.

=SUMMENPRODUKT((C$6:C$13=C6)*1)
Gruß,
steve1da


  

Betrifft: AW: Formel zählenwenns? von: Daniel
Geschrieben am: 23.10.2019 11:58:32

Hi
beim ZählenWenn findet, wenn der Suchbegriff wie eine Zahl aussieht IMMER die Umwandlung in eine Zahl statt, auch wenn die Ausgangswerte als Text formatiert sind.
Damit verbunden ist aber die Rundung auf 15 Stellen (die Rechengenauigkeit von Excel)

wenn man beim ZählenWenn(s) oder SummeWenn(s) bleiben will, kann man die Umwandlung in eine Zahl verhindern, in dem man ein Jokerzeichen angängt, z.B. den "*" für beliebig viele Zeichen.

=ZÄHLENWENNS($C$6:$C13;C6&"*")

solltest du aber nur machen, wenn die Nummern alle gleich lang sind.
können die Längen unterschiedlich sein, besteht wieder die Gefahr, dass das Ergebnis verfälscht wird.
dann entweder das Summenprodukt von SF einsetzen, oder so:
=ZÄHLENWENNS($C$6:$C13;"?"&Teil(C6;2;99);$C$6:$C$13;Links(C6;1)&"*")
Gruß Daniel


  

Betrifft: AW: Formel zählenwenns? von: lemmy
Geschrieben am: 23.10.2019 13:07:20

Hallo Ihr beide!

Super! den Fehler hättte ich nicht gefunden !
Danke Danke!

LG
Lemmy


Beiträge aus dem Excel-Forum zum Thema "Formel zählenwenns?"