Anzeige
Anzeige
HERBERS
Excel-Forum (Archiv)
20+ Jahre Excel-Kompetenz: Von Anwendern, für Anwender
360to364
360to364
Aktuelles Verzeichnis
Verzeichnis Index
Verzeichnis Index
Übersicht Verzeichnisse
Inhaltsverzeichnis

zugehörige KW eines Monats

zugehörige KW eines Monats
08.01.2004 11:04:34
Wolfi
Hallo @ All,
brauch leider mal wieder etwas Unterstützung:
Gibt es eine Formel mit der es möglich ist aus einem Monat jeweils immer den ersten Tag der entsprechenden KW eines Monats zuermitteln.
Beispiel:
in einer Zeile steht September 2002.
Daraus soll jetzt die jeweiligen ersten einer KW ermittel werten also:
2.9.2002
9.9.2002
16.9.2002
23.9.2002
30.9.2002
geht das ?
Gruß und Danke
Wolfi

7
Beiträge zum Forumthread
Beiträge zu diesem Forumthread

Betreff
Datum
Anwender
Anzeige
AW: zugehörige KW eines Monats
08.01.2004 11:13:30
Karl-Otto Reimann
Hallo Wolfi
Dein Datum steht in A2, die Formel in B2:
=KÜRZEN((A2-WOCHENTAG(A2;2)-DATUM(JAHR(A2+4-WOCHENTAG(A2;2));1;-10))/7)&". KW"
Gruß KO
AW: zugehörige KW eines Monats
08.01.2004 11:29:52
Wolfi
Hallo KO,
die Formel ermittelt jetzt die erste KW des Monats als vom obrigen Beispiel ist das kW 36
ich brauch aber jeweils den ersten Tag der KW eines Monats also wäre das dann der 2.9.2002.
Gruß Wolfi
www.excelformeln.de oT
08.01.2004 11:38:32
Ulf
oT
AW: zugehörige KW eines Monats
08.01.2004 12:00:27
Gert Seler
Hallo Wolfi,
mit =WENN(WOCHENTAG(B2;2)=1;KALENDERWOCHE(B2;2);"")
das Datum steht in B2 (z.Bspl. 05.01.2004) Ergebnis müßte 2 lauten. Die Anweisung
(B2;2) besagt, das der erste Tag der Woche am "Montag" und nicht wie Standard am
"Sonntag", ist (DIN und EU-Norm).
Die Formel über die ganze Datenreihe kopieren.
mfg
Gert
Anzeige
AW: zugehörige KW eines Monats
08.01.2004 12:49:50
Wolfi
Hallo Gert,
das Funzt aber leider brauch ich den umgekerhrte Weg:
ich hab nicht das gesamte Datum also 05.01.2004 sonder Januar 2004 und beötige das Datum für die jeweiligen ersten Tage der KW die zu dem Monat gehören.
Gruß Wolfi
hab eine Teillösung gefunden
08.01.2004 13:00:53
Wolfi
In j3 steht Monat und das Jahr
In C4 steht die KW
=DATUM(JAHR(J3),1,7*C4-3-WOCHENTAG(DATUM(JAHR(J3),,),3))
Damit erhalte ich den ersten Tag (Montag) der ersten KW des Monats.
Jetzt fehlen mir nur noch die weiteren Tage der anderen KW des Monats
Gruß Wolfi
AW: zugehörige KW eines Monats
08.01.2004 12:06:45
Gert Seler
Hallo Wolfi,
mit : =WENN(WOCHENTAG(B2;2)=1;KALENDERWOCHE(B2;2);"")
geht es einfacher.
Formel entsprechend kopieren. Datum steht hier in B2.
mfg
Gert
Anzeige

307 Forumthreads zu ähnlichen Themen

Anzeige
Anzeige
Anzeige

Beliebteste Forumthreads (12 Monate)

Anzeige

Beliebteste Forumthreads (12 Monate)

Anzeige
Anzeige
Anzeige