Anzeige
Anzeige
HERBERS
Excel-Forum (Archiv)
20+ Jahre Excel-Kompetenz: Von Anwendern, für Anwender
Inhaltsverzeichnis

dynamisches Datum anhand Kalenderwoche

dynamisches Datum anhand Kalenderwoche
26.03.2009 19:16:14
SteffenS
Hallo Zusammen,
ich möchte gern eine variable Dateneingabe mit Berücksichtigung der Kalenderwoche haben.
in der ersten Spalte steht immer die Summer der folgenden 5 Kalendertage.
In der Überschrift der Spalten B:F sollen dann in Zeile 3 das Datum sethen.
Das heißt in Kalenderwoche 1 von 2009 gibt es nur den 1.1 und 2.1
in Kalenderwoche 2 gibt es aber den 5.1 - 9.1.
Bei meiner Ansicht gehe ich nur von den 5 Arbeitstagen ohne Sa und So.
Zum besseren Verständnis habe ich eine Beispieldatei unter:
https://www.herber.de/bbs/user/60716.xls
hinterlegt.
Ist das was ich will formeltechnisch überhaupt möglich?
Meine "Leeren" Spalten blende ich das mit Hilfe eines Makros aus.
Danke im Voraus.
MFG
Steffen Schmerler

2
Beiträge zum Forumthread
Beiträge zu diesem Forumthread

Betreff
Datum
Anwender
Anzeige
AW: dynamisches Datum anhand Kalenderwoche
26.03.2009 19:56:34
Josef
Hallo Steffen,
http://www.excelformeln.de/formeln.html?welcher=186
Tabelle1

 ABCDEFGHIJKL
2            
3    01. 01.200902. 01.2009 05. 01.200906. 01.200907. 01.200908. 01.200909. 01.2009
4KW0112345KW0212345
520000           
64000           
7            
8            
9            
10            
11            
12            
13            
14            
15            
16            
17            
18            
19            
20            
21            
22Jahr:2009          

Formeln der Tabelle
ZelleFormel
B3=WENN(JAHR(("4.1."&$B$22)+$A$4*7-7-REST("2.1."&$B$22;7)+SPALTE(A1)-1)=$B$22;("4.1."&$B$22)+$A$4*7-7-REST("2.1."&$B$22;7)+SPALTE(A1)-1;"")
C3=WENN(JAHR(("4.1."&$B$22)+$A$4*7-7-REST("2.1."&$B$22;7)+SPALTE(B1)-1)=$B$22;("4.1."&$B$22)+$A$4*7-7-REST("2.1."&$B$22;7)+SPALTE(B1)-1;"")
D3=WENN(JAHR(("4.1."&$B$22)+$A$4*7-7-REST("2.1."&$B$22;7)+SPALTE(C1)-1)=$B$22;("4.1."&$B$22)+$A$4*7-7-REST("2.1."&$B$22;7)+SPALTE(C1)-1;"")
E3=WENN(JAHR(("4.1."&$B$22)+$A$4*7-7-REST("2.1."&$B$22;7)+SPALTE(D1)-1)=$B$22;("4.1."&$B$22)+$A$4*7-7-REST("2.1."&$B$22;7)+SPALTE(D1)-1;"")
F3=WENN(JAHR(("4.1."&$B$22)+$A$4*7-7-REST("2.1."&$B$22;7)+SPALTE(E1)-1)=$B$22;("4.1."&$B$22)+$A$4*7-7-REST("2.1."&$B$22;7)+SPALTE(E1)-1;"")
H3=WENN(JAHR(("4.1."&$B$22)+$G$4*7-7-REST("2.1."&$B$22;7)+SPALTE(A1)-1)=$B$22;("4.1."&$B$22)+$G$4*7-7-REST("2.1."&$B$22;7)+SPALTE(A1)-1;"")
I3=WENN(JAHR(("4.1."&$B$22)+$G$4*7-7-REST("2.1."&$B$22;7)+SPALTE(B1)-1)=$B$22;("4.1."&$B$22)+$G$4*7-7-REST("2.1."&$B$22;7)+SPALTE(B1)-1;"")
J3=WENN(JAHR(("4.1."&$B$22)+$G$4*7-7-REST("2.1."&$B$22;7)+SPALTE(C1)-1)=$B$22;("4.1."&$B$22)+$G$4*7-7-REST("2.1."&$B$22;7)+SPALTE(C1)-1;"")
K3=WENN(JAHR(("4.1."&$B$22)+$G$4*7-7-REST("2.1."&$B$22;7)+SPALTE(D1)-1)=$B$22;("4.1."&$B$22)+$G$4*7-7-REST("2.1."&$B$22;7)+SPALTE(D1)-1;"")
L3=WENN(JAHR(("4.1."&$B$22)+$G$4*7-7-REST("2.1."&$B$22;7)+SPALTE(E1)-1)=$B$22;("4.1."&$B$22)+$G$4*7-7-REST("2.1."&$B$22;7)+SPALTE(E1)-1;"")


Excel Tabellen im Web darstellen >> Excel Jeanie HTML 4
Gruß Sepp

Anzeige
Danke für die Antwort
27.03.2009 11:41:05
SteffenS
das hat mir geholfen.
Das Datum ist schon eine nicht ganz einfache Sache....
mfg
steffen

304 Forumthreads zu ähnlichen Themen

Anzeige
Anzeige
Anzeige
Anzeige

Beliebteste Forumthreads (12 Monate)

Anzeige

Beliebteste Forumthreads (12 Monate)

Anzeige
Anzeige
Anzeige