Microsoft Excel

Herbers Excel/VBA-Archiv

Anzahl der Samstage/Sonntage in einem Zeitraum

Betrifft: Anzahl der Samstage/Sonntage in einem Zeitraum von: Proximus
Geschrieben am: 20.08.2004 15:01:27

Hallo,

kann mir jemand helfen eine Formel auf zu stellen, mit der man alle Samstage bzw. Sonntage in einem Zeitraum zählen kann?!
Ich muss dazu sagen ich beschäftige mich erst seid einer Woche intensiv mit Excel bzw. ich nehme Open Office 1.0 und hab daher noch keine richtige Ahnung von.
Ich hab schon einmal eine Lösung mit VBA gefunden, aber damit komm ich nicht klar. Geht das überhaupt auch mit Open Office?
Ich würde mich sehr freuen wenn ihr mir hier weiter helfen könnt!

DANKE im vorraus!

Proximus

  


Betrifft: AW: Anzahl der Samstage/Sonntage in einem Zeitraum von: udo
Geschrieben am: 20.08.2004 15:57:50

Hallo Proxi ...

https://www.herber.de/bbs/user/9877.xls

viel Spass damit

udo

;-)


  


Betrifft: AW: Anzahl der Samstage/Sonntage in einem Zeitraum von: udo
Geschrieben am: 20.08.2004 16:00:34

nochwas ...

=Tag(1) ist zB Sonntag
=Tag(2) Mo
usw..

setze die Formel irgendwo in ne Zelle rein und zähle dann die Zahlenwerte mit der
SUMMEWENN Formel um ... siehst ja im beispiel


:-)


  


Betrifft: AW: Anzahl der Samstage/Sonntage in einem Zeitraum von: Dieter Maj
Geschrieben am: 20.08.2004 15:58:12

Hallo Proximus
hab hier eine kleine Function

Aufruf der Funktion:
=anzahlsaso(A1;A33)
unter der Annahme, dass in A1 das Anfangsdatum und in A33 das Enddatum steht.

Function AnzahlSASO(ab As Date, eb As Date)
Dim z
Dim tag
Dim anzahl
z = eb + 1 - ab
For tag = 1 To z
If WeekDay(ab) = 6 Or WeekDay(ab) = 7 Then anzahl = anzahl + 1
ab = ab + 1
Next
AnzahlSASO = anzahl
End Function



Du kannst natürlich auch anstatt den Zellbezügen, Datumseingaben machen

Gruß Dieter


  


Betrifft: AW: Anzahl der Samstage/Sonntage in einem Zeitraum von: HermannZ
Geschrieben am: 20.08.2004 18:35:55

hallo Proximus

oder so:
DatumZeitMuster
 ABCD
133Datum von12.08.2004bis29.09.2004
134    
135Samstag 114.08.2004  
136Samstag 221.08.2004  
137Samstag 328.08.2004  
138Samstag 404.09.2004  
139Samstag 511.09.2004  
140Samstag 618.09.2004  
141Samstag 725.09.2004  
142    
143    
144 usw.  
Formeln der Tabelle
A135 : =WENN(B135="";"";TEXT(WOCHENTAG(B135);"TTTT")&" "&ZEILE()-134)
B135 : =B133+6-WOCHENTAG(B133;2)
A136 : =WENN(B136="";"";TEXT(WOCHENTAG(B136);"TTTT")&" "&ZEILE()-134)
B136 : =WENN(B135="";"";WENN(B135+7<$D$133;B135+7;""))
A137 : =WENN(B137="";"";TEXT(WOCHENTAG(B137);"TTTT")&" "&ZEILE()-134)
B137 : =WENN(B136="";"";WENN(B136+7<$D$133;B136+7;""))
A138 : =WENN(B138="";"";TEXT(WOCHENTAG(B138);"TTTT")&" "&ZEILE()-134)
B138 : =WENN(B137="";"";WENN(B137+7<$D$133;B137+7;""))
A139 : =WENN(B139="";"";TEXT(WOCHENTAG(B139);"TTTT")&" "&ZEILE()-134)
B139 : =WENN(B138="";"";WENN(B138+7<$D$133;B138+7;""))
A140 : =WENN(B140="";"";TEXT(WOCHENTAG(B140);"TTTT")&" "&ZEILE()-134)
B140 : =WENN(B139="";"";WENN(B139+7<$D$133;B139+7;""))
A141 : =WENN(B141="";"";TEXT(WOCHENTAG(B141);"TTTT")&" "&ZEILE()-134)
B141 : =WENN(B140="";"";WENN(B140+7<$D$133;B140+7;""))
A142 : =WENN(B142="";"";TEXT(WOCHENTAG(B142);"TTTT")&" "&ZEILE()-134)
B142 : =WENN(B141="";"";WENN(B141+7<$D$133;B141+7;""))
A143 : =WENN(B143="";"";TEXT(WOCHENTAG(B143);"TTTT")&" "&ZEILE()-134)
B143 : =WENN(B142="";"";WENN(B142+7<$D$133;B142+7;""))
 
Diagramm - Grafik - Excel Tabellen einfach im Web darstellen    Excel Jeanie HTML  3.0    Download  


Gruß hermann


 

Beiträge aus den Excel-Beispielen zum Thema "Anzahl der Samstage/Sonntage in einem Zeitraum"