Microsoft Excel

Herbers Excel/VBA-Archiv

WENN(ISTFEHLER(...)) bei Matrixformel | Herbers Excel-Forum


Betrifft: WENN(ISTFEHLER(...)) bei Matrixformel von: MikeS
Geschrieben am: 21.10.2008 11:21:23

Hallo,

mit der nachstehenden Matrixformel berechne ich den Mittelwert eines bestimmten Bereiches. Wie kann ich die Funktion WENN(ISTFEHLER()) in die Formel einbauen, damit Fehler, z.B. #DIV/0! mit einem Blank angezeigt werden?

{=MITTELWERT(WENN((MONAT(BereichA)=MONAT($A2))*(JAHR(BereichA)=JAHR($A2))*(BereichA<>"");BereichB))}

Vielen Dank für Eure Hilfe!

Ciao MikeS

  

Betrifft: AW: WENN(ISTFEHLER(...)) bei Matrixformel von: Matthias L
Geschrieben am: 21.10.2008 11:27:14

Hallo

{=WENN(ISTFEHLER(MITTELWERT(WENN((MONAT(BereichA)=MONAT($A2))*(JAHR(BereichA)=JAHR($A2))*(BereichA<>"");BereichB)));"";MITTELWERT(WENN((MONAT(BereichA)=MONAT($A2))*(JAHR(BereichA)=JAHR($A2))*(BereichA<>"");BereichB)))}

Gruß Matthias


  

Betrifft: AW: WENN(ISTFEHLER(...)) bei Matrixformel von: David
Geschrieben am: 21.10.2008 11:27:29

Hi Mike,

genauso wie mit jeder anderen Formel auch:

{=WENN(ISTFEHLER(MITTELWERT(WENN((MONAT(BereichA)=MONAT($A2))*(JAHR(BereichA)=JAHR($A2)) *(BereichA<>"");BereichB)));"";MITTELWERT(WENN((MONAT(BereichA)=MONAT($A2))*(JAHR(BereichA)=JAHR($A2) )*(BereichA<>"");BereichB)) }

Gruß
David


  

Betrifft: AW: WENN(ISTFEHLER(...)) bei Matrixformel von: MikeS
Geschrieben am: 22.10.2008 09:34:05

Vielen Dank Euch Beiden, es funktioniert!

Ciao MikeS


Beiträge aus den Excel-Beispielen zum Thema "WENN(ISTFEHLER(...)) bei Matrixformel"