Filtern nach letzter Stelle einer Zahl

Bild

Betrifft: Filtern nach letzter Stelle einer Zahl von: Reni
Geschrieben am: 11.04.2005 13:41:33

Hallo an alle,

ich arbeite oft mit 5stelligen Kostenstellen, wobei die letzte Zahl einer 5-stelligen Kostenstelle die dazugehörige Tochtergesellschaft ist. Diese möchte ich jetzt ermitteln, weiß aber nicht wie.

Also:

Wenn die letzte Stelle der Kostenstelle xxxxx gleich 1 ist, dann gehört die Kostenstelle zur Firma A.

Wenn die letzte Stelle der Kostenstelle xxxxx gleich 2 ist, dann gehört die Kostenstelle zur Firma B.

Wenn die letzte Stelle der Kostenstelle xxxxx gleich 3 ist, dann gehört die Kostenstelle zur Firma C.

Wer kann mir helfen?

Grüsse Reni

Bild


Betrifft: Filtern von: Kl@us-M.
Geschrieben am: 11.04.2005 13:51:06

Hi Reni,
kannst Du hiermit etwas anfangen?
Tabelle1
 ABC
112341AA
212342BB
312343CC
498763CC
598761AA
698762BB
Formeln der Tabelle
B1 : =WENN(RECHTS(A1;1)="1";"A";WENN(RECHTS(A1;1)="2";"B";"C"))
C1 : =WAHL(RECHTS(A1;1);"A";"B";"C")
B2 : =WENN(RECHTS(A2;1)="1";"A";WENN(RECHTS(A2;1)="2";"B";"C"))
C2 : =WAHL(RECHTS(A2;1);"A";"B";"C")
B3 : =WENN(RECHTS(A3;1)="1";"A";WENN(RECHTS(A3;1)="2";"B";"C"))
C3 : =WAHL(RECHTS(A3;1);"A";"B";"C")
B4 : =WENN(RECHTS(A4;1)="1";"A";WENN(RECHTS(A4;1)="2";"B";"C"))
C4 : =WAHL(RECHTS(A4;1);"A";"B";"C")
B5 : =WENN(RECHTS(A5;1)="1";"A";WENN(RECHTS(A5;1)="2";"B";"C"))
C5 : =WAHL(RECHTS(A5;1);"A";"B";"C")
B6 : =WENN(RECHTS(A6;1)="1";"A";WENN(RECHTS(A6;1)="2";"B";"C"))
C6 : =WAHL(RECHTS(A6;1);"A";"B";"C")
 



Gruss aus dem wilden Hunsrück
Klaus-Martin



Bild


Betrifft: AW: Filtern von: IngoG
Geschrieben am: 11.04.2005 14:00:25

Hallo Klaus-Martin,

dann ist wohl wahl() die bessere alternative
=wahl(rechts(a1;1)+1;"X";"A";"B";"C";"D";"E";"F";"G";"H";"I")

gibt für 0 X zurück,
für 1 A
für 2 B usw...

hier funzen auch längere namen,

wenn die Namen nur aus einem Buchstaben bestehen geht auch:

=teil("XABCDEFGHI";rechts(a1;1)+1;1)

Deine Lösung hat das Problem, dass nur 7 Wenns ineinander geschachtelt werden können...
Gruß Ingo


Bild


Betrifft: Mehr als 7 WENN geht doch ;-) von: Kl@us-M.
Geschrieben am: 11.04.2005 14:12:10

Hi Ingo,
nur der Richtigkeit halber: =WAHL() ist sicher die beseere Lösung, aber wo steht, dass es mit =WENN() zu Problemen kommt ???
Es lassen sich doch problemlos mehr als 7 Wenn's verschachteln:
Tabelle1
 AB
113M
Formeln der Tabelle
B1 : =WENN(A1=1;"A";WENN(A1=2;"B";WENN(A1=3;"C";WENN(A1=4;"D";WENN(A1=5;"E";WENN(A1=6;"F";WENN(A1=7;"G";"")))))))&WENN(A1=8;"H";WENN(A1=9;"I";WENN(A1=10;"J";WENN(A1=11;"K";WENN(A1=12;"L";WENN(A1=13;"M";WENN(A1=14;"N";"")))))))
 



Gruss aus dem wilden Hunsrück
Klaus-Martin



Bild


Betrifft: AW: Mehr als 7 WENN geht doch ;-) von: Boris
Geschrieben am: 11.04.2005 14:43:25

Hi Klaus-Martin,

ich weiss, dass du es nur der Vollständigkeit halber schreibst, aber

Es lassen sich doch problemlos mehr als 7 Wenn's verschachteln:

Genau das isses ja nicht mehr - ein Verschachtelung. Viel mehr eine Verkettung ;-)

Grüße Boris


Bild


Betrifft: AW: Mehr als 7 WENN geht doch ;-) von: IngoG
Geschrieben am: 11.04.2005 14:43:58

Hallo Klaus-Martin,

Du hast nat. recht, dass man in einer Formel mehr als 7 Wenn unterbringen kann, aber eben nicht verschachteln. ;-)

Gruß Ingo


Bild


Betrifft: AW: Filtern nach letzter Stelle einer Zahl von: IngoG
Geschrieben am: 11.04.2005 13:52:44

Hallo Reni,

die einfachste lösung ist eine Hilfsspalte mit =rechts(a1;1)
und dann darauf filtern.

wenn Du nur zählen und nicht filtern möchtest, kannst Du auch folgende Formel nehmen:

=summenprodukt((rechts(a1:a100;1)=1)*1)

gibt die anzahl der Werte in a1:a100 zurück, die mit 1 enden

Gruß Ingo


 Bild

Beiträge aus den Excel-Beispielen zum Thema "Filtern nach letzter Stelle einer Zahl "