Microsoft Excel

Herbers Excel/VBA-Archiv

Informationen und Beispiele zum Thema MsgBox
BildScreenshot zu MsgBox MsgBox-Seite mit Beispielarbeitsmappe aufrufen

Zifferkombinationen in Uhrzeiten | Herbers Excel-Forum


Betrifft: Zifferkombinationen in Uhrzeiten von: Ferdi
Geschrieben am: 17.02.2012 22:44:23

Hallo zusammen!

Ich würde in einer Reihe vom Uhrzeiten (genaugenommen in allen 86400 möglichen von 00:00:00 bis 23:59:59) der Form hh:mm:ss
gern bestimmte Zifferkombinationen suchen!
Als Beispiel:
(5;7) Oder (2;4)
gezählt werden soll die Anzahl der Vorkommen von mindestens einer, oder beiden Kombinationen.
Innerhalb der Beispielzeiten wären das somit vier. Wenn beide vorkommen wird also ein Treffer gezählt, da es ansonsten doppelt gezählt wäre!
00:57:24
24:11:00
05:42:17
15:11:07

Ich hoffe es ist verständlich, was ich meine.
Ist es möglich, das mit Excel zu bewerkstelligen?
Über Hilfe würde ich mich sehr freuen!

Lieben Gruß
Ferdi

  

Betrifft: 24:11:00 ? was ist das denn bei "hh:mm:ss" von: Matthias L
Geschrieben am: 17.02.2012 23:16:13

Hallo

das ist dann eher [h]:mm:ss

Wo und wie liegen denn die Daten wirklich vor?
Es ist also egal ob eine der Ziffern(5;7) in der Stunde, der Minute oder der Sekunde vorkommen?

Die Ziffern(5;7) z.B. bei 15:27:00 - dann zählen?
Die Ziffern(5;7) z.B. bei 17:30:53 - dann zählen?

oder willst Du generell die Kombinationen z.B.(5;7)
im Zeitbereich von "00:00:01" bis "23:59:59" zählen?
Dan wäre die erste zu zählende Zeiteinheit "00:00:57" ... Ist das korrekt?

Gruß Matthias


  

Betrifft: AW: 24:11:00 ? was ist das denn bei "hh:mm:ss" von: Ferdi
Geschrieben am: 17.02.2012 23:51:15

Hallo Matthias,

es ist egal an welcher Stelle die Ziffern vorkommen. Sobald 5 und 7 in einer Zeit vorkommen, wäre das ein Treffer, bzw. Zähler.

Ich sehe überigens grade, dass ich mich im Eingangsposting vertan habe. Ich meine nicht
(5;7) Oder (2;4) sondern
Mindestens (5;7) oder (2;4).

Wenn ich dann also nach zwei Kombinationen suche, also wie erwähnt z.B. mindestend das Vorkommen von (5;7) oder (2;4) wäre das Vorkommen mindestens einer der Kombinationen, egal an welcher Stelle auch ein Treffer.
Du hast Recht, die ersten Treffer wären z.B.:
00:00:24
00:00:42
00:00:57

aber auch 00:54:27 wäre einer. Oder 02:47:15 usw.

Mindestens (5;7) oder (2;4) heisst also, jede Uhrzeit in der Mindestens eine der Kombinationen, egal an welcher Stelle, vorkommt, zählt als Treffer.

Ich hoffe ich habs jetzt nicht zu verwirrend gemacht;-)
Die Daten liegen einfach als fortlaufende Zahlenkollone vor.
LG


  

Betrifft: AW: 24:11:00 ? was ist das denn bei "hh:mm:ss" von: M@x
Geschrieben am: 17.02.2012 23:57:56

Hallo,
ohne jetzt nach dem Sinn der Aktion zu fragen,
wenn du mit den einzelnen Ziffern einer Zeitangabe "spielen" willst, mußt du die Zeit zuerst in Text umwandeln
=TEXT(A1;"hh:mm:ss") damit du die einzelnen Ziffer zu fassen bekommst,
denn für Excel ist zBsp 12:00 0,5
das wäre mal der erste Schritt

Gruss

M@x


  

Betrifft: AW: 24:11:00 ? was ist das denn bei "hh:mm:ss" von: Ferdi
Geschrieben am: 18.02.2012 00:16:40

Hallo M@x,

ok, das sollte zu bewerkstelligen sein!
Trotzdem stehe ich danach leider wieder völlig auf dem Schlauch...

Ich vermute, dass die Lösung zu der Fragestellung nicht ganz einfach und ohne Weitere aus dem
Ärmel zu schütteln ist. Grade deshalb wäre es toll wenn ich irgendwie an eine Lösung käme!
Ich hoffe also auf weitere Antworten!
gruß


  

Betrifft: AW: 24:11:00 ? was ist das denn bei "hh:mm:ss" von: M@x
Geschrieben am: 18.02.2012 00:39:19

Hi
24:11:00 ergibt bei hh:mm:ss 00:11:00
und bei [hh]:mm:ss 24:11:00
aber die Primäre Frage umfasste ja nur 24Stunden.

für die weiteren Schritte fehlt mir momentan auch ein vernünftiger Ansatz,
aber vielleicht erhöhst du die Wahrscheinlichkeit einer zufriedenstellenden Antwort , wenn du den Zweck erklärst.
dann kann man vielleicht etwas weiter denken und leichter altenative Wege suchen

Gruss

M@x


  

Betrifft: 9698 nur mal bei (5;7) ist das korrekt ? oT von: Matthias L
Geschrieben am: 18.02.2012 00:17:31




  

Betrifft: AW: 21784 nur mal bei (2;4) ist das korrekt ? oT von: Matthias L
Geschrieben am: 18.02.2012 00:20:48




  

Betrifft: AW: 21784 nur mal bei (2;4) ist das korrekt ? oT von: Ferdi
Geschrieben am: 18.02.2012 00:43:32

Matthias, beide male korrekt:-)

Ich hab auch ne Vermutung woher Du das weisst;-)

Allerdings hilft das leider noch nicht bei der Frage nach den Haufigkeiten von den gesuchen Zweierkombinationen, da die Häufigkeiten für die einzelnen Kombinationen nicht einfach addiert werden können...wegen Doppelzählung:-(


  

Betrifft: was vermutest Du denn ? von: Matthias L
Geschrieben am: 18.02.2012 01:29:40

Hi

Zitat:
Ich hab auch ne Vermutung woher Du das weisst

Was vermutest Du denn?

Ich hatte nur versucht eine Lösung zu finden und M@x gefragt, ob er das auch als Ergebnis hat.

Gruß Matthias


  

Betrifft: AW: Zifferkombinationen in Uhrzeiten von: Josef Ehrensberger
Geschrieben am: 18.02.2012 00:54:12


Hallo Ferdi,

überprüfe das mal.

{=SUMME((ISTZAHL((FINDEN("2";TEXT(ZEIT(0;0;ZEILE($2:$86401));"hh:mm:ss")))*ISTZAHL(FINDEN("4"; TEXT(ZEIT(0;0;ZEILE($2:$86401));"hh:mm:ss")))))+(ISTZAHL((FINDEN("5";TEXT(ZEIT(0;0;ZEILE($2:$86401)); "hh:mm:ss")))*ISTZAHL(FINDEN("7";TEXT(ZEIT(0;0;ZEILE($2:$86401));"hh:mm:ss")))))) }




« Gruß Sepp »



  

Betrifft: Zifferkombinationen in Uhrzeiten von: Erich G.
Geschrieben am: 18.02.2012 01:17:24

Hi Sepp,
ich bekomme da ein paar weniger raus - in E4:

 E
232672
3 
430286

Formeln der Tabelle
ZelleFormel
E2{=SUMME((ISTZAHL((FINDEN("2";TEXT(ZEIT(0;0;ZEILE($2:$86401)); "hh:mm:ss")))*ISTZAHL(FINDEN("4"; TEXT(ZEIT(0;0;ZEILE($2:$86401)); "hh:mm:ss")))))+(ISTZAHL((FINDEN("5";TEXT(ZEIT(0;0;ZEILE($2:$86401)); "hh:mm:ss")))*ISTZAHL(FINDEN("7";TEXT(ZEIT(0;0;ZEILE($2:$86401)); "hh:mm:ss"))))))}
E4{=SUMME(1*(ISTZAHL(FINDEN("2";TEXT(ZEILE($2:$86401)/86400;"hmmss"))) *ISTZAHL(FINDEN("4";TEXT(ZEILE($2:$86401)/86400;"hmmss"))) +ISTZAHL(FINDEN("5";TEXT(ZEILE($2:$86401)/86400;"hmmss"))) *ISTZAHL(FINDEN("7";TEXT(ZEILE($2:$86401)/86400;"hmmss")))>0))}
Enthält Matrixformel:
Umrandende
{ } nicht miteingeben,
sondern Formel mit STRG+SHIFT+RETURN abschließen!
Matrix verstehen


Mit den Formeln in Spalte C könnte man die Treffer als Liste erzeugen. Aber ich warne davor:
Die Prozessoren gehen in die Knie!

 ABC
22400:00:2400:00:24
34200:00:4200:00:42
45700:00:57 
58400:01:24 
610200:01:42 
711700:01:57 
812400:02:04 
913400:02:14 
1014400:02:24 
1115400:02:34 
1216000:02:40 
1316100:02:41 

Formeln der Tabelle
ZelleFormel
C2{=KKLEINSTE(WENN(ISTZAHL(FINDEN(2;TEXT(ZEILE($1:$86400)/86400;"hhmmss"))) *ISTZAHL(FINDEN(4;TEXT(ZEILE($1:$86400)/86400;"hhmmss"))) +ISTZAHL(FINDEN(5;TEXT(ZEILE($1:$86400)/86400;"hhmmss"))) *ISTZAHL(FINDEN(7;TEXT(ZEILE($1:$86400)/86400;"hhmmss"))); ZEILE($1:$86400)/86400); ZEILE()-1)}
C3{=KKLEINSTE(WENN(ISTZAHL(FINDEN(2;TEXT(ZEILE($1:$86400)/86400;"hhmmss"))) *ISTZAHL(FINDEN(4;TEXT(ZEILE($1:$86400)/86400;"hhmmss"))) +ISTZAHL(FINDEN(5;TEXT(ZEILE($1:$86400)/86400;"hhmmss"))) *ISTZAHL(FINDEN(7;TEXT(ZEILE($1:$86400)/86400;"hhmmss"))); ZEILE($1:$86400)/86400); ZEILE()-1)}
Enthält Matrixformel:
Umrandende
{ } nicht miteingeben,
sondern Formel mit STRG+SHIFT+RETURN abschließen!
Matrix verstehen

Schneller läuft da VBA:
Sub ZeitZiff()
   Dim zz As Long, ee As Long, sT As String
   
   Application.Calculation = xlCalculationManual
   ee = 1
   For zz = 1 To 86400
      sT = Format(zz / 86400, "hmmss")
      If (InStr(sT, "2") * InStr(sT, "4")) _
       + (InStr(sT, "5") * InStr(sT, "7")) > 0 Then
         ee = ee + 1
         Cells(ee, 1) = zz
         Cells(ee, 2) = zz / 86400
      End If
   Next zz
   Application.Calculation = xlCalculationAutomatic
End Sub
Rückmeldung wäre nett! - Grüße aus Kamp-Lintfort von Erich


  

Betrifft: siehe auch... von: Erich G.
Geschrieben am: 18.02.2012 01:27:15

in http://www.office-loesung.de/ftopic509361_0_0_asc.php

Grüße aus Kamp-Lintfort von Erich


  

Betrifft: AW: siehe auch... von: Ferdi
Geschrieben am: 18.02.2012 01:38:08

ja, in dem Forum hat man einen anderen Lösungsweg vorgeschlagen.
Leider gibt es mit dem Lösungsvorschag dort noch nichts um die Häufigkeiten für beide Kombinationen zu errechnen.


  

Betrifft: AW: Zifferkombinationen in Uhrzeiten von: Ferdi
Geschrieben am: 18.02.2012 01:34:35

Hallo an Euch beide!

mannmann...was für Formeln!! Vielen Dank schonmal dafür!
Ein Bekannter von mir hat das mal mit MUPAD gemacht und ich weiss, dass er für
(2;5),(7;9)

25440
Fälle herausbekam! Also schon seeehr nah an dem was mit die Formel von Sepp produziert.
Woher die Differrenz von fünf (Mit der Formel von Sepp kommen bei mir 25445 raus) herkommt, weiss ich nicht!


  

Betrifft: Zifferkombinationen in Uhrzeiten von: Erich G.
Geschrieben am: 18.02.2012 06:43:30

Hi Ferdi,
trotz des Crosspostings noch mal eine Zählformel:

 D
330286
4 

Formeln der Tabelle
ZelleFormel
D3{=SUMME(1*( ISTZAHL(FINDEN(2;TEXT(ZEILE($1:$86400)/86400;"hmmss")))*ISTZAHL(FINDEN(4;TEXT(ZEILE($1:$86400)/86400;"hmmss")))+ ISTZAHL(FINDEN(5;TEXT(ZEILE($1:$86400)/86400;"hmmss")))*ISTZAHL(FINDEN(7;TEXT(ZEILE($1:$86400)/86400;"hmmss")))>0))}
Enthält Matrixformel:
Umrandende
{ } nicht miteingeben,
sondern Formel mit STRG+SHIFT+RETURN abschließen!
Matrix verstehen

und auch noch ein Makro zum Zählen und evtl. Ausgeben der Treffer:
Option Explicit

Sub ZeitZiff()
   Dim zz As Long, ee As Long, sT As String
   ' ----------------------------------------- ermitteln, zählen
   ReDim arrE(1 To 86400)
   For zz = 1 To 86400
      sT = Format(zz / 86400#, "hmmss")
      If (InStr(sT, "2") * InStr(sT, "4")) _
       + (InStr(sT, "5") * InStr(sT, "7")) > 0 Then
         ee = ee + 1
         arrE(ee) = zz
      End If
   Next zz
   ' ----------------------------------------- evtl. ausgeben
   If MsgBox("Es gibt " & ee & " Treffer." & vbLf & vbLf & _
      "Liste ausgeben?", vbYesNoCancel + vbQuestion) = vbYes Then
      ReDim arrOut(1 To ee, 1 To 2)
      For zz = 1 To ee
         arrOut(zz, 1) = arrE(zz)
         arrOut(zz, 2) = arrE(zz) / 86400#
      Next zz
      Cells(1, 1).Resize(ee, 2) = arrOut
   End If
End Sub
Nach deinem Kommentar zum Crossposting noch eine Bemerkung:
Wenn du schon in mehreren Bereichen Menschen für diech tätig werden lassen willst, wäre es anständig (gewesen),
darüber zu informieren. Nicht jeder ist in mehreren Foren unterwegs.

Rückmeldung wäre nett! - Grüße aus Kamp-Lintfort von Erich


  

Betrifft: ZEIT-Parameter zu groß von: Erich G.
Geschrieben am: 18.02.2012 06:35:35

Hi Sepp,
mir ist gerade ein Problem deiner Formel aufgefallen:

Der Fkt ZEIT() soll man als Parameter keine größeren Zahlen als 32767 übergeben. :-(
Da bietet sich dann eher die Division durch 86400 an,

Schönes Wochenende! Rückmeldung wäre nett! - Grüße aus Kamp-Lintfort von Erich


  

Betrifft: AW: ZEIT-Parameter zu groß von: Josef Ehrensberger
Geschrieben am: 18.02.2012 09:08:26


Hallo Erich,

war ja schon spät gestern;-)) deshalb ist mir der Fehler nicht mehr aufgefallen;-((

Ein paar Zeichen kürzer geht's noch.

Tabelle1

 B
330286

Formeln der Tabelle
ZelleFormel
B3{=SUMME(1*(ISTZAHL(FINDEN(2;TEXT(ZEILE($2:$86401)/86400;"hms"))*FINDEN(4;TEXT(ZEILE($2:$86401)/86400;"hms")))+ISTZAHL(FINDEN(5;TEXT(ZEILE($2:$86401)/86400;"hms"))*FINDEN(7;TEXT(ZEILE($2:$86401)/86400;"hms")))>0))}
Enthält Matrixformel:
Umrandende
{ } nicht miteingeben,
sondern Formel mit STRG+SHIFT+RETURN abschließen!
Matrix verstehen


Excel Tabellen im Web darstellen >> Excel Jeanie HTML 4




« Gruß Sepp »



  

Betrifft: AW: ZEIT-Parameter zu groß von: Ferdi
Geschrieben am: 18.02.2012 11:01:58

Guten Morgen!

Die verschiedenen Lösungsvorschläge scheinen doch unterschiedliche Ergebnisse zu liefern.
(vor allem der erste vorschlag von Sepp kam dem Ergebniss das ich habe am nähesten, obwohl dort scheinbar ein Fehler in der Formel ist)
Ich werde nach dem Wochenende alle Vorschläge zusammenfassen und posten!
Schönes Wochenende noch!
Gruß


  

Betrifft: benutzerdefinierte Funktion, Kombinationen zählen von: fcs
Geschrieben am: 18.02.2012 12:34:11

Hallo Ferdi,

ich hab den Lösungs-Ansatz von Erich in etwas modifizierter Form in eine benutzerdefinierte Funktion umgesetzt, die dann wie eine normale Tabellenfunktion verwendet werden kann.
Trotzt 86400 Berechnungsschleifen ist die Laufzeit nur im Sekundenbereich - deutlich schneller als die Matrix-Formel.

Gruß
Franz

Tabelle1

 ABCDEFG
1Kombi1 Kombi2  Zeitformat:hhmmss
2       
3245730286 30286

Formeln der Tabelle
ZelleFormel
E3=KombinationenZaehlen(A3;B3;C3;D3;G1)
G3{=SUMME(1*(ISTZAHL(FINDEN(A3;TEXT(ZEILE($A$2:$A$86401)/86400;$G$1))*FINDEN(B3;TEXT(ZEILE($A$2:$A$86401)/86400;$G$1)))+ISTZAHL(FINDEN(C3;TEXT(ZEILE($A$2:$A$86401)/86400;$G$1))*FINDEN(D3;TEXT(ZEILE($A$2:$A$86401)/86400;$G$1)))>0))}
Enthält Matrixformel:
Umrandende
{ } nicht miteingeben,
sondern Formel mit STRG+SHIFT+RETURN abschließen!
Matrix verstehen


Excel Tabellen im Web darstellen >> Excel Jeanie HTML 4
'Allgemeines Modul
Public Function KombinationenZaehlen(sZiffer1 As String, sZiffer2 As String, _
    Optional sZiffer3 As String, Optional sZiffer4 As String, _
    Optional sFormat As String = "hh:mm:ss") As Long
  'sZiffer1 und sZiffer2 sind die Ziffern der 1. Kombination
  'sZiffer3 und sZiffer4 sind die Ziffern der 2. Kombination (Optional)
  Dim sTime As String
  Dim iStd As Integer, iMin As Integer, iSek As Integer
  If sZiffer3 = "" Or sZiffer4 = "" Then
    sZiffer3 = "§"
    sZiffer4 = "§"
  End If
  For iStd = 0 To 23
    For iMin = 0 To 59
      For iSek = 0 To 59
        sTime = Format(TimeSerial(iStd, iMin, iSek), sFormat)
        If (InStr(1, sTime, sZiffer1) > 0 And InStr(1, sTime, sZiffer2) > 0) _
              Or (InStr(1, sTime, sZiffer3) > 0 And InStr(1, sTime, sZiffer4) > 0) Then
           KombinationenZaehlen = KombinationenZaehlen + 1
        End If
      Next
    Next
  Next
End Function



  

Betrifft: noch eine benutzerdefinierte Funktion von: Erich G.
Geschrieben am: 18.02.2012 13:06:29

Hi Franz,
so ist eine Fkt. etwas weniger 'anwendungssicher', aber wohl auch ausreichend:

Function ZZiff(sZif1 As String, sZif2 As String, _
    Optional sZif3 As String = "§", Optional sZif4 As String = "§", _
    Optional sFormat As String = "hms") As Long
   Dim zz As Long, sT As String

   For zz = 1 To 86400
      sT = Format(zz / 86400#, sFormat)
      If (InStr(sT, sZif1) * InStr(sT, sZif2)) _
       + (InStr(sT, sZif3) * InStr(sT, sZif4)) > 0 Then ZZiff = ZZiff + 1
   Next zz
End Function
Rückmeldung wäre nett! - Grüße aus Kamp-Lintfort von Erich


  

Betrifft: AW: noch eine benutzerdefinierte Funktion von: fcs
Geschrieben am: 18.02.2012 17:22:43

Hallo Erich,

ob deine Funktion weniger "anwendungssicher" ist als mein Vorschlag das weiss ich nicht.

Deine Version berücksichtig die 2. Kombination auch wenn nur eine der Ziffern als Parameter angegeben ist.

Ob
Format(zz / 86400#, sFormat) bzw. Format(TimeSerial(iStd, iMin, iSek), sFormat)
unterschiedliche Werte ergeben kann durch Rundungsungenauigkeiten hab ich jetzt nicht intensiv untersucht.
Jedenfalls liefern beide Funktionen bei den von mir getesteten Kombinationen das gleiche Ergebnis.

Gruß
Franz


  

Betrifft: ich hab 27234 raus bei 2;4 oder 5;7 oT von: Matthias L
Geschrieben am: 18.02.2012 20:17:30




  

Betrifft: 27234 ? Wie ermittelt? (owT) von: Erich G.
Geschrieben am: 19.02.2012 05:40:07

Schönen Sonntag!


  

Betrifft: wie ermittelt? Na sehr mühsam ... von: Matthias L
Geschrieben am: 19.02.2012 08:47:06

Hallo Erich

Nicht schön und dauert auch eine kleine Weile (ca. 3 Sek.). Mir ging es auch nicht um Geschwindigkeit,
sondern wollte nur versuchen es zu lösen.

Hab mal ein paar Zeilen ausgeblendet.
Kannst Du das Ergebnis bestätigen, oder ist da irgendwo ein Fehler drin ?

Tabelle1

 ABCDEFGHIJKLMNO
100:00:0118:12:17  0 5742 0   
200:00:0218:12:18  0 969821784 0   
300:00:0318:12:19  0      0   
400:00:0418:12:20  0  27234  0   
800:00:0818:12:24  0      11 1
1800:00:1818:12:34  0      11 1
2400:00:2418:12:40  0      2111
2500:00:2518:12:41  0      11 1
2600:00:2618:12:42  0      11 1
2700:00:2718:12:43  0      11 1
2800:00:2818:12:44  0      11 1
2900:00:2918:12:45  0      11 1
3000:00:3018:12:46  0      11 1
3100:00:3118:12:47  0      11 1
3200:00:3218:12:48  0      11 1
3300:00:3318:12:49  0      11 1
3800:00:3818:12:54  0      11 1
4100:00:4118:12:57 11      0  1
4200:00:4218:12:58  0      1 11
5700:00:5718:13:131 1      0  1
6800:01:0818:13:24  0      11 1
8400:01:2418:13:40  0      1 11
8500:01:2518:13:41  0      0   
8600:01:2618:13:42  0      11 1
10100:01:4118:13:57 11      0  1
10200:01:4218:13:58  0      1 11
10300:01:4318:13:59  0      0   
10400:01:4418:14:00  0      0   
10500:01:4518:14:01  0      0   
10600:01:4618:14:02  0      11 1

Formeln der Tabelle
ZelleFormel
C1=WENN(ISTFEHLER(WENN(UND(FINDEN($G$1;TEXT(A1;"hh:mm:ss"));FINDEN($H$1;TEXT(A1;"hh:mm:ss")));1;0));"";WENN(UND(FINDEN($G$1;TEXT(A1;"hh:mm:ss"));FINDEN($H$1;TEXT(A1;"hh:mm:ss")));1;0))
D1=WENN(ISTFEHLER(WENN(UND(FINDEN($G$1;TEXT(B1;"hh:mm:ss"));FINDEN($H$1;TEXT(B1;"hh:mm:ss")));1;0));"";WENN(UND(FINDEN($G$1;TEXT(B1;"hh:mm:ss"));FINDEN($H$1;TEXT(B1;"hh:mm:ss")));1;0))
E1=SUMME(C1:D1)
L1=SUMME(M1:N1)
M1=WENN(ISTFEHLER(WENN(UND(FINDEN($I$1;TEXT(B1;"hh:mm:ss"));FINDEN($J$1;TEXT(B1;"hh:mm:ss")));1;0));"";WENN(UND(FINDEN($I$1;TEXT(B1;"hh:mm:ss"));FINDEN($J$1;TEXT(B1;"hh:mm:ss")));1;0))
N1=WENN(ISTFEHLER(WENN(UND(FINDEN($I$1;TEXT(A1;"hh:mm:ss"));FINDEN($J$1;TEXT(A1;"hh:mm:ss")));1;0));"";WENN(UND(FINDEN($I$1;TEXT(A1;"hh:mm:ss"));FINDEN($J$1;TEXT(A1;"hh:mm:ss")));1;0))
O1=WENN(ODER(E1>0;L1>0);1;"")
C2=WENN(ISTFEHLER(WENN(UND(FINDEN($G$1;TEXT(A2;"hh:mm:ss"));FINDEN($H$1;TEXT(A2;"hh:mm:ss")));1;0));"";WENN(UND(FINDEN($G$1;TEXT(A2;"hh:mm:ss"));FINDEN($H$1;TEXT(A2;"hh:mm:ss")));1;0))
D2=WENN(ISTFEHLER(WENN(UND(FINDEN($G$1;TEXT(B2;"hh:mm:ss"));FINDEN($H$1;TEXT(B2;"hh:mm:ss")));1;0));"";WENN(UND(FINDEN($G$1;TEXT(B2;"hh:mm:ss"));FINDEN($H$1;TEXT(B2;"hh:mm:ss")));1;0))
E2=SUMME(C2:D2)
G2=SUMME(E:E)
I2=SUMME(L:L)
L2=SUMME(M2:N2)
M2=WENN(ISTFEHLER(WENN(UND(FINDEN($I$1;TEXT(B2;"hh:mm:ss"));FINDEN($J$1;TEXT(B2;"hh:mm:ss")));1;0));"";WENN(UND(FINDEN($I$1;TEXT(B2;"hh:mm:ss"));FINDEN($J$1;TEXT(B2;"hh:mm:ss")));1;0))
N2=WENN(ISTFEHLER(WENN(UND(FINDEN($I$1;TEXT(A2;"hh:mm:ss"));FINDEN($J$1;TEXT(A2;"hh:mm:ss")));1;0));"";WENN(UND(FINDEN($I$1;TEXT(A2;"hh:mm:ss"));FINDEN($J$1;TEXT(A2;"hh:mm:ss")));1;0))
O2=WENN(ODER(E2>0;L2>0);1;"")
C3=WENN(ISTFEHLER(WENN(UND(FINDEN($G$1;TEXT(A3;"hh:mm:ss"));FINDEN($H$1;TEXT(A3;"hh:mm:ss")));1;0));"";WENN(UND(FINDEN($G$1;TEXT(A3;"hh:mm:ss"));FINDEN($H$1;TEXT(A3;"hh:mm:ss")));1;0))
D3=WENN(ISTFEHLER(WENN(UND(FINDEN($G$1;TEXT(B3;"hh:mm:ss"));FINDEN($H$1;TEXT(B3;"hh:mm:ss")));1;0));"";WENN(UND(FINDEN($G$1;TEXT(B3;"hh:mm:ss"));FINDEN($H$1;TEXT(B3;"hh:mm:ss")));1;0))
E3=SUMME(C3:D3)
L3=SUMME(M3:N3)
M3=WENN(ISTFEHLER(WENN(UND(FINDEN($I$1;TEXT(B3;"hh:mm:ss"));FINDEN($J$1;TEXT(B3;"hh:mm:ss")));1;0));"";WENN(UND(FINDEN($I$1;TEXT(B3;"hh:mm:ss"));FINDEN($J$1;TEXT(B3;"hh:mm:ss")));1;0))
N3=WENN(ISTFEHLER(WENN(UND(FINDEN($I$1;TEXT(A3;"hh:mm:ss"));FINDEN($J$1;TEXT(A3;"hh:mm:ss")));1;0));"";WENN(UND(FINDEN($I$1;TEXT(A3;"hh:mm:ss"));FINDEN($J$1;TEXT(A3;"hh:mm:ss")));1;0))
O3=WENN(ODER(E3>0;L3>0);1;"")
C4=WENN(ISTFEHLER(WENN(UND(FINDEN($G$1;TEXT(A4;"hh:mm:ss"));FINDEN($H$1;TEXT(A4;"hh:mm:ss")));1;0));"";WENN(UND(FINDEN($G$1;TEXT(A4;"hh:mm:ss"));FINDEN($H$1;TEXT(A4;"hh:mm:ss")));1;0))
D4=WENN(ISTFEHLER(WENN(UND(FINDEN($G$1;TEXT(B4;"hh:mm:ss"));FINDEN($H$1;TEXT(B4;"hh:mm:ss")));1;0));"";WENN(UND(FINDEN($G$1;TEXT(B4;"hh:mm:ss"));FINDEN($H$1;TEXT(B4;"hh:mm:ss")));1;0))
E4=SUMME(C4:D4)
H4=SUMME(O:O)
L4=SUMME(M4:N4)
M4=WENN(ISTFEHLER(WENN(UND(FINDEN($I$1;TEXT(B4;"hh:mm:ss"));FINDEN($J$1;TEXT(B4;"hh:mm:ss")));1;0));"";WENN(UND(FINDEN($I$1;TEXT(B4;"hh:mm:ss"));FINDEN($J$1;TEXT(B4;"hh:mm:ss")));1;0))
N4=WENN(ISTFEHLER(WENN(UND(FINDEN($I$1;TEXT(A4;"hh:mm:ss"));FINDEN($J$1;TEXT(A4;"hh:mm:ss")));1;0));"";WENN(UND(FINDEN($I$1;TEXT(A4;"hh:mm:ss"));FINDEN($J$1;TEXT(A4;"hh:mm:ss")));1;0))
O4=WENN(ODER(E4>0;L4>0);1;"")
C8=WENN(ISTFEHLER(WENN(UND(FINDEN($G$1;TEXT(A8;"hh:mm:ss"));FINDEN($H$1;TEXT(A8;"hh:mm:ss")));1;0));"";WENN(UND(FINDEN($G$1;TEXT(A8;"hh:mm:ss"));FINDEN($H$1;TEXT(A8;"hh:mm:ss")));1;0))
D8=WENN(ISTFEHLER(WENN(UND(FINDEN($G$1;TEXT(B8;"hh:mm:ss"));FINDEN($H$1;TEXT(B8;"hh:mm:ss")));1;0));"";WENN(UND(FINDEN($G$1;TEXT(B8;"hh:mm:ss"));FINDEN($H$1;TEXT(B8;"hh:mm:ss")));1;0))
E8=SUMME(C8:D8)
L8=SUMME(M8:N8)
M8=WENN(ISTFEHLER(WENN(UND(FINDEN($I$1;TEXT(B8;"hh:mm:ss"));FINDEN($J$1;TEXT(B8;"hh:mm:ss")));1;0));"";WENN(UND(FINDEN($I$1;TEXT(B8;"hh:mm:ss"));FINDEN($J$1;TEXT(B8;"hh:mm:ss")));1;0))
N8=WENN(ISTFEHLER(WENN(UND(FINDEN($I$1;TEXT(A8;"hh:mm:ss"));FINDEN($J$1;TEXT(A8;"hh:mm:ss")));1;0));"";WENN(UND(FINDEN($I$1;TEXT(A8;"hh:mm:ss"));FINDEN($J$1;TEXT(A8;"hh:mm:ss")));1;0))
O8=WENN(ODER(E8>0;L8>0);1;"")
C18=WENN(ISTFEHLER(WENN(UND(FINDEN($G$1;TEXT(A18;"hh:mm:ss"));FINDEN($H$1;TEXT(A18;"hh:mm:ss")));1;0));"";WENN(UND(FINDEN($G$1;TEXT(A18;"hh:mm:ss"));FINDEN($H$1;TEXT(A18;"hh:mm:ss")));1;0))
D18=WENN(ISTFEHLER(WENN(UND(FINDEN($G$1;TEXT(B18;"hh:mm:ss"));FINDEN($H$1;TEXT(B18;"hh:mm:ss")));1;0));"";WENN(UND(FINDEN($G$1;TEXT(B18;"hh:mm:ss"));FINDEN($H$1;TEXT(B18;"hh:mm:ss")));1;0))
E18=SUMME(C18:D18)
L18=SUMME(M18:N18)
M18=WENN(ISTFEHLER(WENN(UND(FINDEN($I$1;TEXT(B18;"hh:mm:ss"));FINDEN($J$1;TEXT(B18;"hh:mm:ss")));1;0));"";WENN(UND(FINDEN($I$1;TEXT(B18;"hh:mm:ss"));FINDEN($J$1;TEXT(B18;"hh:mm:ss")));1;0))
N18=WENN(ISTFEHLER(WENN(UND(FINDEN($I$1;TEXT(A18;"hh:mm:ss"));FINDEN($J$1;TEXT(A18;"hh:mm:ss")));1;0));"";WENN(UND(FINDEN($I$1;TEXT(A18;"hh:mm:ss"));FINDEN($J$1;TEXT(A18;"hh:mm:ss")));1;0))
O18=WENN(ODER(E18>0;L18>0);1;"")
C24=WENN(ISTFEHLER(WENN(UND(FINDEN($G$1;TEXT(A24;"hh:mm:ss"));FINDEN($H$1;TEXT(A24;"hh:mm:ss")));1;0));"";WENN(UND(FINDEN($G$1;TEXT(A24;"hh:mm:ss"));FINDEN($H$1;TEXT(A24;"hh:mm:ss")));1;0))
D24=WENN(ISTFEHLER(WENN(UND(FINDEN($G$1;TEXT(B24;"hh:mm:ss"));FINDEN($H$1;TEXT(B24;"hh:mm:ss")));1;0));"";WENN(UND(FINDEN($G$1;TEXT(B24;"hh:mm:ss"));FINDEN($H$1;TEXT(B24;"hh:mm:ss")));1;0))
E24=SUMME(C24:D24)
L24=SUMME(M24:N24)
M24=WENN(ISTFEHLER(WENN(UND(FINDEN($I$1;TEXT(B24;"hh:mm:ss"));FINDEN($J$1;TEXT(B24;"hh:mm:ss")));1;0));"";WENN(UND(FINDEN($I$1;TEXT(B24;"hh:mm:ss"));FINDEN($J$1;TEXT(B24;"hh:mm:ss")));1;0))
N24=WENN(ISTFEHLER(WENN(UND(FINDEN($I$1;TEXT(A24;"hh:mm:ss"));FINDEN($J$1;TEXT(A24;"hh:mm:ss")));1;0));"";WENN(UND(FINDEN($I$1;TEXT(A24;"hh:mm:ss"));FINDEN($J$1;TEXT(A24;"hh:mm:ss")));1;0))
O24=WENN(ODER(E24>0;L24>0);1;"")
C25=WENN(ISTFEHLER(WENN(UND(FINDEN($G$1;TEXT(A25;"hh:mm:ss"));FINDEN($H$1;TEXT(A25;"hh:mm:ss")));1;0));"";WENN(UND(FINDEN($G$1;TEXT(A25;"hh:mm:ss"));FINDEN($H$1;TEXT(A25;"hh:mm:ss")));1;0))
D25=WENN(ISTFEHLER(WENN(UND(FINDEN($G$1;TEXT(B25;"hh:mm:ss"));FINDEN($H$1;TEXT(B25;"hh:mm:ss")));1;0));"";WENN(UND(FINDEN($G$1;TEXT(B25;"hh:mm:ss"));FINDEN($H$1;TEXT(B25;"hh:mm:ss")));1;0))
E25=SUMME(C25:D25)
L25=SUMME(M25:N25)
M25=WENN(ISTFEHLER(WENN(UND(FINDEN($I$1;TEXT(B25;"hh:mm:ss"));FINDEN($J$1;TEXT(B25;"hh:mm:ss")));1;0));"";WENN(UND(FINDEN($I$1;TEXT(B25;"hh:mm:ss"));FINDEN($J$1;TEXT(B25;"hh:mm:ss")));1;0))
N25=WENN(ISTFEHLER(WENN(UND(FINDEN($I$1;TEXT(A25;"hh:mm:ss"));FINDEN($J$1;TEXT(A25;"hh:mm:ss")));1;0));"";WENN(UND(FINDEN($I$1;TEXT(A25;"hh:mm:ss"));FINDEN($J$1;TEXT(A25;"hh:mm:ss")));1;0))
O25=WENN(ODER(E25>0;L25>0);1;"")
C26=WENN(ISTFEHLER(WENN(UND(FINDEN($G$1;TEXT(A26;"hh:mm:ss"));FINDEN($H$1;TEXT(A26;"hh:mm:ss")));1;0));"";WENN(UND(FINDEN($G$1;TEXT(A26;"hh:mm:ss"));FINDEN($H$1;TEXT(A26;"hh:mm:ss")));1;0))
D26=WENN(ISTFEHLER(WENN(UND(FINDEN($G$1;TEXT(B26;"hh:mm:ss"));FINDEN($H$1;TEXT(B26;"hh:mm:ss")));1;0));"";WENN(UND(FINDEN($G$1;TEXT(B26;"hh:mm:ss"));FINDEN($H$1;TEXT(B26;"hh:mm:ss")));1;0))
E26=SUMME(C26:D26)
L26=SUMME(M26:N26)
M26=WENN(ISTFEHLER(WENN(UND(FINDEN($I$1;TEXT(B26;"hh:mm:ss"));FINDEN($J$1;TEXT(B26;"hh:mm:ss")));1;0));"";WENN(UND(FINDEN($I$1;TEXT(B26;"hh:mm:ss"));FINDEN($J$1;TEXT(B26;"hh:mm:ss")));1;0))
N26=WENN(ISTFEHLER(WENN(UND(FINDEN($I$1;TEXT(A26;"hh:mm:ss"));FINDEN($J$1;TEXT(A26;"hh:mm:ss")));1;0));"";WENN(UND(FINDEN($I$1;TEXT(A26;"hh:mm:ss"));FINDEN($J$1;TEXT(A26;"hh:mm:ss")));1;0))
O26=WENN(ODER(E26>0;L26>0);1;"")
C27=WENN(ISTFEHLER(WENN(UND(FINDEN($G$1;TEXT(A27;"hh:mm:ss"));FINDEN($H$1;TEXT(A27;"hh:mm:ss")));1;0));"";WENN(UND(FINDEN($G$1;TEXT(A27;"hh:mm:ss"));FINDEN($H$1;TEXT(A27;"hh:mm:ss")));1;0))
D27=WENN(ISTFEHLER(WENN(UND(FINDEN($G$1;TEXT(B27;"hh:mm:ss"));FINDEN($H$1;TEXT(B27;"hh:mm:ss")));1;0));"";WENN(UND(FINDEN($G$1;TEXT(B27;"hh:mm:ss"));FINDEN($H$1;TEXT(B27;"hh:mm:ss")));1;0))
E27=SUMME(C27:D27)
L27=SUMME(M27:N27)
M27=WENN(ISTFEHLER(WENN(UND(FINDEN($I$1;TEXT(B27;"hh:mm:ss"));FINDEN($J$1;TEXT(B27;"hh:mm:ss")));1;0));"";WENN(UND(FINDEN($I$1;TEXT(B27;"hh:mm:ss"));FINDEN($J$1;TEXT(B27;"hh:mm:ss")));1;0))
N27=WENN(ISTFEHLER(WENN(UND(FINDEN($I$1;TEXT(A27;"hh:mm:ss"));FINDEN($J$1;TEXT(A27;"hh:mm:ss")));1;0));"";WENN(UND(FINDEN($I$1;TEXT(A27;"hh:mm:ss"));FINDEN($J$1;TEXT(A27;"hh:mm:ss")));1;0))
O27=WENN(ODER(E27>0;L27>0);1;"")
C28=WENN(ISTFEHLER(WENN(UND(FINDEN($G$1;TEXT(A28;"hh:mm:ss"));FINDEN($H$1;TEXT(A28;"hh:mm:ss")));1;0));"";WENN(UND(FINDEN($G$1;TEXT(A28;"hh:mm:ss"));FINDEN($H$1;TEXT(A28;"hh:mm:ss")));1;0))
D28=WENN(ISTFEHLER(WENN(UND(FINDEN($G$1;TEXT(B28;"hh:mm:ss"));FINDEN($H$1;TEXT(B28;"hh:mm:ss")));1;0));"";WENN(UND(FINDEN($G$1;TEXT(B28;"hh:mm:ss"));FINDEN($H$1;TEXT(B28;"hh:mm:ss")));1;0))
E28=SUMME(C28:D28)
L28=SUMME(M28:N28)
M28=WENN(ISTFEHLER(WENN(UND(FINDEN($I$1;TEXT(B28;"hh:mm:ss"));FINDEN($J$1;TEXT(B28;"hh:mm:ss")));1;0));"";WENN(UND(FINDEN($I$1;TEXT(B28;"hh:mm:ss"));FINDEN($J$1;TEXT(B28;"hh:mm:ss")));1;0))
N28=WENN(ISTFEHLER(WENN(UND(FINDEN($I$1;TEXT(A28;"hh:mm:ss"));FINDEN($J$1;TEXT(A28;"hh:mm:ss")));1;0));"";WENN(UND(FINDEN($I$1;TEXT(A28;"hh:mm:ss"));FINDEN($J$1;TEXT(A28;"hh:mm:ss")));1;0))
O28=WENN(ODER(E28>0;L28>0);1;"")
C29=WENN(ISTFEHLER(WENN(UND(FINDEN($G$1;TEXT(A29;"hh:mm:ss"));FINDEN($H$1;TEXT(A29;"hh:mm:ss")));1;0));"";WENN(UND(FINDEN($G$1;TEXT(A29;"hh:mm:ss"));FINDEN($H$1;TEXT(A29;"hh:mm:ss")));1;0))
D29=WENN(ISTFEHLER(WENN(UND(FINDEN($G$1;TEXT(B29;"hh:mm:ss"));FINDEN($H$1;TEXT(B29;"hh:mm:ss")));1;0));"";WENN(UND(FINDEN($G$1;TEXT(B29;"hh:mm:ss"));FINDEN($H$1;TEXT(B29;"hh:mm:ss")));1;0))
E29=SUMME(C29:D29)
L29=SUMME(M29:N29)
M29=WENN(ISTFEHLER(WENN(UND(FINDEN($I$1;TEXT(B29;"hh:mm:ss"));FINDEN($J$1;TEXT(B29;"hh:mm:ss")));1;0));"";WENN(UND(FINDEN($I$1;TEXT(B29;"hh:mm:ss"));FINDEN($J$1;TEXT(B29;"hh:mm:ss")));1;0))
N29=WENN(ISTFEHLER(WENN(UND(FINDEN($I$1;TEXT(A29;"hh:mm:ss"));FINDEN($J$1;TEXT(A29;"hh:mm:ss")));1;0));"";WENN(UND(FINDEN($I$1;TEXT(A29;"hh:mm:ss"));FINDEN($J$1;TEXT(A29;"hh:mm:ss")));1;0))
O29=WENN(ODER(E29>0;L29>0);1;"")
C30=WENN(ISTFEHLER(WENN(UND(FINDEN($G$1;TEXT(A30;"hh:mm:ss"));FINDEN($H$1;TEXT(A30;"hh:mm:ss")));1;0));"";WENN(UND(FINDEN($G$1;TEXT(A30;"hh:mm:ss"));FINDEN($H$1;TEXT(A30;"hh:mm:ss")));1;0))
D30=WENN(ISTFEHLER(WENN(UND(FINDEN($G$1;TEXT(B30;"hh:mm:ss"));FINDEN($H$1;TEXT(B30;"hh:mm:ss")));1;0));"";WENN(UND(FINDEN($G$1;TEXT(B30;"hh:mm:ss"));FINDEN($H$1;TEXT(B30;"hh:mm:ss")));1;0))
E30=SUMME(C30:D30)
L30=SUMME(M30:N30)
M30=WENN(ISTFEHLER(WENN(UND(FINDEN($I$1;TEXT(B30;"hh:mm:ss"));FINDEN($J$1;TEXT(B30;"hh:mm:ss")));1;0));"";WENN(UND(FINDEN($I$1;TEXT(B30;"hh:mm:ss"));FINDEN($J$1;TEXT(B30;"hh:mm:ss")));1;0))
N30=WENN(ISTFEHLER(WENN(UND(FINDEN($I$1;TEXT(A30;"hh:mm:ss"));FINDEN($J$1;TEXT(A30;"hh:mm:ss")));1;0));"";WENN(UND(FINDEN($I$1;TEXT(A30;"hh:mm:ss"));FINDEN($J$1;TEXT(A30;"hh:mm:ss")));1;0))
O30=WENN(ODER(E30>0;L30>0);1;"")
C31=WENN(ISTFEHLER(WENN(UND(FINDEN($G$1;TEXT(A31;"hh:mm:ss"));FINDEN($H$1;TEXT(A31;"hh:mm:ss")));1;0));"";WENN(UND(FINDEN($G$1;TEXT(A31;"hh:mm:ss"));FINDEN($H$1;TEXT(A31;"hh:mm:ss")));1;0))
D31=WENN(ISTFEHLER(WENN(UND(FINDEN($G$1;TEXT(B31;"hh:mm:ss"));FINDEN($H$1;TEXT(B31;"hh:mm:ss")));1;0));"";WENN(UND(FINDEN($G$1;TEXT(B31;"hh:mm:ss"));FINDEN($H$1;TEXT(B31;"hh:mm:ss")));1;0))
E31=SUMME(C31:D31)
L31=SUMME(M31:N31)
M31=WENN(ISTFEHLER(WENN(UND(FINDEN($I$1;TEXT(B31;"hh:mm:ss"));FINDEN($J$1;TEXT(B31;"hh:mm:ss")));1;0));"";WENN(UND(FINDEN($I$1;TEXT(B31;"hh:mm:ss"));FINDEN($J$1;TEXT(B31;"hh:mm:ss")));1;0))
N31=WENN(ISTFEHLER(WENN(UND(FINDEN($I$1;TEXT(A31;"hh:mm:ss"));FINDEN($J$1;TEXT(A31;"hh:mm:ss")));1;0));"";WENN(UND(FINDEN($I$1;TEXT(A31;"hh:mm:ss"));FINDEN($J$1;TEXT(A31;"hh:mm:ss")));1;0))
O31=WENN(ODER(E31>0;L31>0);1;"")
C32=WENN(ISTFEHLER(WENN(UND(FINDEN($G$1;TEXT(A32;"hh:mm:ss"));FINDEN($H$1;TEXT(A32;"hh:mm:ss")));1;0));"";WENN(UND(FINDEN($G$1;TEXT(A32;"hh:mm:ss"));FINDEN($H$1;TEXT(A32;"hh:mm:ss")));1;0))
D32=WENN(ISTFEHLER(WENN(UND(FINDEN($G$1;TEXT(B32;"hh:mm:ss"));FINDEN($H$1;TEXT(B32;"hh:mm:ss")));1;0));"";WENN(UND(FINDEN($G$1;TEXT(B32;"hh:mm:ss"));FINDEN($H$1;TEXT(B32;"hh:mm:ss")));1;0))
E32=SUMME(C32:D32)
L32=SUMME(M32:N32)
M32=WENN(ISTFEHLER(WENN(UND(FINDEN($I$1;TEXT(B32;"hh:mm:ss"));FINDEN($J$1;TEXT(B32;"hh:mm:ss")));1;0));"";WENN(UND(FINDEN($I$1;TEXT(B32;"hh:mm:ss"));FINDEN($J$1;TEXT(B32;"hh:mm:ss")));1;0))
N32=WENN(ISTFEHLER(WENN(UND(FINDEN($I$1;TEXT(A32;"hh:mm:ss"));FINDEN($J$1;TEXT(A32;"hh:mm:ss")));1;0));"";WENN(UND(FINDEN($I$1;TEXT(A32;"hh:mm:ss"));FINDEN($J$1;TEXT(A32;"hh:mm:ss")));1;0))
O32=WENN(ODER(E32>0;L32>0);1;"")
C33=WENN(ISTFEHLER(WENN(UND(FINDEN($G$1;TEXT(A33;"hh:mm:ss"));FINDEN($H$1;TEXT(A33;"hh:mm:ss")));1;0));"";WENN(UND(FINDEN($G$1;TEXT(A33;"hh:mm:ss"));FINDEN($H$1;TEXT(A33;"hh:mm:ss")));1;0))
D33=WENN(ISTFEHLER(WENN(UND(FINDEN($G$1;TEXT(B33;"hh:mm:ss"));FINDEN($H$1;TEXT(B33;"hh:mm:ss")));1;0));"";WENN(UND(FINDEN($G$1;TEXT(B33;"hh:mm:ss"));FINDEN($H$1;TEXT(B33;"hh:mm:ss")));1;0))
E33=SUMME(C33:D33)
L33=SUMME(M33:N33)
M33=WENN(ISTFEHLER(WENN(UND(FINDEN($I$1;TEXT(B33;"hh:mm:ss"));FINDEN($J$1;TEXT(B33;"hh:mm:ss")));1;0));"";WENN(UND(FINDEN($I$1;TEXT(B33;"hh:mm:ss"));FINDEN($J$1;TEXT(B33;"hh:mm:ss")));1;0))
N33=WENN(ISTFEHLER(WENN(UND(FINDEN($I$1;TEXT(A33;"hh:mm:ss"));FINDEN($J$1;TEXT(A33;"hh:mm:ss")));1;0));"";WENN(UND(FINDEN($I$1;TEXT(A33;"hh:mm:ss"));FINDEN($J$1;TEXT(A33;"hh:mm:ss")));1;0))
O33=WENN(ODER(E33>0;L33>0);1;"")
C38=WENN(ISTFEHLER(WENN(UND(FINDEN($G$1;TEXT(A38;"hh:mm:ss"));FINDEN($H$1;TEXT(A38;"hh:mm:ss")));1;0));"";WENN(UND(FINDEN($G$1;TEXT(A38;"hh:mm:ss"));FINDEN($H$1;TEXT(A38;"hh:mm:ss")));1;0))
D38=WENN(ISTFEHLER(WENN(UND(FINDEN($G$1;TEXT(B38;"hh:mm:ss"));FINDEN($H$1;TEXT(B38;"hh:mm:ss")));1;0));"";WENN(UND(FINDEN($G$1;TEXT(B38;"hh:mm:ss"));FINDEN($H$1;TEXT(B38;"hh:mm:ss")));1;0))
E38=SUMME(C38:D38)
L38=SUMME(M38:N38)
M38=WENN(ISTFEHLER(WENN(UND(FINDEN($I$1;TEXT(B38;"hh:mm:ss"));FINDEN($J$1;TEXT(B38;"hh:mm:ss")));1;0));"";WENN(UND(FINDEN($I$1;TEXT(B38;"hh:mm:ss"));FINDEN($J$1;TEXT(B38;"hh:mm:ss")));1;0))
N38=WENN(ISTFEHLER(WENN(UND(FINDEN($I$1;TEXT(A38;"hh:mm:ss"));FINDEN($J$1;TEXT(A38;"hh:mm:ss")));1;0));"";WENN(UND(FINDEN($I$1;TEXT(A38;"hh:mm:ss"));FINDEN($J$1;TEXT(A38;"hh:mm:ss")));1;0))
O38=WENN(ODER(E38>0;L38>0);1;"")
C41=WENN(ISTFEHLER(WENN(UND(FINDEN($G$1;TEXT(A41;"hh:mm:ss"));FINDEN($H$1;TEXT(A41;"hh:mm:ss")));1;0));"";WENN(UND(FINDEN($G$1;TEXT(A41;"hh:mm:ss"));FINDEN($H$1;TEXT(A41;"hh:mm:ss")));1;0))
D41=WENN(ISTFEHLER(WENN(UND(FINDEN($G$1;TEXT(B41;"hh:mm:ss"));FINDEN($H$1;TEXT(B41;"hh:mm:ss")));1;0));"";WENN(UND(FINDEN($G$1;TEXT(B41;"hh:mm:ss"));FINDEN($H$1;TEXT(B41;"hh:mm:ss")));1;0))
E41=SUMME(C41:D41)
L41=SUMME(M41:N41)
M41=WENN(ISTFEHLER(WENN(UND(FINDEN($I$1;TEXT(B41;"hh:mm:ss"));FINDEN($J$1;TEXT(B41;"hh:mm:ss")));1;0));"";WENN(UND(FINDEN($I$1;TEXT(B41;"hh:mm:ss"));FINDEN($J$1;TEXT(B41;"hh:mm:ss")));1;0))
N41=WENN(ISTFEHLER(WENN(UND(FINDEN($I$1;TEXT(A41;"hh:mm:ss"));FINDEN($J$1;TEXT(A41;"hh:mm:ss")));1;0));"";WENN(UND(FINDEN($I$1;TEXT(A41;"hh:mm:ss"));FINDEN($J$1;TEXT(A41;"hh:mm:ss")));1;0))
O41=WENN(ODER(E41>0;L41>0);1;"")
C42=WENN(ISTFEHLER(WENN(UND(FINDEN($G$1;TEXT(A42;"hh:mm:ss"));FINDEN($H$1;TEXT(A42;"hh:mm:ss")));1;0));"";WENN(UND(FINDEN($G$1;TEXT(A42;"hh:mm:ss"));FINDEN($H$1;TEXT(A42;"hh:mm:ss")));1;0))
D42=WENN(ISTFEHLER(WENN(UND(FINDEN($G$1;TEXT(B42;"hh:mm:ss"));FINDEN($H$1;TEXT(B42;"hh:mm:ss")));1;0));"";WENN(UND(FINDEN($G$1;TEXT(B42;"hh:mm:ss"));FINDEN($H$1;TEXT(B42;"hh:mm:ss")));1;0))
E42=SUMME(C42:D42)
L42=SUMME(M42:N42)
M42=WENN(ISTFEHLER(WENN(UND(FINDEN($I$1;TEXT(B42;"hh:mm:ss"));FINDEN($J$1;TEXT(B42;"hh:mm:ss")));1;0));"";WENN(UND(FINDEN($I$1;TEXT(B42;"hh:mm:ss"));FINDEN($J$1;TEXT(B42;"hh:mm:ss")));1;0))
N42=WENN(ISTFEHLER(WENN(UND(FINDEN($I$1;TEXT(A42;"hh:mm:ss"));FINDEN($J$1;TEXT(A42;"hh:mm:ss")));1;0));"";WENN(UND(FINDEN($I$1;TEXT(A42;"hh:mm:ss"));FINDEN($J$1;TEXT(A42;"hh:mm:ss")));1;0))
O42=WENN(ODER(E42>0;L42>0);1;"")
C57=WENN(ISTFEHLER(WENN(UND(FINDEN($G$1;TEXT(A57;"hh:mm:ss"));FINDEN($H$1;TEXT(A57;"hh:mm:ss")));1;0));"";WENN(UND(FINDEN($G$1;TEXT(A57;"hh:mm:ss"));FINDEN($H$1;TEXT(A57;"hh:mm:ss")));1;0))
D57=WENN(ISTFEHLER(WENN(UND(FINDEN($G$1;TEXT(B57;"hh:mm:ss"));FINDEN($H$1;TEXT(B57;"hh:mm:ss")));1;0));"";WENN(UND(FINDEN($G$1;TEXT(B57;"hh:mm:ss"));FINDEN($H$1;TEXT(B57;"hh:mm:ss")));1;0))
E57=SUMME(C57:D57)
L57=SUMME(M57:N57)
M57=WENN(ISTFEHLER(WENN(UND(FINDEN($I$1;TEXT(B57;"hh:mm:ss"));FINDEN($J$1;TEXT(B57;"hh:mm:ss")));1;0));"";WENN(UND(FINDEN($I$1;TEXT(B57;"hh:mm:ss"));FINDEN($J$1;TEXT(B57;"hh:mm:ss")));1;0))
N57=WENN(ISTFEHLER(WENN(UND(FINDEN($I$1;TEXT(A57;"hh:mm:ss"));FINDEN($J$1;TEXT(A57;"hh:mm:ss")));1;0));"";WENN(UND(FINDEN($I$1;TEXT(A57;"hh:mm:ss"));FINDEN($J$1;TEXT(A57;"hh:mm:ss")));1;0))
O57=WENN(ODER(E57>0;L57>0);1;"")
C68=WENN(ISTFEHLER(WENN(UND(FINDEN($G$1;TEXT(A68;"hh:mm:ss"));FINDEN($H$1;TEXT(A68;"hh:mm:ss")));1;0));"";WENN(UND(FINDEN($G$1;TEXT(A68;"hh:mm:ss"));FINDEN($H$1;TEXT(A68;"hh:mm:ss")));1;0))
D68=WENN(ISTFEHLER(WENN(UND(FINDEN($G$1;TEXT(B68;"hh:mm:ss"));FINDEN($H$1;TEXT(B68;"hh:mm:ss")));1;0));"";WENN(UND(FINDEN($G$1;TEXT(B68;"hh:mm:ss"));FINDEN($H$1;TEXT(B68;"hh:mm:ss")));1;0))
E68=SUMME(C68:D68)
L68=SUMME(M68:N68)
M68=WENN(ISTFEHLER(WENN(UND(FINDEN($I$1;TEXT(B68;"hh:mm:ss"));FINDEN($J$1;TEXT(B68;"hh:mm:ss")));1;0));"";WENN(UND(FINDEN($I$1;TEXT(B68;"hh:mm:ss"));FINDEN($J$1;TEXT(B68;"hh:mm:ss")));1;0))
N68=WENN(ISTFEHLER(WENN(UND(FINDEN($I$1;TEXT(A68;"hh:mm:ss"));FINDEN($J$1;TEXT(A68;"hh:mm:ss")));1;0));"";WENN(UND(FINDEN($I$1;TEXT(A68;"hh:mm:ss"));FINDEN($J$1;TEXT(A68;"hh:mm:ss")));1;0))
O68=WENN(ODER(E68>0;L68>0);1;"")
C84=WENN(ISTFEHLER(WENN(UND(FINDEN($G$1;TEXT(A84;"hh:mm:ss"));FINDEN($H$1;TEXT(A84;"hh:mm:ss")));1;0));"";WENN(UND(FINDEN($G$1;TEXT(A84;"hh:mm:ss"));FINDEN($H$1;TEXT(A84;"hh:mm:ss")));1;0))
D84=WENN(ISTFEHLER(WENN(UND(FINDEN($G$1;TEXT(B84;"hh:mm:ss"));FINDEN($H$1;TEXT(B84;"hh:mm:ss")));1;0));"";WENN(UND(FINDEN($G$1;TEXT(B84;"hh:mm:ss"));FINDEN($H$1;TEXT(B84;"hh:mm:ss")));1;0))
E84=SUMME(C84:D84)
L84=SUMME(M84:N84)
M84=WENN(ISTFEHLER(WENN(UND(FINDEN($I$1;TEXT(B84;"hh:mm:ss"));FINDEN($J$1;TEXT(B84;"hh:mm:ss")));1;0));"";WENN(UND(FINDEN($I$1;TEXT(B84;"hh:mm:ss"));FINDEN($J$1;TEXT(B84;"hh:mm:ss")));1;0))
N84=WENN(ISTFEHLER(WENN(UND(FINDEN($I$1;TEXT(A84;"hh:mm:ss"));FINDEN($J$1;TEXT(A84;"hh:mm:ss")));1;0));"";WENN(UND(FINDEN($I$1;TEXT(A84;"hh:mm:ss"));FINDEN($J$1;TEXT(A84;"hh:mm:ss")));1;0))
O84=WENN(ODER(E84>0;L84>0);1;"")
C85=WENN(ISTFEHLER(WENN(UND(FINDEN($G$1;TEXT(A85;"hh:mm:ss"));FINDEN($H$1;TEXT(A85;"hh:mm:ss")));1;0));"";WENN(UND(FINDEN($G$1;TEXT(A85;"hh:mm:ss"));FINDEN($H$1;TEXT(A85;"hh:mm:ss")));1;0))
D85=WENN(ISTFEHLER(WENN(UND(FINDEN($G$1;TEXT(B85;"hh:mm:ss"));FINDEN($H$1;TEXT(B85;"hh:mm:ss")));1;0));"";WENN(UND(FINDEN($G$1;TEXT(B85;"hh:mm:ss"));FINDEN($H$1;TEXT(B85;"hh:mm:ss")));1;0))
E85=SUMME(C85:D85)
L85=SUMME(M85:N85)
M85=WENN(ISTFEHLER(WENN(UND(FINDEN($I$1;TEXT(B85;"hh:mm:ss"));FINDEN($J$1;TEXT(B85;"hh:mm:ss")));1;0));"";WENN(UND(FINDEN($I$1;TEXT(B85;"hh:mm:ss"));FINDEN($J$1;TEXT(B85;"hh:mm:ss")));1;0))
N85=WENN(ISTFEHLER(WENN(UND(FINDEN($I$1;TEXT(A85;"hh:mm:ss"));FINDEN($J$1;TEXT(A85;"hh:mm:ss")));1;0));"";WENN(UND(FINDEN($I$1;TEXT(A85;"hh:mm:ss"));FINDEN($J$1;TEXT(A85;"hh:mm:ss")));1;0))
O85=WENN(ODER(E85>0;L85>0);1;"")
C86=WENN(ISTFEHLER(WENN(UND(FINDEN($G$1;TEXT(A86;"hh:mm:ss"));FINDEN($H$1;TEXT(A86;"hh:mm:ss")));1;0));"";WENN(UND(FINDEN($G$1;TEXT(A86;"hh:mm:ss"));FINDEN($H$1;TEXT(A86;"hh:mm:ss")));1;0))
D86=WENN(ISTFEHLER(WENN(UND(FINDEN($G$1;TEXT(B86;"hh:mm:ss"));FINDEN($H$1;TEXT(B86;"hh:mm:ss")));1;0));"";WENN(UND(FINDEN($G$1;TEXT(B86;"hh:mm:ss"));FINDEN($H$1;TEXT(B86;"hh:mm:ss")));1;0))
E86=SUMME(C86:D86)
L86=SUMME(M86:N86)
M86=WENN(ISTFEHLER(WENN(UND(FINDEN($I$1;TEXT(B86;"hh:mm:ss"));FINDEN($J$1;TEXT(B86;"hh:mm:ss")));1;0));"";WENN(UND(FINDEN($I$1;TEXT(B86;"hh:mm:ss"));FINDEN($J$1;TEXT(B86;"hh:mm:ss")));1;0))
N86=WENN(ISTFEHLER(WENN(UND(FINDEN($I$1;TEXT(A86;"hh:mm:ss"));FINDEN($J$1;TEXT(A86;"hh:mm:ss")));1;0));"";WENN(UND(FINDEN($I$1;TEXT(A86;"hh:mm:ss"));FINDEN($J$1;TEXT(A86;"hh:mm:ss")));1;0))
O86=WENN(ODER(E86>0;L86>0);1;"")
C101=WENN(ISTFEHLER(WENN(UND(FINDEN($G$1;TEXT(A101;"hh:mm:ss"));FINDEN($H$1;TEXT(A101;"hh:mm:ss")));1;0));"";WENN(UND(FINDEN($G$1;TEXT(A101;"hh:mm:ss"));FINDEN($H$1;TEXT(A101;"hh:mm:ss")));1;0))
D101=WENN(ISTFEHLER(WENN(UND(FINDEN($G$1;TEXT(B101;"hh:mm:ss"));FINDEN($H$1;TEXT(B101;"hh:mm:ss")));1;0));"";WENN(UND(FINDEN($G$1;TEXT(B101;"hh:mm:ss"));FINDEN($H$1;TEXT(B101;"hh:mm:ss")));1;0))
E101=SUMME(C101:D101)
L101=SUMME(M101:N101)
M101=WENN(ISTFEHLER(WENN(UND(FINDEN($I$1;TEXT(B101;"hh:mm:ss"));FINDEN($J$1;TEXT(B101;"hh:mm:ss")));1;0));"";WENN(UND(FINDEN($I$1;TEXT(B101;"hh:mm:ss"));FINDEN($J$1;TEXT(B101;"hh:mm:ss")));1;0))
N101=WENN(ISTFEHLER(WENN(UND(FINDEN($I$1;TEXT(A101;"hh:mm:ss"));FINDEN($J$1;TEXT(A101;"hh:mm:ss")));1;0));"";WENN(UND(FINDEN($I$1;TEXT(A101;"hh:mm:ss"));FINDEN($J$1;TEXT(A101;"hh:mm:ss")));1;0))
O101=WENN(ODER(E101>0;L101>0);1;"")
C102=WENN(ISTFEHLER(WENN(UND(FINDEN($G$1;TEXT(A102;"hh:mm:ss"));FINDEN($H$1;TEXT(A102;"hh:mm:ss")));1;0));"";WENN(UND(FINDEN($G$1;TEXT(A102;"hh:mm:ss"));FINDEN($H$1;TEXT(A102;"hh:mm:ss")));1;0))
D102=WENN(ISTFEHLER(WENN(UND(FINDEN($G$1;TEXT(B102;"hh:mm:ss"));FINDEN($H$1;TEXT(B102;"hh:mm:ss")));1;0));"";WENN(UND(FINDEN($G$1;TEXT(B102;"hh:mm:ss"));FINDEN($H$1;TEXT(B102;"hh:mm:ss")));1;0))
E102=SUMME(C102:D102)
L102=SUMME(M102:N102)
M102=WENN(ISTFEHLER(WENN(UND(FINDEN($I$1;TEXT(B102;"hh:mm:ss"));FINDEN($J$1;TEXT(B102;"hh:mm:ss")));1;0));"";WENN(UND(FINDEN($I$1;TEXT(B102;"hh:mm:ss"));FINDEN($J$1;TEXT(B102;"hh:mm:ss")));1;0))
N102=WENN(ISTFEHLER(WENN(UND(FINDEN($I$1;TEXT(A102;"hh:mm:ss"));FINDEN($J$1;TEXT(A102;"hh:mm:ss")));1;0));"";WENN(UND(FINDEN($I$1;TEXT(A102;"hh:mm:ss"));FINDEN($J$1;TEXT(A102;"hh:mm:ss")));1;0))
O102=WENN(ODER(E102>0;L102>0);1;"")
C103=WENN(ISTFEHLER(WENN(UND(FINDEN($G$1;TEXT(A103;"hh:mm:ss"));FINDEN($H$1;TEXT(A103;"hh:mm:ss")));1;0));"";WENN(UND(FINDEN($G$1;TEXT(A103;"hh:mm:ss"));FINDEN($H$1;TEXT(A103;"hh:mm:ss")));1;0))
D103=WENN(ISTFEHLER(WENN(UND(FINDEN($G$1;TEXT(B103;"hh:mm:ss"));FINDEN($H$1;TEXT(B103;"hh:mm:ss")));1;0));"";WENN(UND(FINDEN($G$1;TEXT(B103;"hh:mm:ss"));FINDEN($H$1;TEXT(B103;"hh:mm:ss")));1;0))
E103=SUMME(C103:D103)
L103=SUMME(M103:N103)
M103=WENN(ISTFEHLER(WENN(UND(FINDEN($I$1;TEXT(B103;"hh:mm:ss"));FINDEN($J$1;TEXT(B103;"hh:mm:ss")));1;0));"";WENN(UND(FINDEN($I$1;TEXT(B103;"hh:mm:ss"));FINDEN($J$1;TEXT(B103;"hh:mm:ss")));1;0))
N103=WENN(ISTFEHLER(WENN(UND(FINDEN($I$1;TEXT(A103;"hh:mm:ss"));FINDEN($J$1;TEXT(A103;"hh:mm:ss")));1;0));"";WENN(UND(FINDEN($I$1;TEXT(A103;"hh:mm:ss"));FINDEN($J$1;TEXT(A103;"hh:mm:ss")));1;0))
O103=WENN(ODER(E103>0;L103>0);1;"")
C104=WENN(ISTFEHLER(WENN(UND(FINDEN($G$1;TEXT(A104;"hh:mm:ss"));FINDEN($H$1;TEXT(A104;"hh:mm:ss")));1;0));"";WENN(UND(FINDEN($G$1;TEXT(A104;"hh:mm:ss"));FINDEN($H$1;TEXT(A104;"hh:mm:ss")));1;0))
D104=WENN(ISTFEHLER(WENN(UND(FINDEN($G$1;TEXT(B104;"hh:mm:ss"));FINDEN($H$1;TEXT(B104;"hh:mm:ss")));1;0));"";WENN(UND(FINDEN($G$1;TEXT(B104;"hh:mm:ss"));FINDEN($H$1;TEXT(B104;"hh:mm:ss")));1;0))
E104=SUMME(C104:D104)
L104=SUMME(M104:N104)
M104=WENN(ISTFEHLER(WENN(UND(FINDEN($I$1;TEXT(B104;"hh:mm:ss"));FINDEN($J$1;TEXT(B104;"hh:mm:ss")));1;0));"";WENN(UND(FINDEN($I$1;TEXT(B104;"hh:mm:ss"));FINDEN($J$1;TEXT(B104;"hh:mm:ss")));1;0))
N104=WENN(ISTFEHLER(WENN(UND(FINDEN($I$1;TEXT(A104;"hh:mm:ss"));FINDEN($J$1;TEXT(A104;"hh:mm:ss")));1;0));"";WENN(UND(FINDEN($I$1;TEXT(A104;"hh:mm:ss"));FINDEN($J$1;TEXT(A104;"hh:mm:ss")));1;0))
O104=WENN(ODER(E104>0;L104>0);1;"")
C105=WENN(ISTFEHLER(WENN(UND(FINDEN($G$1;TEXT(A105;"hh:mm:ss"));FINDEN($H$1;TEXT(A105;"hh:mm:ss")));1;0));"";WENN(UND(FINDEN($G$1;TEXT(A105;"hh:mm:ss"));FINDEN($H$1;TEXT(A105;"hh:mm:ss")));1;0))
D105=WENN(ISTFEHLER(WENN(UND(FINDEN($G$1;TEXT(B105;"hh:mm:ss"));FINDEN($H$1;TEXT(B105;"hh:mm:ss")));1;0));"";WENN(UND(FINDEN($G$1;TEXT(B105;"hh:mm:ss"));FINDEN($H$1;TEXT(B105;"hh:mm:ss")));1;0))
E105=SUMME(C105:D105)
L105=SUMME(M105:N105)
M105=WENN(ISTFEHLER(WENN(UND(FINDEN($I$1;TEXT(B105;"hh:mm:ss"));FINDEN($J$1;TEXT(B105;"hh:mm:ss")));1;0));"";WENN(UND(FINDEN($I$1;TEXT(B105;"hh:mm:ss"));FINDEN($J$1;TEXT(B105;"hh:mm:ss")));1;0))
N105=WENN(ISTFEHLER(WENN(UND(FINDEN($I$1;TEXT(A105;"hh:mm:ss"));FINDEN($J$1;TEXT(A105;"hh:mm:ss")));1;0));"";WENN(UND(FINDEN($I$1;TEXT(A105;"hh:mm:ss"));FINDEN($J$1;TEXT(A105;"hh:mm:ss")));1;0))
O105=WENN(ODER(E105>0;L105>0);1;"")
C106=WENN(ISTFEHLER(WENN(UND(FINDEN($G$1;TEXT(A106;"hh:mm:ss"));FINDEN($H$1;TEXT(A106;"hh:mm:ss")));1;0));"";WENN(UND(FINDEN($G$1;TEXT(A106;"hh:mm:ss"));FINDEN($H$1;TEXT(A106;"hh:mm:ss")));1;0))
D106=WENN(ISTFEHLER(WENN(UND(FINDEN($G$1;TEXT(B106;"hh:mm:ss"));FINDEN($H$1;TEXT(B106;"hh:mm:ss")));1;0));"";WENN(UND(FINDEN($G$1;TEXT(B106;"hh:mm:ss"));FINDEN($H$1;TEXT(B106;"hh:mm:ss")));1;0))
E106=SUMME(C106:D106)
L106=SUMME(M106:N106)
M106=WENN(ISTFEHLER(WENN(UND(FINDEN($I$1;TEXT(B106;"hh:mm:ss"));FINDEN($J$1;TEXT(B106;"hh:mm:ss")));1;0));"";WENN(UND(FINDEN($I$1;TEXT(B106;"hh:mm:ss"));FINDEN($J$1;TEXT(B106;"hh:mm:ss")));1;0))
N106=WENN(ISTFEHLER(WENN(UND(FINDEN($I$1;TEXT(A106;"hh:mm:ss"));FINDEN($J$1;TEXT(A106;"hh:mm:ss")));1;0));"";WENN(UND(FINDEN($I$1;TEXT(A106;"hh:mm:ss"));FINDEN($J$1;TEXT(A106;"hh:mm:ss")));1;0))
O106=WENN(ODER(E106>0;L106>0);1;"")


Excel Tabellen im Web darstellen >> Excel Jeanie HTML 4



hab dann mal noch den Test mit gleicher Kombi gemacht, ob auch richtig und nur einmal gezählt wird
und klappt auch.

Tabelle1

 ABCDEFGHIJKLMNO
100:00:0118:12:17  0 5757 0   
200:00:0218:12:18  0 96989698 0   
300:00:0318:12:19  0      0   
400:00:0418:12:20  0  9618  0   
4100:00:4118:12:57 11      11 1
5700:00:5718:13:131 1      1 11
10100:01:4118:13:57 11      11 1
11700:01:5718:14:131 1      1 11
16100:02:4118:14:57 11      11 1
17100:02:5118:15:07 11      11 1
17700:02:5718:15:131 1      1 11
18100:03:0118:15:17 11      11 1
19100:03:1118:15:27 11      11 1
20100:03:2118:15:37 11      11 1
21100:03:3118:15:47 11      11 1
22100:03:4118:15:57 11      11 1


Excel Tabellen im Web darstellen >> Excel Jeanie HTML 4

Nur würde ich gerne wissen, ob mein Ergebnis stimmt. was hast Du raus/oder ein anderer Excelfreund ?
Wäre nicht schlecht wenn man das mal mit ein paar Zahlenkombinationen testen könnte.
Ob mein Ergebnis dann mit Deinem identisch ist.
Vielleicht hast Du ja Lust das mal mit mir zu testen

Auch Dir einen schönen Sonntag ...
Gruß Matthias


  

Betrifft: Stopp! ich hab einen Fehler gefunden oT von: Matthias L
Geschrieben am: 19.02.2012 09:21:09




  

Betrifft: AW: Stopp! ich hab einen Fehler gefunden oT von: Ferdi
Geschrieben am: 20.02.2012 15:37:03

Matthias,

mit der Formel von Erich kommt folgendes für die Eingabe heraus:
Tabelle1

 CDE
2 Ziffer 1Ziffer 2
3Kombi157
4Kombi257
5   
6Treffer 19698 

Formeln der Tabelle
ZelleFormel
D6{=SUMME(1*(
ISTZAHL(FINDEN(D3;TEXT(ZEILE($1:$86400)/86400;"hms"))*FINDEN(E3;TEXT(ZEILE($1:$86400)/86400;"hms")))+
ISTZAHL(FINDEN(D4;TEXT(ZEILE($1:$86400)/86400;"hms"))*FINDEN(E4;TEXT(ZEILE($1:$86400)/86400;"hms")))*(D4<>"")*(E4<>"")>0)
)}
Enthält Matrixformel:
Umrandende
{ } nicht miteingeben,
sondern Formel mit STRG+SHIFT+RETURN abschließen!
Matrix verstehen


Excel Tabellen im Web darstellen >> Excel Jeanie HTML 4


  

Betrifft: Zifferkombis in Uhrzeiten - aktuelles von: Erich G.
Geschrieben am: 19.02.2012 18:20:41

Hi zusammen,
hier mein aktueller Stand:

 EFGH
11573028630286
1224  

Formeln der Tabelle
ZelleFormel
G11{=SUMME(1*(
ISTZAHL(FINDEN(E11;TEXT(ZEILE($1:$86400)/86400;"hms"))*FINDEN(F11;TEXT(ZEILE($1:$86400)/86400;"hms")))+
ISTZAHL(FINDEN(E12;TEXT(ZEILE($1:$86400)/86400;"hms"))*FINDEN(F12;TEXT(ZEILE($1:$86400)/86400;"hms")))*(E12<>"")*(F12<>"")>0)
)}
H11=ZZiff(E11;F11;E12;F12)
Enthält Matrixformel:
Umrandende
{ } nicht miteingeben,
sondern Formel mit STRG+SHIFT+RETURN abschließen!
Matrix verstehen

Und der Code dazu - mit einer Prozedur, mit der man sie die Treffer
als Liste ausgeben lassen kann:
Option Explicit

Function ZZiff(sZif1 As String, sZif2 As String, _
   Optional sZif3 As String, Optional sZif4 As String) As Long
   Dim zz As Long, sT As String

   If sZif3 = "" Or sZif4 = "" Then sZif3 = "x": sZif4 = "x"
   For zz = 1 To 86400
      sT = Format(zz / 86400#, "hms")
      If InStr(sT, sZif1) * InStr(sT, sZif2) _
       + InStr(sT, sZif3) * InStr(sT, sZif4) Then ZZiff = ZZiff + 1
   Next zz
End Function

Sub ZZiff_Liste()
   Dim zz As Long, ee As Long, sT As String
   ' ----------------------------------------- ermitteln, zählen
   ReDim arrE(1 To 86400)
   For zz = 1 To 86400
      sT = Format(zz / 86400#, "hms")
      If InStr(sT, 2) * InStr(sT, 4) + InStr(sT, 5) * InStr(sT, 7) Then _
         ee = ee + 1: arrE(ee) = zz
   Next zz
   ' ----------------------------------------- evtl. ausgeben
   If MsgBox("Es gibt " & ee & " Treffer." & vbLf & vbLf & _
      "Liste ausgeben?", vbYesNoCancel + vbQuestion) = vbYes Then
      ReDim arrOut(1 To ee, 1 To 2)
      For zz = 1 To ee
         arrOut(zz, 1) = arrE(zz)
         arrOut(zz, 2) = arrE(zz) / 86400#
      Next zz
      Cells(1, 1).Resize(ee, 2) = arrOut
   End If
End Sub
Rückmeldung wäre nett! - Grüße aus Kamp-Lintfort von Erich


  

Betrifft: AW: Zifferkombis in Uhrzeiten - aktuelles von: Ferdi
Geschrieben am: 20.02.2012 15:49:04

Danke an Erich, Sepp und alle Anderen für die Mühe!

Ich denke die Letzte Formel von Erich beantwortet meine Frage auf den Punkt:-)

Leider verschliesst sich mit die genau Herleitung, wie man wohl unschwer an meinem folgenden Versuch erkennen kann, die Formel für einige wenige Uhrzeiten zu modifizieren:

Tabelle1

 HIJK
200:00:00 Ziffer 1Ziffer 2
302:57:09Kombi 125
402:05:00Kombi 279
507:09:00   
6 Treffer0 

Formeln der Tabelle
ZelleFormel
J6{=SUMME(1*(
ISTZAHL(FINDEN(J3;TEXT(ZEILE(H2:H5)/4;"hms"))*FINDEN(K3;TEXT(ZEILE(H2:H5)/4;"hms")))+
ISTZAHL(FINDEN(J4;TEXT(ZEILE(H2:H5)/4;"hms"))*FINDEN(K4;TEXT(ZEILE(H2:H5)/4;"hms")))*(J4<>"")*(K4<>"")>0)
)}
Enthält Matrixformel:
Umrandende
{ } nicht miteingeben,
sondern Formel mit STRG+SHIFT+RETURN abschließen!
Matrix verstehen


Excel Tabellen im Web darstellen >> Excel Jeanie HTML 4





Wie Ihr seht, habe ich nach den Zeilenangaben durch 4 geteilt, da in der Originalformel ebenfalls durch die gesamte Zeilenanzahl geteilt wurde...das scheint jedoch nicht der eigentliche Sinn zu sein. Auch wenn ich durch 86400 teile, ändert sich am Ergebnis nichts!

Wie sähe die Formel in diesem Fall aus?

Was mich auch interessieren würde, wäre die Ausgabe der Ergebnisse. Auch hier hat Erich schon den VBA-code für geliefert, aber auch hier muss ich bei der konkreten Umsetzung leider passen.
Gibt es eine Möglichkeit die Ergebnisse anzuzeigen, die auch für Laien umsetzbar ist?
LG


  

Betrifft: AW: Zifferkombis in Uhrzeiten - aktuelles von: Ferdi
Geschrieben am: 20.02.2012 16:59:53

Das mit der Ergebnisausgabe bitte vergessen!
Ist garnicht so schwer das als Makro laufen zu lassen.

Der erste Teil der Frage würde mich dennoch interessieren, also die Anpassung der Formel an
kürzere Listen.


  

Betrifft: AW: Zifferkombis in Uhrzeiten - aktuelles von: Erich G.
Geschrieben am: 20.02.2012 19:12:18

Hi Ferdi,
wenn eine im Tabellenblatt stehende Liste von Zeigten durchsucht werden soll,
braucht man diese Uhrzeiten nicht per ZEILE() künstlich zu erzeugen. Dann ist die Formel einfacher:

 HIJK
200:00:00Kombi 125
302:57:09Kombi 279
402:05:00   
507:09:00Treffer3 

Formeln der Tabelle
ZelleFormel
J5{=SUMME(1*(
ISTZAHL(FINDEN(J2;TEXT(H2:H5;"hms"))*FINDEN(K2;TEXT(H2:H5;"hms")))+
ISTZAHL(FINDEN(J3;TEXT(H2:H5;"hms"))*FINDEN(K3;TEXT(H2:H5;"hms")))*(J3<>"")*(K3<>"")>0)
)}
Enthält Matrixformel:
Umrandende
{ } nicht miteingeben,
sondern Formel mit STRG+SHIFT+RETURN abschließen!
Matrix verstehen

Bei der langen Formel wurden alle Uhrzeigen eines Tages in Sekundenschritten generiert:

ZEILE(1:86400) sind alle Zeiten des Tages, angefangen bei der 1. Sekunde bis zur 86400. Sekunde -
dann ist wieder Mitternacht, denn ein Tag besteht aus 86400 Sekunden.

Schaut man sich mal ZEILE(50) an - das ist erst mal nur die Zahl 50.
Teilt man 50 durch 86400, bekommt man die Uhrzeit 00:00:50, also 50 Sek. nach Tagesbeginn.

ZEILE(60) = 60 dividiert durch 86400 ergibt 60 Sekunden = 1 Minute = 00:01:00

Durch 86400 teilt man, weil 1 Sekunde der 86400te Teil des Tages ist.
Wollte man 17 Stunden als Uhrzeit haben, würde man 17 durch 24 Teilen, weil eine Stunde der 24te Teil des Tages ist.

Aber wie gesagt: Wenn die Zeiten schon als Liste da stehen, ist gar nichts zu generieren.
Per TEXT(H2:H5;"hms") wird aus jeder Uhrzeit eine Zeichenkette erzeugt, die nur aus den Uhrzeitziffern besteht.
Und in dieser Zeichenkette wird dann gesucht.

Rückmeldung wäre nett! - Grüße aus Kamp-Lintfort von Erich