Microsoft Excel

Herbers Excel/VBA-Archiv

Doppelte Werte verhindern

Betrifft: Doppelte Werte verhindern von: Matzemalzbier
Geschrieben am: 02.11.2012 11:30:40

Hallo

In einer Excel Tabelle befindet sich eine Spalte für Positionsnummern.
Die Tabelle ist einem Formular nachempfunden. Das Formular besteht zunächst aus einem leeren Blatt welches vier Positionen vorhält. Diese sind aber noch nicht definiert. Also eine Zelle in der man z.B. die Ziffer 1 hineinschreibt.
Beispiel:
Zelle für die erste Position 1 oder A oder 1a
Zelle für die zweite Position 2 oder B oder 1b
Zelle für die ditte Position 3 oder C oder 2a
usw...
Dies möchte ich dem User frei entscheiden lassen.
Das einzige was nicht vorkommen darf ist, das mehrere Positionen den gleichen Wert erhalten.

Hat jemand eine Idee?
Mein Ansatz wäre zunächst eine Gültigkeitsprüfung oder wie es jetzt heißt Datenprüfung.
Aber wie?

Der Nutzer kann bei Bedarf weitere Blätter einfügen. (Dabei wird über VBA das erste Blatt kopiert und vom Inhalt bereinigt) In den eingefügten Blättern soll ebenfalls verhindert werden doppelte Positionsnummern zu vergeben.

Hinweis:
Office 2007 ist installiert, jedoch wird noch im Kompatibilitätsmodus gearbeitet.

Danke für euer Interesse.

  

Betrifft: AW: Doppelte Werte verhindern von: Nepumuk
Geschrieben am: 02.11.2012 12:54:15

Hallo Matzemalzbier,

Bereich markieren - Daten - Datenprüfung - Benutzerdefiniert - Formel: =ZÄHLENWENN($A$1:$A$20;A1)=1

$A$1:$A$20 ist der Bereich den du überwachen willst.
A1 ist die erste Zelle des Bereichs.

Die Gültigkeit kann aber durch reinkopieren überschrieben werden. Wenn das deine User machen, dann musst du das ganze per VBA abfangen. Beides (Gültigkeit und VBA) wird beim Kopieren der Tabelle mit kopiert.

Gruß
Nepumuk


  

Betrifft: AW: Doppelte Werte verhindern von: Matzemalzbier
Geschrieben am: 02.11.2012 15:24:45

Danke Nepumuk - Das ist es!!!

Zumindest in einer leeren Mappe funktioniert es so wie es soll.
In der Ziel-Tabelle greift diese Prüfung nicht. Da suche ich noch nach dem Grund...

Gruß, Matzemalzbier.


 

Beiträge aus den Excel-Beispielen zum Thema "Doppelte Werte verhindern"