Microsoft Excel

Herbers Excel/VBA-Archiv

Vergleich von verschiedenen Information und deren


Betrifft: Vergleich von verschiedenen Information und deren von: Kamjunke
Geschrieben am: 26.05.2017 13:59:57

Moin Moin,

ich habe das Problem das ich mit meiner WENN Funktion an die Grenzen von Excel gelangt bin. Ich möchte einen Buchstaben bzw eine Buchstabenkombination in ein Feld eingeben, darauf hin sollen die dazugehörigen Daten aus einem anderen Blatt geholt werden und mit einem Multiplikator der auf dem Hauptblatt noch händisch vermerkt wird verrechnet werden. Das ganze umfasst ca. 30 Informationen.
Meine Lösung bist jetzt:

=WENN(Z23=Kommentare!$B$3;Anlage1!AC23*Kommentare!$D$3;WENN(Z23=Kommentare!$B$4;AC23*Kommentare!$D$4; WENN(Z23=Kommentare!$B$5;AC23*Kommentare!$D$5;WENN(Z23=Kommentare!$B$6;AC23*Kommentare!$D$6; WENN(Z23=Kommentare!$B$7;AC23*Kommentare!$D$7;WENN(Anlage1!Z23=Kommentare!$B$8; WENN(Anlage1!AC23<50; Anlage1!AC23*Kommentare!$D$9;WENN(Anlage1!AC23>50; Anlage1!AC23*Kommentare!$D$8))))))))

Allerdings kann ich wie oben geschrieben nicht weitere Verknüpfungen hinzufügen. Die Funktion dessen ist genau das was ich möchte :)

Ich habe die Excel Befehle etwas durchgearbeitet mir fällt aber keiner auf der mich weiterbringt.

  

Betrifft: AW: Vergleich von verschiedenen Information und deren von: Ulf
Geschrieben am: 26.05.2017 14:17:56

Hallo Kamjunke,
statt WENNs verwende ich SVERWEISe,
das macht es übersichtlicher und flexibler.

Ulf


  

Betrifft: AW: Vergleich von verschiedenen Information und deren von: Daniel
Geschrieben am: 26.05.2017 14:25:54

Heißt ich müsste für jede Möglichkeit die es gibt in dem Feld einen SVERWEIS erstellen? Wenn ich die Definition von der Funktion richtig verstehe sucht Sie in einer Tabelle ob das was ich da eingegeben habe vorhanden ist und gibt dann einen definierten Wert zurück in das Feld?


  

Betrifft: AW: Vergleich von verschiedenen Information und deren von: Ulf
Geschrieben am: 26.05.2017 14:46:11

Ein Beispiel:
=Wenn(Tag="Montag";"Pizza";WENN(Tag="Dienstag";"Schnitzel"; ... ))

mit den SVERWEIS
1. Spalte die Wochentage zB. Montag in C5 (im obigen Fall =Kommentare!$B$3 bis $B$8 )
2. Spalte jeweils rechts daneben "Pizza" u.s.w. (im obigen Fall =Anlage1!!AC23*Kommentare!$D$3)

und dann:
=SVERWEIS(Tag;C5:D11;1;FALSCH)

Wenn man den Zellen und Bereichen Namen verpasst wird's transparenter.


  

Betrifft: AW: Vergleich von verschiedenen Information und deren von: Daniel
Geschrieben am: 26.05.2017 15:05:14

Okay, danke schon mal für die schnelle Reaktion!
Ich probiere mal meine Auswahl hier zu posten, glaube das ich mich nicht gut genug ausgedrückt habe was ich machen möchte und wo mein Problem liegt...

|gG |gL
2 |24,96 |24,96 |
6 |73,32 |73,32 |
10 |127,92 |127,92 |
16 |166,92 |166,92 |
20 |226,2 |226,2 |
32 |413,4 |413,4 |
35 |460,2 |460,2 |
40 |483,6 |483,6 |
50 |717,6 |717,6 |
63 |858 |858 |
B | | |7,8
C | | |15,6
D | | |31,2
E | | |9,75
Z | | |4,68
K >50 | | |21,84
K <50 | | |18,72

Aus den Spalten- und Zeilenüberschriften soll das passende Sicherungsmodell ausgewählt werden die Infos welches verbaut ist muss in 2 Felden getrennt eingetragen werden und das Ergebnis der Suche mit einem eingetragenen Parameter multipliziert und zur Anzeige gebracht werden. (PS die Tabelle ist nicht vollständig)


  

Betrifft: AW: Vergleich von verschiedenen Information und deren von: Ulf
Geschrieben am: 26.05.2017 15:19:17

was wird ausgewählt? Spalte gG?


  

Betrifft: AW: Vergleich von verschiedenen Information und deren von: Daniel
Geschrieben am: 26.05.2017 15:20:18

gG & gL mit 2 bis 63 oder die Großbuchstaben


  

Betrifft: AW: Vergleich von verschiedenen Information und deren von: Ulf
Geschrieben am: 26.05.2017 15:25:32

|gG |gL
2 |24,96 |24,96 |
6 |73,32 |73,32 |
10 |127,92 |127,92 |

Wenn ich 6 auswähle muss ich auch 73,32 wählen?
Gibt es die Zahl 6 auch mit einer anderen Kombination al 73,32?
Und Was muss womit multipliziert werden?
Ulf


  

Betrifft: AW: Vergleich von verschiedenen Information und deren von: Daniel
Geschrieben am: 26.05.2017 15:28:24

Genau als Beispiel für die gG 6 muss dann die 73,32 gewählt werden und mit einer Zahl multipliziert werden. Das gG o.ä. steht in einer eigenen Zelle und die 6 auch im Hauptdokument.


  

Betrifft: AW: Vergleich von verschiedenen Information und deren von: Ulf
Geschrieben am: 26.05.2017 15:32:50

Hallo Daniel,
ich kann dich nocht so recht verstehen.

Ulf


  

Betrifft: AW: Vergleich von verschiedenen Information und deren von: Ulf
Geschrieben am: 26.05.2017 15:33:17

Hallo Daniel,
ich kann dich nocht so recht verstehen.

Ulf


  

Betrifft: AW: Vergleich von verschiedenen Information und deren von: Daniel
Geschrieben am: 26.05.2017 15:37:00

Ich werde das mal Schematisch aufarbeiten und dann Montag hochladen, glaube sonst versteht das Problem so schnell keiner. :)


  

Betrifft: AW: Vergleich von verschiedenen Information und deren von: Daniel
Geschrieben am: 26.05.2017 15:47:50

https://www.herber.de/bbs/user/113806.doc

Ich hoffe man kann es erkennen und nachvollziehen...

Schönes Wochenende erstmal :)


Beiträge aus den Excel-Beispielen zum Thema "Vergleich von verschiedenen Information und deren "