Microsoft Excel

Herbers Excel/VBA-Archiv

Differenz bilden > Unterschiedl. Zeilen | Herbers Excel-Forum


Betrifft: Differenz bilden > Unterschiedl. Zeilen von: Stef@n
Geschrieben am: 03.02.2010 20:29:24

Hallo Excel-Freunde

ich versuche mal mein Glück in diesem tollen Forum:
Ich habe eine Aufstellung (Inhaltsverzeichnis) eines Buches mit Angabe
der Kapitel-numerierung, Bezeichnung und Seiten-Angabe
Ich möchte jetzt via Formel ?!? errechnen, wieviel Seiten
bis zum nächsten Kapitel vorhanden sind.
Aber nur dann, wenn in einer bestimmten Spalte ein Wert eingetragen ist.

Zur Verdeutlichung habe ich mal eine Datei "hochgeladen"
https://www.herber.de/bbs/user/67740.xls

Ich freue mich sehr auf eine Antwort :)
Mit bestem Gruß
Stef@n

  

Betrifft: AW: Differenz bilden > Unterschiedl. Zeilen von: Daniel
Geschrieben am: 03.02.2010 20:50:42

Hi
das geht z.B. mit dieser Formel in Zelle E228:

=WENN(F228="";"";BEREICH.VERSCHIEBEN(E228;ZÄHLENWENN(B:B;A228)-1;0)-E228)

Spalte B muss lückenlos ausgefüllt sein.

Gruß, Daniel


  

Betrifft: brilliant ! besten Dank Daniel :)) OT von: Stef@n
Geschrieben am: 03.02.2010 21:10:05




Beiträge aus den Excel-Beispielen zum Thema "Differenz bilden > Unterschiedl. Zeilen "