Microsoft Excel

Herbers Excel/VBA-Archiv

SUMIF mit Referenz aus Drop Down Menü



Excel-Version: 5.0/7.0

Betrifft: SUMIF mit Referenz aus Drop Down Menü
von: Danny S.
Geschrieben am: 05.06.2002 - 16:06:14

Ich habe folgendes Problem:
in Mappe1 habe ich eine Datenbasis hinterlegt, z.B. Getränkename in Spalte A und Preis in Spalte B.

auf Mappe2 habe ich in Spalte B eine SUMIF Funktion eingebaut die den Preis für das Getränk das ich in Spalte A auf Mappe2 manuell eintippe eingebe automatisch aus Mappe 1 heraussucht. Funktioniert Prima.

Problem: Ich möchte auf Mappe 2 die Namen der Getränke nicht manuell eintippen sondern per Drop Down Menü das auf die Database verknüpft ist die Namen heraussuchen. Das Drop-Down Menü kann ich problemlos bauen, aber die SUMIF-Funktion aktzeptiert die Zelle in der das Drop-Down Menü liegt aber nicht.

Wie kann ich den ausgewählten Wert aus dem Drop-Down Menü in einer Formel (z.B. SUMIF) verwerten?

Thanks
Danny

  

Re: SUMIF mit Referenz aus Drop Down Menü
von: Hans W. Herber
Geschrieben am: 06.06.2002 - 07:57:53

Hallo Danny,

DropDown-Felder in XL5/7 liefern den bei 1 beginnenden Zeilenindex der Auswahl in die verknüpfte Zelle. Über diesen Zeilenindex kann man dann auf den Wert der Ursprungstabelle zugreifen.
Beispiel:
- Quelldaten in Mappe Test.xls, Blatt Tabelle1, Spalte A

Formelzugriff, wenn die mit dem DropDown-Feld verknüpfte Zelle A1 ist:
=SVERWEIS(A1; [test.xls]Tabelle1!A:A;1;0)

hans