Microsoft Excel

Herbers Excel/VBA-Archiv

Vergleich zweier Spalten und dann summieren

Betrifft: Vergleich zweier Spalten und dann summieren von: Shayev
Geschrieben am: 12.09.2014 13:47:46

Hallo zusammen,

ich möchte gerne in meiner Beispieltabelle Spalte A und C vergleichen, wenn in Spalte A, Test1 drin steht und in C Spalte 1, dann soll aus Spalte F,H und K die Summe ermittelt werden!! Kann man das auch dynamisch machen, wenn z.B meine Spalte A um eine weitere Test1 und Spalte C um eine weitere 1 Eingabe erweitert werden!
Hat jemand einen Vorschlag, vielen Dank im Voraus!

Gruß Shayev

https://www.herber.de/bbs/user/92596.xlsx

  

Betrifft: AW: Vergleich zweier Spalten und dann summieren von: Shayev
Geschrieben am: 12.09.2014 13:54:37

Des Weiteren soll in Spalte A geguckt werden ob ein gleicher Text mehrmals vorkommt und vergleichen ob in Spalte C gleicher Wert falls ja die Summe daraus!! Es sollte dynamisch funktionieren!

Danke und Gruß Shayev


  

Betrifft: AW: Vergleich zweier Spalten und dann summieren von: yummi
Geschrieben am: 12.09.2014 13:56:50

Hallo Shayev,

da wo du das Ergebnis sehen willst für Zeile 2
=WENN(UND(A2="Test1";C2=1)=WAHR;SUMME(F2;H2;K2);"")

Das kannst du dann für alle Zeilen runterziehen.

Gruß
yummi


  

Betrifft: AW: Vergleich zweier Spalten und dann summieren von: Shayev
Geschrieben am: 12.09.2014 14:15:57

Hallo Yummi,

danke für den Hinweis, ich möchte es aber über einen Bereich machen, nicht für jede Zelle einzeln. Danke und Gruß Shayev


  

Betrifft: AW: Vergleich zweier Spalten und dann summieren von: yummi
Geschrieben am: 12.09.2014 14:19:40

Hallo Shayev,

mach mal folgendes: schreib die formel in M2, dann markierst du M2 und fasst dann den quadratischen Punkt in der Zelle (unten links) mit gedrückter Maustaste an und ziehe nach unten solange du willst.

Gruß
yummi


  

Betrifft: AW: Vergleich zweier Spalten und dann summieren von: Shayev
Geschrieben am: 12.09.2014 14:32:51

Danke Yummi, vielleicht habe ich mich nicht richtig ausgdrückt!! Kann man das per VBA realisieren, die Werte werden in die Tabelle per VBA eingespeist, das heißt ich weiß von vorne herein nicht, welcher Textinhalt in Spalte A ist, und ob dieser öfter vorkommt, falls ja soll in Spalte C geguckt werden ob der wert jeweils für den gleichen Textinhalt in Spalte A gleich ist!! Und dann erst für die entsprechenden Spalten F,H und K soll die Summe ermittelt werden! Vielleicht mit Matrizen irgendwie?

Danke und Gruß Shayev


  

Betrifft: SUMMEWENNS nicht zusammenhängender Spalten von: WF
Geschrieben am: 12.09.2014 14:18:23

Hi,

=SUMME(SUMMEWENNS(INDIREKT({"F:F";"H:H";"K:K"});A:A;"Test1";C:C;1))

Salut WF


  

Betrifft: AW: SUMMEWENNS nicht zusammenhängender Spalten von: Shayev
Geschrieben am: 12.09.2014 19:07:36

Danke WF,

das ist schon sehr hilfreich!! ))

Gruß Shayev


 

Beiträge aus den Excel-Beispielen zum Thema "Vergleich zweier Spalten und dann summieren"