Microsoft Excel

Herbers Excel/VBA-Archiv

Sverweis Text aus Tab-Namen

Betrifft: Sverweis Text aus Tab-Namen von: Werner
Geschrieben am: 07.10.2014 12:22:18

Hallo Excel-Freund

mittels der Formel
=TEIL(ZELLE("Dateiname";$A$1);FINDEN("]";ZELLE("Dateiname";$A$1))+1;31)*1
schreibe ich in eine Zelle z.B. D5 den Tab-Namen (hier als Zahl)
Mittels der Formel in E5
=Sverweis(d5;Bereich;3;falsch)
hole ich mir aus eine anderen Tabelle in einem anderen TAB
einen speziellen Text (die Tabelle dort ist als Name "Bereich" definiert.
Wenn der TabName jedoch ein Text ist - funktioniert das ganze nicht
zB Test1 gibt mir die erste Formel #Wert aus
jetzt lösche ich in der 1. Formel das *1 an Ende - und schon steht in D5 "Test1"
Nur leider funktioniert dann die Formel in E5 nicht - ebenfalls #Wert

Gibt es eine Möglichkeit, dass der Sverweis in Zelle E5 auch dann funktioniert
wenn die TabNamen als Text eingefügt sind (und nicht als Zahl)?

Freu mich auf einen Tip
Gruss Werner

  

Betrifft: so wie Du schreibst, ... von: neopa C (paneo)
Geschrieben am: 07.10.2014 12:29:22

Hallo Namensvetter,

... vergleichst Du offensichtlich teilweise Zahlenwerte mit Textwerten bzw. umgekehrt. Du musst Dich auf eins festlegen. Die erste Spalte in Deinem "BEREICH" sollte Textwerte sein.


Gruß Werner
.. , - ...


  

Betrifft: AW: Sverweis Text aus Tab-Namen von: Hajo_Zi
Geschrieben am: 07.10.2014 12:30:04

Hallo Werner,

bei mir geht es, was wohl daran liegt das meine Datei vielleicht anders aussieht.

Tabelle1

 GH
7Tabelle12

verwendete Formeln
Zelle Formel Bereich N/A
G7=TEIL(ZELLE("Dateiname";$A$1);FINDEN("]";ZELLE("Dateiname";$A$1))+1;31)  
H7=SVERWEIS(G7;Makro1!D:F;2;0)  
Excel-Inn.de
Hajo-Excel.de
XHTML-Tabelle zur Darstellung in Foren, einschl. der neuen Funktionen ab Version 2007
Add-In-Version 18.17 einschl. 64 Bit



GrußformelHomepage


 

Beiträge aus den Excel-Beispielen zum Thema "Sverweis Text aus Tab-Namen"