Herbers Excel-Forum - das Archiv

SVERWEIS Probleme mit ~

Bild

Betrifft: SVERWEIS Probleme mit ~
von: Alex
Geschrieben am: 23.09.2003 15:04:16
Hallo zusammen,

ich habe ein kniffliges SVERWEIS Problem. Ich verweise von einer Zelle mit dem Inhalt EVO~ auf eine Tabelle, die in der ersten Spalte ebenfalls EVO~ enthält. Durch das Zeichen ~ funktioniert aber der SVERWEIS aus irgend einem Grund nicht mehr (wenn ich das ~ lösche funktioniert der Verweis). Es handelt sich um viele Tabellen mit Werten, die aus drei Buchstaben und ~ bestehen und oft aktuallisiert werden müssen. Ich möchte daher weder per Hand noch per Makro die ~ jedesmal entfernen. Kann ich einen SVERWEIS irgendwie mit LINKS(Zelle,3) oder so kombinieren oder gibt es einen anderen Weg (wie gesagt möglichst nicht in VBA)???

Danke für die Hilfe
Alex

Bild

Betrifft: AW: SVERWEIS Probleme mit ~
von: LotharP
Geschrieben am: 23.09.2003 15:13:13
Hi Alex,

vieleicht über bearbeiten ersetzen ~ durch ""?
Kann sein das du "~" schreiben mußt.
Ich weiss auch nicht ob das Zeichen auf beiden Seiten steht (Quelle und Chart).
Hoffe das hilft zunächst mal weiter.

Gruß

Lothar
Bild

Betrifft: Problem besteht noch
von: Alex
Geschrieben am: 23.09.2003 15:24:21
das Zeichen "~" steht sowohl in der Quelldatei als auch in dem Bericht, in dem ich den sverweis verwende. Die Inhalte der Quelldatei werden oft überkopiert, wobei sich die Reihenfolge der Bezeichnungen EVA~ oder EVO~ etc auch verändern können und da es sich zusätzlich um ca. 30 Quellblätter handelt ist es auch sehr umständlich, die ~ über Bearbeiten-ersetzen zu ersetzen (hohes Fehlerpotential, kann man ja auch mal schnell vergessen)

Ich weiß auch nicht, was es für ein Problem mit dem ~ ist, z.B. mit dem Zeichen # funktioniert es wieder....
Bild

Betrifft: AW: Problem besteht noch
von: Jörg Gradert
Geschrieben am: 23.09.2003 15:29:39
Hallo Alex,
merkwürdiges Problem, der SVERWEIS() nimmt die ~ aus der Referenzzelle nicht mit.
Schreibe darum
=SVERWEIS(A1&"~";...
dann geht es

Gruss Jörg
Bild

Betrifft: AW: Problem besteht noch
von: Jörg Gradert
Geschrieben am: 23.09.2003 15:31:24
Hallo Alex,
merkwürdiges Problem, der SVERWEIS() nimmt die ~ aus der Referenzzelle nicht mit.
Schreibe darum
=SVERWEIS(A1&"~";...
dann geht es

Gruss Jörg
Bild

Betrifft: generelles Problem!?
von: Alex
Geschrieben am: 23.09.2003 15:43:47
Danke, das Hilft. Sehr kreative Lösung, wäre ich nicht drauf gekommen.
Da schein Excel ja wohl ein Problem zu haben. Ich lasse mir den Sverweis über den Formelassistenten anzeigen, er schreibt folgendes:

Suchkriterium : "EVO~~"
Matrix : "EVO~" ....etc

aber es funktioniert komischerweise trotzdem! Obwohl er mein Suchkriterium mit dem ~~ doch eigentlich nicht finden dürfte!?!?
Nochmal danke für die Lösung
Alex
Bild

Betrifft: AW: SVERWEIS Probleme mit ~
von: Gert Seler
Geschrieben am: 24.09.2003 03:37:06
Hallo Alex,
könnte es sein, das die Daten importiert werden?
Das "Wellenzeichen" oder "Unendlichzeichen" zeigt an, das die Bezeichnung
"EVO" oder "EVA" nur die ersten 3 Textzeichen (Char) eines längeren Wortes sind.
Beim einpflegen der Daten sollte dieses Zeichen ausgefiltert werden.
Frage mal einen informatik-Spezi in der Firma.
mfg
Gert
 Bild
Excel-Beispiele zum Thema " SVERWEIS Probleme mit ~"
SVERWEIS auf geschlossene Arbeitsmappe aus Makro aufrufen Benutzerdefinierte SVERWEIS-Funktion über mehrere Bereiche
Arbeitszeittabelle und SVERWEIS-Formel Zugriff über SVERWEIS() auf eine Artikelliste
SVERWEIS-Formel über mehrere Fundstellen SVERWEIS-, WVERWEIS- und Matrixformel-Beispiele
SVERWEIS, WVERWEIS, INDEX, VERGLEICH und Zielwertsuche Zweidimensionale Matrix mit der SVERWEIS-Funktion durchsuchen
Hyperlinks zu SVERWEIS-Bezugstabellen anlegen SVERWEIS als Ereignisprozedur