Microsoft Excel

Herbers Excel/VBA-Archiv

datums-format in if-bedingung

    Betrifft: datums-format in if-bedingung von: sas
    Geschrieben am: 26.08.2003 18:12:03

    tach auch;)
    folgende aufgabenstellung:
    in einer if-abfrage soll ein fest vorgegebenes datum(feiertag) mit einem als datum formatiertem wert aus exel verglichen werden(tt.mm.jjjj).

    wie muß der in der if-bedingung einzugebende wert formatiert sein??
    bsp. A1 soll bei übereinstimmung mit dem vorgegebenen datum um 1 tag erhöht werden

    wenn(A1=????;A1+1)
    die werte 12.03.2003 und "12.03.2003" für ???? eingestetzt funktionieren bisher nicht(was bei letzterem auch kein wunder is, is ja n string;))

    klasse daß ihr so schnell antwortet und ne schönen tag noch.

    sas

      


    Betrifft: AW: datums-format in if-bedingung von: andre
    Geschrieben am: 26.08.2003 18:16:07

    hallo sas,
    im prinzip so:
    =WENN(DATWERT("26.08.2003")=HEUTE();"ja";"nein")
    gruss andre


      


    Betrifft: AW: datums-format in if-bedingung von: sas
    Geschrieben am: 26.08.2003 19:38:03

    vielen dank;)
    war eigentlich ganz einfach und auch nachvollziehbar, jetzt wo ichs lese;)

    sas