Live-Forum - Die aktuellen Beiträge
Anzeige
Archiv - Navigation
1208to1212
Aktuelles Verzeichnis
Verzeichnis Index
Übersicht Verzeichnisse
Vorheriger Thread
Rückwärts Blättern
Nächster Thread
Vorwärts blättern
Anzeige
HERBERS
Excel-Forum (Archiv)
20+ Jahre Excel-Kompetenz: Von Anwendern, für Anwender
Inhaltsverzeichnis

Formel für Zwischensumme

Formel für Zwischensumme
emma
Hallo zusammen,
eine kleine Frage hätte ich die wahrscheinlich recht simpel ist.
Ich habe eine Tabelle mit 3 verschiedenen Personen. Jede Person hat eine ID, jede Person hat mehrere Einträge in der Tabelle.
Person Spalte B (Datum)
123 16.4
123 17.4
124 13.4
125 13.4
125 11.4
125 11.4
Jetzt würde ich gerne per Formel Zwischenergebnisse für jede Person in Spalte C einfügen, so dass ich sehe wie oft eine Person an verschiedenen Tagen Einträge vorgenommen hat.
Also bei ID 123 steht dann 2, bei ID 125 1 usw.
Bin ich da mit summe wenn auf dem richtigen Weg?
Vielen Dank im voraus!
Viele Grüße
emma

6
Beiträge zum Forumthread
Beiträge zu diesem Forumthread

Betreff
Benutzer
Anzeige
AW: Formel für Zwischensumme
16.04.2011 23:10:40
CitizenX
Hallo Emma,
es ist besser eine Bsp Datei anzuhängen ,in der hervorgeht was ,wann ,wie ..geschehen,berechnet .. werden soll.
Ich hab mal versucht dein Wunsch zu rekonstruieren ,schau mal:
https://www.herber.de/bbs/user/74436.xls
Grüße
Steffen
AW: Formel für Zwischensumme
17.04.2011 00:23:13
emma
Hallo Steffen,
vielen Dank für deine rasche Antwort.
Ich müsste aber in einer Zelle sehen wie viele verschiedene Tage eine Person eingetragen hat. Also die Nummer 125 in deinem Beispiel hat ja an zwei Tagen teilgenommen, da bräuchte ich dann eine 2, wohingegen die 123 nur eine 1 bekommt da sie ja zweimal den 17.4. hat.
Danke!
Viele Grüße
Claudia
Anzeige
Summenprodukt & Zählenwenn ...
17.04.2011 08:27:21
Matthias
Hallo Claudia
hier mal eine etwas andere Variante:
Tabelle1

 ABCDEFG
112316.04.2011 Bsp:123124125
212317.04.2011 11.04.2011  2
312413.04.2011 12.04.2011   
412513.04.2011 13.04.2011 11
512511.04.2011 14.04.2011   
612511.04.2011 15.04.2011   
7   16.04.20111  
8   17.04.20111  
9   Ergebnis:212
10       
11    Optionen-Ansicht
12    Nullwerte ausgeschalten.

Formeln der Tabelle
ZelleFormel
E2=SUMMENPRODUKT(($A$1:$A$6=E$1)*($B$1:$B$6=$D2))
F2=SUMMENPRODUKT(($A$1:$A$6=F$1)*($B$1:$B$6=$D2))
G2=SUMMENPRODUKT(($A$1:$A$6=G$1)*($B$1:$B$6=$D2))
E3=SUMMENPRODUKT(($A$1:$A$6=E$1)*($B$1:$B$6=$D3))
F3=SUMMENPRODUKT(($A$1:$A$6=F$1)*($B$1:$B$6=$D3))
G3=SUMMENPRODUKT(($A$1:$A$6=G$1)*($B$1:$B$6=$D3))
E4=SUMMENPRODUKT(($A$1:$A$6=E$1)*($B$1:$B$6=$D4))
F4=SUMMENPRODUKT(($A$1:$A$6=F$1)*($B$1:$B$6=$D4))
G4=SUMMENPRODUKT(($A$1:$A$6=G$1)*($B$1:$B$6=$D4))
E5=SUMMENPRODUKT(($A$1:$A$6=E$1)*($B$1:$B$6=$D5))
F5=SUMMENPRODUKT(($A$1:$A$6=F$1)*($B$1:$B$6=$D5))
G5=SUMMENPRODUKT(($A$1:$A$6=G$1)*($B$1:$B$6=$D5))
E6=SUMMENPRODUKT(($A$1:$A$6=E$1)*($B$1:$B$6=$D6))
F6=SUMMENPRODUKT(($A$1:$A$6=F$1)*($B$1:$B$6=$D6))
G6=SUMMENPRODUKT(($A$1:$A$6=G$1)*($B$1:$B$6=$D6))
E7=SUMMENPRODUKT(($A$1:$A$6=E$1)*($B$1:$B$6=$D7))
F7=SUMMENPRODUKT(($A$1:$A$6=F$1)*($B$1:$B$6=$D7))
G7=SUMMENPRODUKT(($A$1:$A$6=G$1)*($B$1:$B$6=$D7))
E8=SUMMENPRODUKT(($A$1:$A$6=E$1)*($B$1:$B$6=$D8))
F8=SUMMENPRODUKT(($A$1:$A$6=F$1)*($B$1:$B$6=$D8))
G8=SUMMENPRODUKT(($A$1:$A$6=G$1)*($B$1:$B$6=$D8))
E9=ZÄHLENWENN(E2:E8;">0")
F9=ZÄHLENWENN(F2:F8;">0")
G9=ZÄHLENWENN(G2:G8;">0")


Excel Tabellen im Web darstellen >> Excel Jeanie HTML 4


Userbild
Anzeige
AW: Summenprodukt & Zählenwenn ...
17.04.2011 09:41:45
emma
Hallo Matthias,
vielen Dank, das sieht nicht schlecht aus:-) Gebe es denn auch eine Möglichkeit es direkt in Spalte C zu sehen? Und zwar immer da wo der letzte Eintrag des TN ist? Für 123 dann z.B. in C2 eine 2? Das Problem ist das ich viele IDs und Tage habe und ich es dann gerne direkt sehen würde, danke!
Viele Grüße
Zählen unterschiedliche mit Bedingung
17.04.2011 11:14:38
Erich
Hi,
wie wäre es damit:
 ABC
1PersonDatumAnzahl
212316.04.2011 
312317.04.20112
412413.04.20111
512513.04.2011 
612511.04.2011 
712511.04.20112

Formeln der Tabelle
ZelleFormel
C2=WENN(ZÄHLENWENN(A:A;A2)>ZÄHLENWENN(A$1:A2;A2); ""; SUMMENPRODUKT((VERGLEICH(B$1:B$12&A$1:A$12;B$1:B$12&A$1:A$12;0)=ZEILE($1:$12)*(B$1:B$12<>"")*(A$1:A$12=A2))*1))

Die Formel stammt im Prinzip von http://www.excelformeln.de/formeln.html?welcher=334
(Die Formel in http://www.excelformeln.de/formeln.html?welcher=418 stimmt m. E. nicht...)
Rückmeldung wäre nett! - Grüße von Erich aus Kamp-Lintfort
Anzeige
AW: Zählen unterschiedliche mit Bedingung
17.04.2011 11:58:05
emma
Super, das klappt, vielen Dank:-)

300 Forumthreads zu ähnlichen Themen

Anzeige
Anzeige
Anzeige

Beliebteste Forumthreads (12 Monate)

Anzeige

Beliebteste Forumthreads (12 Monate)

Anzeige
Anzeige
Anzeige