Microsoft Excel

Herbers Excel/VBA-Archiv

Formel in Sheet via VBA eingeben


Betrifft: Formel in Sheet via VBA eingeben von: ray
Geschrieben am: 19.04.2017 15:55:28

Hallo,

ich bin zu blöd:

Range("n12").Select
ActiveCell.FormulaLocal = "=WENN(ISTFEHLER(SVERWEIS(A12;RL02!$A$8:$Z$800;13;FALSCH));"";WENN(SVERWEIS(A12;RL02!$A$8:$Z$800;13;FALSCH)="";"";SVERWEIS(A12;RL02!$A$8:$Z$800;13;FALSCH)))"

Das soll die Formel einfach in die Zelle N12 schreiben. Funzt aber nicht...

Idee?


Viele Grüße aus Hamburg kalt, lustlos.....

Ray

  

Betrifft: AW: Formel in Sheet via VBA eingeben von: Werner
Geschrieben am: 19.04.2017 15:59:03

Hallo Ray,

Die "Gänsefüßchen" innerhalb der Formel musst du verdoppeln.
"=WENN(ISTFEHLER(SVERWEIS(A12;RL02!$A$8:$Z$800;13;FALSCH));"""";WENN(SVERWEIS(A12;RL02!$A$8:$Z$800;13;FALSCH)="""";"""";SVERWEIS(A12;RL02!$A$8:$Z$800;13;FALSCH)))"

Gruß Werner


  

Betrifft: AW: Formel in Sheet via VBA eingeben von: ChrisL
Geschrieben am: 19.04.2017 15:59:29

hi Ray

Die Anführungszeichen innerhalb vom Text-String verdoppeln und bei der Gelegenheit noch gleich das Select eliminieren.

Range("n12").FormulaLocal = "=WENN(ISTFEHLER(SVERWEIS(A12;RL02!$A$8:$Z$800;13;FALSCH));"""";WENN(SVERWEIS(A12;RL02!$A$8:$Z$800;13;FALSCH)="""";"""";SVERWEIS(A12;RL02!$A$8:$Z$800;13;FALSCH)))"

cu
Chris


  

Betrifft: AW: Formel in Sheet via VBA eingeben von: ChrisL
Geschrieben am: 19.04.2017 17:08:01

Der Vollständigkeit halber noch die "internationale" Version, welche Sprachunabhängig funktioniert:
Range("n12").Formula = "=IF(ISERROR(VLOOKUP(A12,RL02!$A$8:$Z$800,13,FALSE)),"""",IF(VLOOKUP(A12,RL02!$A$8:$Z$800,13,FALSE)="""", """",VLOOKUP(A12,RL02!$A$8:$Z$800,13,FALSE)))"


  

Betrifft: AW: Füttere das mal in den Makrorekorder… von: Sheldon
Geschrieben am: 19.04.2017 16:00:17

Hallo Ray,

…dann wirst du sehen, wieso das nicht so klappt, wie Du erwartest. Die Formelsprache ist in VBA immer englisch, im Excel wird dann aber die deutsche Sprache gezeigt (oder welche Sprachversion jeweils genutzt wird). Das ergibt auch Sinn, damit ein Makro auch mit einem anderen Sprachsatz stets funktioniert.


Gruß
Sheldon


  

Betrifft: AW: Füttere das mal in den Makrorekorder… von: Werner
Geschrieben am: 19.04.2017 16:04:27

Hallo Sheldon,

er benutzt .FormulaLocal und das "spricht" Deutsch bei einer deutschen Version.

Gruß Werner


  

Betrifft: Danke, ich chk das morgen.... von: ray
Geschrieben am: 19.04.2017 16:25:17

ot


  

Betrifft: Supi funzt. Vielen herzlichen Dank!!!! oT von: ray
Geschrieben am: 20.04.2017 09:44:48

oT


  

Betrifft: AW: Gerne u. Danke für die Rückmeldung. von: Werner
Geschrieben am: 20.04.2017 09:50:37




  

Betrifft: Rückmeldung gehört zum guten Ton dazu :-) von: ray
Geschrieben am: 20.04.2017 10:13:31

ot


  

Betrifft: schon :-D, leider nicht bei allen :-C o.w.T. von: Werner
Geschrieben am: 20.04.2017 10:28:10




Beiträge aus den Excel-Beispielen zum Thema "Formel in Sheet via VBA eingeben"