Herbers Excel-Forum - das Archiv

Formel in VBA ?



Excel-Version: 97
nach unten

Betrifft: Formel in VBA ?
von: Rainer K.


Geschrieben am: 03.05.2002 - 16:22:03

Hallo Forum !
Hat jemand eine Ahnung wie man nachstehende Formel in VBA ausdrückt ?

=WENN(MONAT($B$1)=MONAT(B3);B3;""))

Gruß
Rainer


nach oben   nach unten

Re: Formel in VBA ?
von: andreas e


Geschrieben am: 03.05.2002 - 16:29:24

kannst es über makro aufzeichen auch sehen :

ActiveCell.FormulaR1C1 = "=IF(MONTH(R1C2)=MONTH(R[2]C[-1]),R[2]C[-1],"""")"

gruß
andreas e
http://www.skripteundaufgaben.de viele kostenlose downloads zu EXCEL und mehr !

nach oben   nach unten

Re: Formel in VBA ?
von: rainer
Geschrieben am: 03.05.2002 - 16:31:05

Hallo Rainer! Bitteschön

"=IF(MONTH($B$1)=MONTH(B3),B3,"")
Gruß
rainer


nach oben   nach unten

Re: Formel in VBA ?
von: Rainer K.
Geschrieben am: 03.05.2002 - 16:35:26

Hallo ihr beiden !

Ich danke euch vielmals für eure schnelle Hilfe.

Gruß
Rainer


 nach oben

Excel-Beispiele zum Thema "Formel in VBA ?"
Anzeigen von Werten und Formeln Zeile einfügen und Formeln und Werte übernehmen
Formeln mit Zelladressen speichern Zeilenumbruch in Formel erzwingen
Aktueller Arbeitsblattname in Formel Variable in Formel einbauen
Ein Zeichen in einer Formel suchen Variable in Excel-Formel einbauen.
Summenformel unter Zahlenreihe eintragen Arbeitszeittabelle und SVERWEIS-Formel